Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

4000 switch gives the foll error messg when I associate from one AP to anot

When I associate from one access-point (AP 350) to another my switch complains that it sees mac address in the CAM table in another port and then starts dropping packets.

The error message is

%SYS-4-P2_WARN (x1)</B>: Host [mac addr] is flapping between port [dec/dec] and port

[dec/dec]

3 REPLIES
Cisco Employee

Re: 4000 switch gives the foll error messg when I associate from

For wireless devices moving around, they will basically being handoff between different AP's due to the signal strength detected to ensure the best communication result. While the mobile devices are doing this, they will cause the MAC addresses to be registered to different ports due to the handoff.

When this occurred often, the switch will start to complain about the MAC addresses moving between different ports in the CAM table. This is a normal behavior of a switch, as it uses the CAM table to make forward decision more efficiently instead of flooding it to all ports. The default aging time is 300 sec, and once the device moved to another port, it will be learned on the other port and the original entry would be flushed out. All communication will stop to this MAC for 15 seconds upon receiving this message.

New Member

Re: 4000 switch gives the foll error messg when I associate from

Thanks for the reply. That is exactly what I am facing. (i.e no communication for about 15 seconds). Since this is a ip phone deployment using wireless I cannot afford no communication for about 15 seconds as I would loose the call. Anything on the switch we can do so that the CAM table for that port (or in worst case scenario the vlan) can be flushed immediately (and not wait for the minimum aging timer) so that switch starts forwarding frames immediately on the new port and I have minimum loss of packets(if any). Any help or pointers will be really appreciated.

New Member

Re: 4000 switch gives the foll error messg when I associate from

Hi.

we have exactly the same problem with our 4006 in combination with APs in the warehouse. That is also due to the roaming of the clients to different APs!

But I am not sure if tweaking on the mac timer is a good idea! Maybe in your scenario changing the aging time would be a solution, but you can only change it for a VLAN, not for certain ports!

100
Views
0
Helpful
3
Replies