Cisco Support Community
Community Member

4012 Rom Monitor

WS-X4012 always boots into ROM Monitor,I tried to boot it up with some documents listed in WWW.CISCO.COM,but it's no use.How can I boot it up?


Re: 4012 Rom Monitor

Can you show what comes up when you plug a console cable into the console port and boot up?

There are many reasons why a Sup module might boot into ROMMON so more information would help me to work out what might be wrong.



Community Member

Re: 4012 Rom Monitor

rommon 1 > set

PS1=rommon ! >















rommon 2 > show boot

BOOT variable = cat4000.5-5-21.bin,1;

Configuration reg is 0x10f

ignore-config: disabled

console baud: 9600

boot: image specified by the boot system commands

autoboot state = 2

autoboot count = 0

autoboot sptr = 0

The system will now begin autobooting.

Unable to determine first file name on device "bootflash:"

Resetting system...

0:00.516774: No gateway has been specified

0:00.518501: ig0: 00:04:28:4c:c3:fe is

0:00.519110: netmask:

0:00.519448: broadcast:

0:00.519800: gateway:

WS-X4012 bootrom version 6.1(5), built on 2003.03.19 16:59:08

H/W Revisions: Meteor: 4 Comet: 10 Board: 2

Supervisor MAC addresses: 00:04:28:4c:c0:00 through 00:04:28:4c:c3:ff (1024 addresses)

Installed memory: 64 MB

Testing LEDs.... done!

rommon 1 >


there is no image in it,I tried to load it up from a tftpServer,and the SUP load from an image from tftpserver but still boot into ROM Monitor.But I can't copy an image into bootflash: using tftpserver.


Re: 4012 Rom Monitor

Can you please answer these further questions:

1. What command did you use to copy from a tftp server?

2. What error did you get get when trying to copy?

3. Have you got an ethernet cable plugged into the management ethernet port on the supervisor (to the left of the console port), and have you got a link light?

Now, please try the following:

1. type "unset boot"

2. Change your IP address to and the default gateway. You MUST set a default gateway for it to work and this is where I think your problem is. You can do this by:

set interface fa1

set ip route default

3. Type "ping"

***Can you ping this IP?***

4. Try your IOS copy again.

Hope this helps.

Community Member

Re: 4012 Rom Monitor sure that ur able to connect with the tftp server,or u can do one thing,u load the iamge file at one workstaion and give the following command.

ROMMON > boot filename [ip-address]

Manually boots the router from a network file.

In the following example, a router is manually booted from the network


Re: 4012 Rom Monitor

Add the following command to your config , "set boot system flash bootflash:cat4000.5-5-21 " . This will put the correct boot statement in . If it goes to rommon first , then issue command "boot bootflash:cat4000.5-5-21" , then once booted up add set boot system flash bootflash:cat4000.5-5-21 .

Community Member

Re: 4012 Rom Monitor

I set my PC,and UP the TFTP service,

ROMMON> boot cat4000.5-5-21.bin

****The TFTP Service indecates that the Switch Downloaded the image cat4000.5-5-21.bin from my TFTPSERVER****

when the download-process finished,it couldn't boot up,returned to ROMMON>.There is something like that the image was loaded into RAM but not running.

Community Member

Re: 4012 Rom Monitor

I describe my process:

I set my PC IP:,

ROMMON>set ip interface me1

ROMMON>set ip route default


Then I UP my tftp Service on my PC,put the image cat4000.5-5-21.bin at the right DIRECTION.And connected the link to ME ethernet port.

ROMMON>ping is alive.

ROMMON>boot cat4000.5-5-21.bin

****The 4003 loads the image,this can be see at TFTP service console.******

It seemed that 4003 loads the image into RAM,but can't boot up.It returns to ROMMON>


Re: 4012 Rom Monitor

Please show whole output from the console from when you typed the commands in.

Can you please type:

dir bootflash:


boot bootflash:cat4000.5-5-21.bin

(you need to put bootflash: in front of the image name)

Hope this helps


Community Member

Re: 4012 Rom Monitor

ROMMON>dir bootflash:

there is nothing.No image in bootflash:

CreatePlease to create content