Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

4503 Layer 3 connected to a 2600 router

We have a 4503 configured as a core switch. Our parent company had installed a T1 for intanet back to the HQ. At the time we were running a switched network, no gateways only proxy to the internet. So we decided at the time is was worth putting it on a a NATed Win2k box. Things have changed since then with the 4503. We are starting to segment out the lan. Heres where I run into problems. The 2600 router is owned and managed by our parent company.

IP of router is 10.177.0.2 /24

IP of g3/24 on the 4503 is 10.177.0.3 /24

IP of VLAN1 on 4503 is 10.0.30.31/22

I have configured the switch as this.

int g3/24

no switch port

ip address 10.177.0.3 255.255.255.0

descerption uplink to HQ

speed auto

int vlan1

ip address 10.0.30.31 255.255.240.0

ip route 10.46.0.0 255.255.255.0 10.177.0.2

(this is the intranet segemnt we need to connect to.)

ip route 0.0.0.0 0.0.0.0 10.0.16.55 (firewall)

___________________________________________________________

Firewall/Proxy has the following:

route add 10.46.0.0 mask 255.255.255.0 10.0.30.31

____________________________________________________________

I know these route are correct, cause if I take off the 10.46.0.0 255.255.255.0 10.177.0.2 route and do a tracert route from my PC it will hit the firewall then hit the 4503 and then bounce back to the firewall.

____________________________________________________________

Now, heres the problem I have.

When I plug the router in to 4503, the line protocol comes up and line is ready. If I do a sh int status g3/24 it shows connected.

but I cannot pass any traffic through the line. (keep in mind that our parent company owns this and nothing except WWW is allowed through it, so I am not even able to ping the ethernet card on the router.

I have tried everyhting I can think of plus some more creative ideas, all have failed. But if I go back to the PC and hook the T1back into it I can pass traffic.

I know that they are not filtering by mac-address cause I can swap out NIC cards in the win2k box and still get there.

Am I missing somthing?

Like I have said I tried everything I can think of, Clear ARP on 4503 and unplug the 2600 for a minute to clear that ARP table. tried no cdp on the g3/24

The only difference I can see between the PC and the 4503 is the PC has a default gateway to the router. The 4503 has a route staement since its not the default gateway. From what I have worked with routing, route statements should do the trick. Never seen one where it didnt work, unless it was the wrong route.

Any ideas, please let me know.

Thanks

Anthony

1 REPLY
Community Member

Re: 4503 Layer 3 connected to a 2600 router

Two things you might check. One check the ip address of the corporate router as it may have been mistyped. Second thing to check is the firewall to make sure that there are no filters set up to not allow any HTTP traffic. Last resort try another port on the switch.

86
Views
0
Helpful
1
Replies
CreatePlease to create content