Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

6500 - subinterface vlan X interface vlan config

What are the pros and cons between configuring one 6500 port usint subinterface comands or creating all vlans and assign them to one port.

So far I know:

- doing sub-int you can no create the same vlan number in any other port

- sub int don't allow vlan access list.

But what about performance, security...

here it is the configs:

interface GigabitEthernet1/3

description physical interface

no ip address

!

interface GigabitEthernet1/3.998

description subinterface for vlan 998

encapsulation dot1Q 998

ip address 98.98.98.98 255.255.255.0

no cdp enable

!

interface GigabitEthernet1/3.999

description subinterface for vlan 999

encapsulation dot1Q 999

ip address 99.99.99.99 255.255.255.0

no cdp enable

++++++++++++++++++++++++++++++++++++++++

vlan 98-99

interface Vlan 98

description int vlan 98

ip address 98.98.98.98 255.255.255.0

no cdp enable

interface Vlan 99

description int vlan 99

ip address 99.99.99.99 255.255.255.0

no cdp enable

interface GigabitEthernet3/1

desc trunk 98 99

switchport

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 98-99

switchport mode trunk

no ip address

no cdp enable

Thanks

Marcelo

  • Other Network Infrastructure Subjects
5 REPLIES
Cisco Employee

Re: 6500 - subinterface vlan X interface vlan config

If it is just for routing, I would go with Interface VLANs and not sub-interfaces. Also, you did not mention what kind of Supervisor/IOS you have. 12.2(18)SXE is the first release to support sun-interfaces on a layer 3 interface:

http://www.cisco.com/univercd/cc/td/doc/product/lan/cat6000/122sx/swcg/layer3.htm#wp1040486

New Member

Re: 6500 - subinterface vlan X interface vlan config

Just for flexibility, I craete VLAN interfaces for actual VLANs where server or users are going to be connected. As you stated, then I can put that VLAN on any port on the switch and still perform L3 services.

For router connections on a 6500 I create a routed interface where the physical interface has the IP address. But since it is a router connection I have never really needed to do multiple VLANs on those interfaces.

Just some basic rules I follow for design/implementation. Keeps the LAN flexible and efficient.

-Mark

Silver

Re: 6500 - subinterface vlan X interface vlan config

I use VLAN simply if i wanted to do RSTP and not routing protocols. Allows me to have better redundancy through ether channels, flex-links etc.... In short, VLANs allow you to augment BW sub-interfaces have BW equal to the main interface.

New Member

Re: 6500 - subinterface vlan X interface vlan config

Hi!

Thanks for the feedback.

I am planning to run MPLS and BGP.

I am using a sup 720 with 12.2.18(sx)

Thanks

Re: 6500 - subinterface vlan X interface vlan config

Hi

You wont be able to run MPLS with sup720 u either require sup 7203B or sup 7203BXL.

do refer this link for more info..

http://cisco.com/en/US/products/hw/switches/ps708/products_data_sheet09186a0080159856.html

regds

1405
Views
0
Helpful
5
Replies