Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

7206/NPE-G1 performance problem

We're experiencing a performance problem with our 7200/NPE-G1 router. When doing an FTP session across the router, we noticed that performance was only 30-50 Mbit. When the test hosts are on the same network, performance is the full 100 Mbit the hosts are connected with. We also tried connecting the test hosts directly to the router interfaces, one interface for eac host, in a plain vanilla configuration. Performance was the same. When using simple bandwidth testtools like NetCPS the results are similar.

When testing in the same way over a 6500/MSFC2 performance was line speed, as expected.

MRTG monitoring seems to indicate that aggregate performance is higher than this, but we've been unable to get a single end to end test to go higher than 50 Mbps.

The router is configured to use CEF, and as far as we can tell, CEF is working properly.

Does anyone know what could be causing this? I would expect the NPE-G1 to be capable of handing 100 Mbps...

Below the configuration as we use it. G0/1 and g0/2 were used only for end-to-end testing, the .1q test used vlans 202 and 203 on g0/3

!

ip subnet-zero

ip multicast-routing

ip cef

!

buffers small permanent 150

buffers small max-free 300

buffers small min-free 50

buffers middle permanent 40

buffers middle min-free 20

buffers big permanent 60

buffers big min-free 10

!

!

interface GigabitEthernet0/1

ip address 172.16.1.1 255.255.255.0

duplex auto

speed auto

media-type rj45

no negotiation auto

!

interface GigabitEthernet0/2

ip address 172.16.2.1 255.255.255.0

duplex auto

speed auto

media-type rj45

no negotiation auto

!

interface GigabitEthernet0/3

ip address 10.110.2.251 255.255.0.0

no ip proxy-arp

ip pim dense-mode

duplex full

speed 1000

media-type rj45

no negotiation auto

standby 1 ip 10.110.2.90

standby 1 priority 110

standby 1 preempt

!

!

interface GigabitEthernet0/3.202

description Interface naar LAN202_HK

encapsulation dot1Q 202

ip address 10.202.2.251 255.255.0.0

ip helper-address 10.201.2.53

ip helper-address 10.211.2.53

ip helper-address 10.203.1.10

no ip redirects

no ip proxy-arp

ip pim dense-mode

standby 202 ip 10.202.2.90

standby 202 priority 110

standby 202 preempt

!

interface GigabitEthernet0/3.203

description Interface naar LAN203_HK

encapsulation dot1Q 203

ip address 10.203.2.251 255.255.0.0

ip helper-address 10.201.2.53

ip helper-address 10.211.2.53

ip helper-address 10.214.1.2

ip helper-address 10.213.1.11

no ip redirects

no ip proxy-arp

ip pim dense-mode

standby 203 ip 10.203.2.90

standby 203 priority 110

standby 203 preempt

!

!

ip classless

!

3 REPLIES
Bronze

Re: 7206/NPE-G1 performance problem

I would suggest you to try changing the " buffers big permanent "parameter. This might help you. .I am aware that some images of 7200 support two PCI buses , one for odd slot and one for even slots. So if you overload any one of the bus the performance degrades. If you have two cards put one on odd and other in even, or you might have to upgrade the image on the router.

New Member

Re: 7206/NPE-G1 performance problem

I assume your results were using a single FTP session to the host machine ? What happens if you open up 2 or more FTP sessions simultaneously.

ie, If you are topping out at 50Mbit with 1 session and you open another, does the first drop to 25Mbit or do both of them actually run at around 50Mbit.

The issue could just be the latency of the TCP conversation.

= K

New Member

Re: 7206/NPE-G1 performance problem

Your last comment made me check that, and related issues out. As it turns out, the issue was TCP windows size, with an appropriately large windows speed was wire speed.

Thanks.

198
Views
0
Helpful
3
Replies
CreatePlease to create content