Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

802.1q between 3524XL and Xylan Omniswitch

Hi

I want to configure a 802.1q trunk between a 3524 and a Xylan Omniswitch.

On the cisco, I configured the Trunk ENcapsulation dot1q. It doesn't work. I guess the vlan 1 on the Cisco could be the problem.

Have anyone already done such a configuration?

Thks for your help

JP

5 REPLIES
Silver

Re: 802.1q between 3524XL and Xylan Omniswitch

JP,

VLAN 1 should not be an issue unless you are running into a Native VLAN issue with your Xylan switch. Without your config it's hard to say what could be the problem. here is an example one for you of a Dot1q trunk.

interface GigabitEthernet6/1

no ip address

speed nonegotiate

switchport

switchport trunk encapsulation dot1q

switchport mode trunk.

Hope that helps,

Don

Bronze

Re: 802.1q between 3524XL and Xylan Omniswitch

Are you having the problem with vlan one or all the vlans..

New Member

Re: 802.1q between 3524XL and Xylan Omniswitch

Hi

The problem is with all the vlans. I'd like to have a trunk with vlan 2 & 3. My config for the cisco is here:

interface GigabitEthernet0/1

no autonegociation

switchport trunk encapsulation dot1q

switchport trunk native vlan 2

switchport mode trunk

Thanks for your help

JP

Bronze

Re: 802.1q between 3524XL and Xylan Omniswitch

Please make sure the native vlan is matched due to the reason, we never encapsulate packets on the native vlan.

Try to create some dunnmu vlan is the native vlan to see if that resolve the issue. May be the X switch is also encapsulating on the native VLAN.

Silver

Re: 802.1q between 3524XL and Xylan Omniswitch

If you need to tag the Native VLAN also, so all VLANs are tagged, you can use the following:

vlan dot1q tag native

This command is discussed in the following URL:

http://www.cisco.com/univercd/cc/td/doc/product/lan/c3550/1219ea1/3550cr/cli3.htm#xtocid8

Possibly the Xlan has no Native (untagged) vlan concept that is your problem???

Hope this helps,

Don

227
Views
0
Helpful
5
Replies
CreatePlease login to create content