Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

802.1q over transparent bridging

Hello,

I configured two 1710 routers for transparent bridging. The routers are connected with a tunnel, which also part of the bridge. I have tested the configuration and it works oke (see configuration below).

But the routers need to be installed between two switches with trunk interfaces 802.1q (see below). For transparent bridging I thought I increase the MTU on the interfaces. I tried to increase the MTU of the interfaces to 1524 but the router gives the message

% Interface Ethernet0 does not support user settable mtu.

What I’m I doing wrong? who can give me some tips?

Regards,

Michiel

SWITCH

| (802.1q trunk)

|

| (bridge interface)

ROUTER

: (bridge interface)

:

: (bridge interface)

ROUTER

| (bridge interface)

|

| (802.1q trunk)

SWITCH

---------------------------------------------

version 12.2

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Router1

!

logging queue-limit 100

!

memory-size iomem 25

ip subnet-zero

!

!

no ip domain lookup

!

ip audit notify log

ip audit po max-events 100

!

interface Loopback0

no ip address

no ip mroute-cache

!

interface Tunnel0

no ip address

tunnel source FastEthernet0

tunnel destination 192.168.1.248

bridge-group 1

!

interface Ethernet0

no ip address

no ip mroute-cache

half-duplex

bridge-group 1

!

interface FastEthernet0

ip address 192.168.0.248 255.255.255.0

no ip mroute-cache

speed auto

!

ip classless

ip route 192.168.1.0 255.255.255.0 192.168.0.253

no ip http server

no ip http secure-server

!

bridge 1 protocol ieee

!

line con 0

line aux 0

line vty 0 4

exec-timeout 15 0

password cisco

login

!

end

version 12.2

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Router2

!

logging queue-limit 100

enable secret xxxxxxxxx

!

memory-size iomem 25

ip subnet-zero

no ip routing

!

!

no ip domain lookup

!

ip audit notify log

ip audit po max-events 100

!

interface Loopback0

no ip address

no ip route-cache

no ip mroute-cache

!

interface Tunnel0

no ip address

ip access-group 101 out

tunnel source FastEthernet0

tunnel destination 192.168.0.248

bridge-group 1

!

interface Ethernet0

no ip address

no ip route-cache

no ip mroute-cache

half-duplex

bridge-group 1

!

interface FastEthernet0

ip address 192.168.1.248 255.255.255.0

no ip route-cache

no ip mroute-cache

speed auto

!

ip classless

ip route 192.168.0.0 255.255.255.0 192.168.1.253

no ip http server

no ip http secure-server

!

bridge 1 protocol ieee

!

line con 0

line aux 0

line vty 0 4

exec-timeout 15 0

password cisco

login

!

end

3 REPLIES
New Member

Re: 802.1q over transparent bridging

Hello,

I dont see any need to change MTU if you introduce 802.1q. What is the motive behind MTU change and where do you want to change that? It should work as usual even if you make routers between switches as you mentioned above.

If it is on fastethernet interface to compensate the GRE overhead (extra 24 bytes). You can give "ip mtu 1524". But I dont think it is necesassary in most of the cases.

New Member

Re: 802.1q over transparent bridging

I thought that on a 802.1q link the MTU on the bridge interfaces changes of 1500 to 1524, because on a interface the MTU is max 1500 it has to be increased for the trunk.

Is my theorie wrong? Why do you think, changing the MTU isn't necessary on ethernet0, can you please explain that for me

Regards,

Michiel

New Member

Re: 802.1q over transparent bridging

I got your point! Please note additional overhead introduced by 802.1q trunking is 4 bytes but not 24 bytes as you said.

In cisco terminology MTU size does not include link layer overhead. on ethernet interface if MTU is 1500 bytses, that means maximum frame size supported is 1518 bytes (Etehret header+FCS). When you enable 802.1q, this makes frame size (Maximum) 1522.

Usually on switches (almost all) can accommodate this additional 4 bytes when you enable trunking on interface. same way when you enable inter VLAN routing with external router (router on stick), support for baby giants (Frame size of up to 1522) is assumed.

If you want to try this conenct 2 PCs in 2 different VLANs and ping with data payload of 1472 (Enable Inter VLAN routing for test sake)

ping -t -f -l 1472 "ip address"

Above makes 1500 Bytes in total (1472+8 Byte ICMP header+20 byte IP header)...If it is not through, may be problem with the platform. Please note, it is quite logical to think baby giant frames are also supported when 802.1q is supported.

HTH

232
Views
0
Helpful
3
Replies
CreatePlease to create content