Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

802.1q trunking 2611 to 3524

Hi,

I'm trying to set up an 802.1q trunk between the buit-in 10meg ehternet port on a 2611 router and a cat 3524 switch. I am running release 12.2(11)T10 on the router. The subinterfaces will come up but I can not ping any devices on the vlans on the switches.

I know that 802.1q was not supported on the built-in interface till 12.2(2)T but should be with my version.

Are there any special caveats for configuring 802.1q trunking on these interfaces?

Thanks,

Joe

7 REPLIES
Community Member

Re: 802.1q trunking 2611 to 3524

Which feature set are you running? The are 14 feature sets available for 12.2(11)T10 but only 8 support 802.1q trunking.

Community Member

Re: 802.1q trunking 2611 to 3524

I am running IP Plus.

c2600-is-mz.122-11.T10.bin

Anonymous
N/A

Re: 802.1q trunking 2611 to 3524

What does your subinterface config look like? Do you mind posting it?

Community Member

Re: 802.1q trunking 2611 to 3524

Here it is:

*********2600******************

interface Ethernet0/0

no ip address

no ip unreachables

no ip proxy-arp

duplex full

!

interface Ethernet0/0.1

encapsulation dot1Q 1 native

ip address 10.1.8.1 255.255.255.0

ip helper-address 10.10.10.56

no ip unreachables

!

interface Ethernet0/0.2

encapsulation dot1Q 2

ip address 192.168.8.1 255.255.255.0

ip helper-address 10.1.8.30

ip helper-address 10.10.10.56

no ip unreachables

*****3524***************************

interface FastEthernet0/24

description 2611 router E0/0

duplex full

speed 10

switchport trunk encapsulation dot1q

switchport mode trunk

switchport voice vlan 2

Anonymous
N/A

Re: 802.1q trunking 2611 to 3524

Your config looks good. That's exactly how I have mine configured and it works. I'm stumped. Sorry!

Community Member

Re: 802.1q trunking 2611 to 3524

ok thanks...at least we know that the config is correct.

Appreciate your help.

Re: 802.1q trunking 2611 to 3524

Hi,

I think this is the right moment to use a protocol analyzer.

Configure a SPAN (mirror) port on the switch mirroring the trunk traffic.

Connect a data analyzer (a PC running Ethereal freeware, e.g.) to it.

Try to Ping to/from the router and capture the ICMP frames.

You should see if your router sends/replies the correct frames.

Regards,

Milan

368
Views
0
Helpful
7
Replies
CreatePlease to create content