Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

802.1Q trunking on 26 failed

Recently I found that 802.1q trunking on 2610 platform will fail because of ARP reply filtered

Configuration below

!

interface Ethernet0/0

description Connection to CORSW1 F0/6

no ip address

full-duplex

!

interface Ethernet0/0.1

description Vlan 46 connection

encapsulation dot1Q 46 native

ip address 183.x.46.x.255.255.0

!

interface Ethernet0/0.2

description VLAN 16 connection

encapsulation dot1Q 16

ip address 183.x.16.x.255.255.0

!

It is showing up but can not pass traffic simply because ARP reply will be filtered

00:19:44: IP ARP: sent req src 183.1.46.6 0005.5e9a.e2e0,

dst 183.1.46.10 0000.0000.0000 Ethernet0/0.1

00:19:44: IP ARP rep filtered src 183.1.46.10 0012.438b.a780, dst 183.1.46.6 0005.5e9a.e2e0 wrong cable, interface Ethernet0/0

It says request goes out frmo E0/0.1 but back from E0/0. Anybody was suffereing from this and got a solution? Thanks

5 REPLIES
Hall of Fame Super Bronze

Re: 802.1Q trunking on 26 failed

You are concentrating on the wrong portion of the message, this is the important portion.

"wrong cable"

Read this URL and make sure you are running the suggested T release

http://www.cisco.com/en/US/products/hw/routers/ps259/prod_bulletin09186a00800921e4.html

Please rate helpful posts.

Thanks

New Member

Re: 802.1Q trunking on 26 failed

I am not quite convienced by your suggestion. the IOS version I am running on the router is 12.3(19), which is higher than 12.2(2)T.

Hall of Fame Super Bronze

Re: 802.1Q trunking on 26 failed

Higher revision within that train release. "T" releases contain special features.

Please rate helpful posts.

Thanks

Hall of Fame Super Bronze

Re: 802.1Q trunking on 26 failed

Also, based on the interface description, 'ethernet 0/0' it sounds like this is not the built-in LAN interface but a modular LAN interface.

The document I posted stated:

"

802.1Q encapsulation is now available on the built-in 10BaseT Ethernet interfaces of the Cisco 2610, 2611, and 2612 with Cisco IOS software 12.2(2)T and subsequent releases. Although this feature has been available on the Cisco 2600/3600 series since the release of Cisco IOS 12.1(5)T, support was previously limited to Fast Ethernet interfaces only. 802.1Q is not supported on any other Cisco 2600/3600 series 10BaseT Ethernet interface."

Re: 802.1Q trunking on 26 failed

Your trunk seems to be working fine. The only problem is what Ortiz has already pointed out - "wrong cable" is the problem.

I could reproduce your problem in my lab using IOS 12.2(8)T10 and here is the source of it: native vlan is the key. You have configured int eth0/0.1 being in vlan 46 and you've also declared this vlan as native.

What happens is following: packets leave your router tagged with VLAN 46, they reach node 183.1.46.10 and it replies with its MAC address (else you wouldn't see reply at all). Now this packet comes to the switch. Switch sees that this is packet of VLAN 46, which is native VLAN at least on the port where your 2600 router is connected. Native VLAN traffic is transmitted untagged, so ARP reply is sent untagged toward your router. Router is confused.

Solution: don't use native VLAN for anything except STP, VTP and few other LAN control protocols, i.e. no user (router is user) traffic in native VLAN.

Here is output I've seen:

CE1#ping 172.16.3.2

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 172.16.3.2, timeout is 2 seconds:

2d06h: IP ARP: creating incomplete entry for IP address: 172.16.3.2 interface Ethernet0/0.503

2d06h: IP ARP: sent req src 172.16.3.1 0006.d768.a9e0,

dst 172.16.3.2 0000.0000.0000 Ethernet0/0.503

2d06h: IP ARP: sent req src 172.16.3.1 0006.d768.a9e0,

dst 172.16.3.2 0000.0000.0000 Ethernet0/0.503

2d06h: IP ARP rep filtered src 172.16.3.2 0011.9241.e4a1, dst 172.16.3.1 0006.d768.a9e0 wrong cable, interface Ethernet0/0

CE1#sh run int eth0/0

Building configuration...

Current configuration : 80 bytes

!

interface Ethernet0/0

description XS5-FE0/4

no ip address

full-duplex

end

CE1#sh run int eth0/0.503

Building configuration...

Current configuration : 102 bytes

!

interface Ethernet0/0.503

encapsulation dot1Q 503 native

ip address 172.16.3.1 255.255.255.0

end

And the switch:

!

interface FastEthernet0/4

description CE1-ETH0/0

switchport trunk native vlan 503

switchport mode trunk

speed 10

duplex full

P.S.: Don't change native VLAN if you don't have good reason for it. When you do, be sure you can foresee the results.

388
Views
0
Helpful
5
Replies
CreatePlease to create content