Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

805 to 805 dial up through PSTN

I have connected two 805 routers on a PSTN line . The remote rouer does not allow calls to be authenticated on it. The line gets disconnected

6 REPLIES

Re: 805 to 805 dial up through PSTN

Please supply configs or output of "debug ppp negotiation".

Community Member

Re: 805 to 805 dial up through PSTN

--begin ciscomoderator note-- The following post has been edited to remove potentially confidential information. Please refrain from posting confidential information on the site to reduce security risks to your network. -- end ciscomoderator note --

Hi Please find the runn config. The modem handshakes holds the line and then disconnects.

Configuration of Dial In Router

Router1#sh runn

Building configuration...

Current configuration : 1115 bytes

!

version 12.2

no service pad

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname Router1

!

enable secret 5 --moderator edit--

!

username Router2 password 0 Router2

ip subnet-zero

!

no ip domain-lookup

chat-script dial "" AT OK "\atdp 3211" TIMEOUT 60 CONNECT \C ( exchange supports only pulse )

modemcap entry usr:MSC=& FS0=1 & C1&D2;&H1;&R2;&B1;&W;

!

!

!

interface Ethernet0

ip address 10.1.1.1 255.255.255.0

!

interface Serial0

physical-layer async

no ip address

encapsulation ppp

dialer in-band

dialer pool-member 1

async default routing

async mode dedicated

ppp authentication chap pap

!

interface Dialer1

ip address 30.1.1.1 255.255.255.0

encapsulation ppp

dialer pool 1

dialer remote-name Router2

dialer string 3211

dialer-group 1

no cdp enable

ppp authentication chap pap

!

ip classless

ip route 20.1.1.0 255.255.255.0 30.1.1.2

ip http server

ip pim bidir-enable

!

!

dialer-list 1 protocol ip permit

!

line con 0

stopbits 1

line 1

modem InOut

modem autoconfigure type usr

transport input all

speed 115200

flowcontrol hardware

line vty 0 4

login

!

end

Re: 805 to 805 dial up through PSTN

It seems you have a modem configuration problem.

Try removing modem autoconfiguration from line 1 and configure the modem manually using a terminal with the following initialisation string: AT&F1&W

This is the "harware profile" initialisation string for usr modems.

Community Member

Re: 805 to 805 dial up through PSTN

--begin ciscomoderator note-- The following post has been edited to remove potentially confidential information. Please refrain from posting confidential information on the site to reduce security risks to your network. -- end ciscomoderator note --

Configuration of Dial In Router

Router1#sh runn

Building configuration...

Current configuration : 1115 bytes

!

version 12.2

no service pad

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname Router1

!

enable secret 5 --moderator edit--

!

username Router2 password 0 Router2

ip subnet-zero

!

no ip domain-lookup

chat-script dial "" AT OK "\atdp 3211" TIMEOUT 60 CONNECT \C ( exchange supports only pulse )

modemcap entry usr:MSC=& FS0=1 & C1&D2;&H1;&R2;&B1;&W;

!

!

!

interface Ethernet0

ip address 10.1.1.1 255.255.255.0

!

interface Serial0

physical-layer async

no ip address

encapsulation ppp

dialer in-band

dialer pool-member 1

async default routing

async mode dedicated

ppp authentication chap pap

!

interface Dialer1

ip address 30.1.1.1 255.255.255.0

encapsulation ppp

dialer pool 1

dialer remote-name Router2

dialer string 3211

dialer-group 1

no cdp enable

ppp authentication chap pap

!

ip classless

ip route 20.1.1.0 255.255.255.0 30.1.1.2

ip http server

ip pim bidir-enable

!

!

dialer-list 1 protocol ip permit

!

line con 0

stopbits 1

line 1

modem InOut

modem autoconfigure type usr

transport input all

speed 115200

flowcontrol hardware

line vty 0 4

login

!

end

Silver

Re: 805 to 805 dial up through PSTN

We need to see the following debugs on both the routers:

deb chat / deb modem / deb ppp nego

Try the following modemcap:&f1s0=1&c1&d2&a1&w on the usr with dip switches 3&8 down & rest up.

Thanks, Mak.

Cisco Employee

Re: 805 to 805 dial up through PSTN

.

136
Views
0
Helpful
6
Replies
CreatePlease to create content