Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

806 router and cable modems...

I got the Cisco 806 router yesterday. I have a cable modem (non-Cisco). Having a problem getting an IP on the E1 interface. The config is Internet>cable modem>806>PC. Already went to http://www.cisco.com/warp/public/109/router_behind_cm_19268.shtml#intro , but haven't had any luck yet. When I first got the rouer out of the box, hook up everything and could ping the E0 interface, but can't now. Any suggestions?

John

9 REPLIES
Cisco Employee

Re: 806 router and cable modems...

The role of 806 router behind non-cisco cable modem is to obtain ip address dynamically (for its one of the eth port) from isp and perform NAT for the internal ip address on a privet LAN..Not to troubleshoot it, we need to know

that the ip address is obtained for eth port connected to cable modem or not..

"sh ip interface brief" will inform that..

From a PC, are you able to ping the privet ip address of the eth port??

The url that you are refering to, does have verification steps, pl. see what do we got in your case..

Cisco Employee

Re: 806 router and cable modems...

Hi,

Try using the built-in web-based tool, Cisco Router Web Setup to configure your router. It has a feature called Test Connection which will test your connection and fix the problem for you.

Regards,

Ravikumar

New Member

Re: 806 router and cable modems...

I have tried the Cisco Router Web Setup, but didn't get it working right that way. I loaded a new IOS image on it, configured the outside interface to DHCP and it got an IP. Thanks for reply.

John

New Member

Re: 806 router and cable modems...

I'm having the same problem, what IOS version are you using to get it to work?

New Member

Re: 806 router and cable modems...

I'm using 12.2(4r)XM1. I finally got it working a week ago. Now the outside interface gets an IP address ok. I erased the config and started from scratch. When I got the config how it was supposed to look I turned off the cable modem and router, then plugged the cable modem back in then the router. Works fine now.

John

New Member

Re: 806 router and cable modems...

I have my 806 connected to Comcast below is my configuration. Hope it helps you

Route IOS version - c806-k9osy6-mz.122-11.t.bin

Configuration:

!

version 12.2

no parser cache

no service pad

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname xxxx

!

enable secret

!

username xxxx privilege 15 password 7

ip subnet-zero

ip name-server 68.39.224.5

ip name-server 68.39.224.6

ip dhcp excluded-address 10.10.10.1

ip dhcp excluded-address 68.37.x.x 68.37.x.x

!

ip dhcp pool client

network 10.10.10.0 255.255.255.0

dns-server 68.39.x.x 68.39.x.x

domain-name comcast.net

default-router 10.10.10.1

lease infinite

!

ip inspect name myfw cuseeme timeout 3600

ip inspect name myfw ftp timeout 3600

ip inspect name myfw http timeout 3600

ip inspect name myfw rcmd timeout 3600

ip inspect name myfw realaudio timeout 3600

ip inspect name myfw smtp timeout 3600

ip inspect name myfw tftp timeout 30

ip inspect name myfw udp timeout 15

ip inspect name myfw tcp timeout 3600

ip inspect name myfw h323 timeout 3600

!

partition flash 2 6 2

!

!

!

!

interface Loopback0

ip address 10.1.1.1 255.255.255.255

!

interface Ethernet0

ip address 10.10.10.1 255.255.255.0

ip nat inside

no cdp enable

hold-queue 32 in

hold-queue 100 out

!

interface Ethernet1

mac-address 0002.1764.73b9

ip address dhcp client-id Ethernet1

ip access-group 111 in

ip nat outside

ip inspect myfw out

no keepalive

no cdp enable

!

ip nat inside source list 102 interface Ethernet1 overload

ip classless

ip http server

ip pim bidir-enable

!

!

access-list 102 permit ip 10.10.10.0 0.0.0.255 any

access-list 111 permit icmp any any administratively-prohibited

access-list 111 permit icmp any any packet-too-big

access-list 111 permit icmp any any time-exceeded

access-list 111 permit icmp any any traceroute

access-list 111 permit icmp any any unreachable

access-list 111 permit udp any eq bootps any eq bootpc

access-list 111 permit udp any eq bootps any eq bootps

access-list 111 permit udp any eq domain any

access-list 111 permit udp any any eq isakmp

access-list 111 permit tcp any any eq telnet

access-list 111 permit tcp any any gt 1023 established

access-list 111 permit tcp any any eq 6699

access-list 111 permit udp any any eq 6257

access-list 111 permit tcp any any eq 6346 established

access-list 111 permit ahp any any

access-list 111 permit esp any any

access-list 111 deny icmp any any echo-reply

no cdp run

!

line con 0

exec-timeout 120 0

password 7

logging synchronous

login

stopbits 1

line vty 0 4

exec-timeout 120 0

password 7

login

length 0

!

scheduler max-task-time 5000

end

Cisco Employee

Re: 806 router and cable modems...

Some ISPs bind the subscriber to the PC MAC address. A DHCP request will get a response only if it is sent from the registered MAC address. This might be to restrict the number of PCs behind the cable modem. Try setting the MAC address of 806's WAN interface to that of your PC. Of course, you should give a new MAC address to your PC.

-Ganesh.

New Member

Re: 806 router and cable modems...

You can also try connecting the PC directly to the cable modem, if it gets an IP address, then release it and then try it with your router...

Juan

New Member

Re: 806 router and cable modems...

Ok, thanks. Yeah, now I can get an IP.

John

112
Views
0
Helpful
9
Replies
CreatePlease login to create content