Cisco Support Community
Community Member

827 ADSL Modem: Ethernet0 down

I have an 827 ADSL modem which was working fine up until a few weeks ago. The Ethernet0 interface no longer functions properly, but the ATM0 interface and connection to my DSL provider is just fine. (I can ping, telnet, etc to external IPs via the serial console on the device.)

When I power cycle the modem with the Ethernet cable plugged in, 'sh int eth0' gives me:

"Ethernet0 is up, line protocol is up"

at this point the connection LED is solid and the TX LED blinks on every so often (15-30 secs). PCs that are directly connected to the cable (I've tried Linux/Win2k/WinXP) do not recognize a connection and state "Media disconnected"-type errors.

If I then disconnect either end of the cable, or power cycle without the connection, then reconnect the cable, 'sh int eth0' shows:

"Ethernet0 is up, line protocol is down"

until I power cycle again.

There is also a toggle on the back of the modem to select PC or HUB. The above description is in PC mode, and HUB mode yields the "..line protocol is down" state all of the time (which makes sense). I have also tried using various known-good cables and machines.

Nothing changed in the router configuration from the day it was working to the day it wasn't. I've experimented with the configuration a bit without any luck. My suspicion is that this is some harware issue, but I really don't know.

Any help is appreciated.


Re: 827 ADSL Modem: Ethernet0 down

Looks like a hardware problem to me too. It may be also due to loose connection or corrupt cable. Did you try using another cable??

CreatePlease to create content