Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

827 pppoe Dynamic ip with webserver

I use a Cisco 827 router with PPPoE with a dynamic ip address from the provider.Everything 's working fine, but now i would lijke to install a webserver. Therefor i have to do on portforwarding because the router is configuerd in NAT. I did everything right (i think) but i can't connect my webserver from outside.

However with an Alcatelrouter everything is working well.

Were 's my problem??

Here is my config. My webserver is 192.168.254.5

-------------------------------------------------------------

no service pad

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname ADSL

!

enable secret xxxxxxxxxxx

!

username ADSL password xxxxxxxx

username xxxxx password xxxxxxxxxxxx

ip subnet-zero

ip name-server 195.238.2.22

ip name-server 195.238.2.21

ip dhcp excluded-address 192.168.254.254

ip dhcp excluded-address 192.168.254.5

!

ip dhcp pool CLIENT

import all

network 192.168.254.0 255.255.255.0

default-router 192.168.254.254

lease 0 2

!

vpdn enable

!

vpdn-group 1

request-dialin

protocol pppoe

!

!

!

!

interface Ethernet0

ip address 192.168.254.254 255.255.255.0

ip nat inside

ip tcp adjust-mss 1452

hold-queue 100 out

!

interface ATM0

no ip address

atm vc-per-vp 64

no atm ilmi-keepalive

--More--

pvc 8/35

pppoe-client dial-pool-number 1

!

dsl operating-mode auto

!

interface Dialer1

ip address negotiated

ip mtu 1492

ip nat outside

encapsulation ppp

ip tcp adjust-mss 1452

dialer pool 1

dialer remote-name redback

dialer-group 1

ppp authentication pap chap callin

ppp chap hostname xxxxxxxxxx

ppp chap password xxxxxxxxxxxxxxx

ppp pap sent-username xxxxxxxxxxx password xxxxxxxxxxx

ppp ipcp dns request

ppp ipcp wins request

!

ip nat inside source list 102 interface Dialer1 overload

ip nat inside source static tcp 192.168.254.5 80 interface Dialer1 80

ip classless

ip route 0.0.0.0 0.0.0.0 Dialer1

no ip http server

!

!

access-list 23 permit 192.168.254.0 0.0.0.255

access-list 102 permit ip 192.168.254.0 0.0.0.255 any

dialer-list 1 protocol ip permit

!

line con 0

stopbits 1

line vty 0 4

access-class 23 in

exec-timeout 120 0

login

length 0

!

scheduler max-task-time 5000

end

------------------------------------------------------------------------------

2 REPLIES
New Member

Re: 827 pppoe Dynamic ip with webserver

Your config looks fine from what I can see, but here's a couple of things to try.

First, try adding the key word extendable to the static line, ie:

ip nat inside source static tcp 192.168.254.5 80 interface Dialer1 80 extendable

The only other thing I can think of is if you had added your static translation to the config and didn't reload the router or do a clear ip nat trans * after making the change. This could cause it not to work because the Dialer1 overload translation would still be in effect for your web server.

Hope it helps -

Bob

New Member

Re: 827 pppoe Dynamic ip with webserver

Hi Bob,

I tryd to add the "extendable" at the end of the static command line but it i recieved an invalid input at the word extendable.

The second thing you was no succes either.

I took a look on the site and found an example of a config but it looks the same as the one i 'm using.

Still any suggestions.

Thanks.

Jim

211
Views
0
Helpful
2
Replies