Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

827 Router Config problem

I am doing a migration of all our ADSL routers (non-cisco) to 827 Cisco router. Until now I had no problem at all.

But with one I have a routing problem :

This is my config :

Cisco827#sh run

Building configuration...

Current configuration : 1199 bytes

!

version 12.2

no service pad

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname Cisco827

!

no logging buffered

enable secret 5 $1$WQwL$79u5MHQfXmZA9C1Ng3gc30

enable password 7 0101090B4F

!

username xxxxxx password 7 0316540412

ip subnet-zero

ip name-server 195.238.2.21

ip name-server 195.238.2.22

!

vc-class atm office

inarp 30

inarp 30

encapsulation aal5snap

!

interface Ethernet0

ip address 10.16.5.1 255.255.255.240

ip nat inside

load-interval 30

no keepalive

no cdp enable

hold-queue 100 out

!

interface ATM0

no ip address

load-interval 30

no atm ilmi-keepalive

dsl operating-mode auto

hold-queue 224 in

!

interface ATM0.1 point-to-point

description Cisco 827 ADSL PRO

ip address 194.78.209.222 255.255.255.0

ip nat outside

pvc 8/35

class-vc office

!

!

ip nat inside source list 130 interface ATM0.1 overload

ip classless

ip route 0.0.0.0 0.0.0.0 194.78.209.1

ip http server

!

!

access-list 130 permit ip any any

no cdp run

!

line con 0

exec-timeout 120 0

logging synchronous

stopbits 1

line vty 0 4

exec-timeout 120 0

password 7 095E41060D

login local

length 0

!

scheduler max-task-time 5000

end

As you can see , quite an easy config which I did on every router. But on this setup I can ping from my laptop (connected to the router) to 10.16.5.1 and to the WAN IP adress. But I can't ping to the WAN Gateway 194.78.209.1. And on the router I can't ping to my WAN interface and to my WAN Gateway.

Alle the WAN IP addresses and VPI/VCI are OK because I copied them from the non-cisco router.

Probably I am missing something but I can't think of what.

Thanks in advance for the help.

  • Other Network Infrastructure Subjects
2 REPLIES
New Member

Re: 827 Router Config problem

Something I forgot : I have a good connection to the DSLAM (CD led is green)

But if I do a debug atm packet :

I get ATM0(I): VCD:0x0 type:0x0Inactive or not configured VCD length:0x38

I hope this could help you

Cisco Employee

Re: 827 Router Config problem

first, the "encapsulation ..." command is missing in the config. Also you need to know what kind of technology that adsl line is configured for.

Is it RFC1483 bridging or routing, RBE, PPPoE or PPPoA etc.

Once you have that information, here is the same sample config for that

For RBE

http://www.cisco.com/warp/customer/794/827rfc_6400rbe_1.html

For PPPoA/PPPoE

http://www.cisco.com/cgi-bin/Support/browse/psp_view.pl?

p=Internetworking:PPPoE__PPPoA__PPP_over_Ethernet__PPP_over_ATM&viewall=true

For RFC1483 bridging

http://www.cisco.com/cgi-bin/Support/browse/psp_view.pl?p=Internetworking:RFC_1483_Bridging___Routing&viewall=true

126
Views
0
Helpful
2
Replies
This widget could not be displayed.