Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

[827] tcp over dsl (config attached)

--begin ciscomoderator note-- The following post has been edited to remove potentially confidential information. Please refrain from posting confidential information on the site to reduce security risks to your network. -- end ciscomoderator note --

hi, there:

i have a problem that i'm sure someone will catch very quickly.

i have 2 827-4v routers that i'm trying to use for voip.

they're connected to the internet and can ping each other.

but they cannot open up the voip call, forthermore i can't telnet to either one of them over the internet. both of them are connected to my lan, so i can reach them, but if i try to telnet or ssh to the atm (or dialer) interfaces, the telnet fails.

i turned on a debug and see a 'bad sequence number' message that forces the session to be turned down by the recipient of the telnet request.

i pasted my config here, the other router is a mirror image. now, only one thing, please do not pay attention to the firewall and vpn configs. that part ios already working and my problem was present way before i even started with this. like i said, i know someone will catch this very quickly, so...

thanks,

c.

ps. the only differenece between this router and the other one is that the other one runs pppoe through the dsl interface.

Current configuration : 2481 bytes

!

version 12.2

no parser cache

no service single-slot-reload-enable

no service pad

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname 827-1

!

logging rate-limit console 10 except errors

enable secret 5 xxxxxxxxxxxxxxxxxxxxx

!

username cisco password 7 xxxxxxxxxxxxxxxxxx

ip subnet-zero

ip telnet source-interface ATM0.1

!

ip dhcp y

network 10.0.0.0 255.0.0.0

dns-server a.a.a.a

domain-name y

default-router 10.0.0.138

!

ip ssh time-out 120

ip ssh authentication-retries 3

no ip dhcp-client network-discovery

call rsvp-sync

!

voice service pots

!

voice service voip

!

!

!

!

!

!

crypto isakmp policy 10

encr 3des

authentication pre-share

group 2

crypto isakmp key cisco address d.d.d.d

!

!

crypto ipsec transform-set test esp-des esp-sha-hmac

!

crypto map test local-address ATM0.1

crypto map test 10 ipsec-isakmp

set peer b.b.b.b

set transform-set test

match address 101

!

!

!

!

interface Ethernet0

ip address 10.0.0.138 255.0.0.0

ip nat inside

hold-queue 100 out

!

interface ATM0

no ip address

no atm ilmi-keepalive

!

dsl operating-mode auto

!

interface ATM0.1 point-to-point

ip address x.x.x.x 255.255.255.252

ip mtu 1492

ip nat outside

pvc 8/81

encapsulation aal5snap

!

crypto map test

!

interface Dialer1

no ip address

no cdp enable

!

ip nat inside source route-map nonat interface ATM0.1 overload

ip classless

ip route 0.0.0.0 0.0.0.0 x.x.x.x

ip http server

!

access-list 1 permit any

access-list 101 permit ip 10.0.0.0 0.255.255.255 192.168.0.0 0.0.0.255

access-list 110 deny ip 10.0.0.0 0.255.255.255 192.168.0.0 0.0.0.255

access-list 110 permit ip 10.0.0.0 0.255.255.255 any

route-map nonat permit 10

match ip address 110

!

!

voice-port 1

!

voice-port 2

!

voice-port 3

!

voice-port 4

!

dial-peer voice 1 pots

destination-pattern 1111

port 1

!

!

dial-peer voice 100 voip

destination-pattern 2222

session target ipv4:c.c.c.c

!

!

line con 0

exec-timeout 120 0

stopbits 1

line vty 0 4

exec-timeout 120 0

password 7 xxxxxxxxxxxxxxxxxxx

login local

!

scheduler max-task-time 5000

end

1 REPLY
Silver

Re: [827] tcp over dsl (config attached)

Use debug ip packet for further investigation. It seems your TCP is not working except for ping.

81
Views
0
Helpful
1
Replies