Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

827H ip/fw ios - dsl operating-mode auto

Hi

I have a 827h router running the ip ios (c820-oy6-mz.122-4.YA2.bin). This works fine.

If however i upgrade the ios to include the ip/fw/des ios (c820-k8osy6-mz.122-2.T4.bin) it immediately stops working. the atm0 interface shows down and line protocol down.

I have tried all the obvious things to no avail. One thing i have noticed is that in config mode if i change to the atm0 interface I have no option to enter commands starting with 'dsl' the main one that i have noticed is missing is "dsl operating-mode auto". This is a command that i have seen in every sample config posted on cisco.com and on other sites.

Router Config

- - - - - - - - - - - - - - - - - - - - - - - - - -

version 12.2

no parser cache

service single-slot-reload-enable

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname KahunaRO

!

logging buffered 4096 debugging

logging rate-limit console 10 except errors

!

username pagec password 0 xxxxxxxxxxxx

ip subnet-zero

!

ip inspect name Dialer_0 tcp

ip inspect name Dialer_0 udp

ip inspect name Dialer_0 cuseeme

ip inspect name Dialer_0 ftp

ip inspect name Dialer_0 h323

ip inspect name Dialer_0 rcmd

ip inspect name Dialer_0 realaudio

ip inspect name Dialer_0 streamworks

ip inspect name Dialer_0 vdolive

ip inspect name Dialer_0 sqlnet

ip inspect name Dialer_0 tftp

ip ssh time-out 120

ip ssh authentication-retries 3

no ip dhcp-client network-discovery

!

!

!

!

interface Ethernet0

ip address 192.168.xxx.200 255.255.255.0

ip access-group 102 in

ip nat inside

!

interface Virtual-Template1

no ip address

!

interface ATM0

no ip address

no atm ilmi-keepalive

!

interface ATM0.1 point-to-point

pvc 0/38

encapsulation aal5mux ppp dialer

dialer pool-member 1

!

!

interface Dialer0

bandwidth 640

ip address xxx.xxx.xxx.xxx 255.255.255.0

ip access-group 101 in

no ip redirects

no ip unreachables

ip nat outside

ip inspect Dialer_0 out

encapsulation ppp

dialer pool 1

dialer-group 1

no cdp enable

ppp chap hostname me@mydsl.net

ppp chap password 7 141C1D05030C2B

ppp ipcp dns request

!

ip nat inside source list 1 interface Dialer0 overload

ip classless

ip route 0.0.0.0 0.0.0.0 Dialer0

ip http server

!

access-list 1 permit xxx.xxx.xxx.0 0.0.0.255

access-list 23 permit xxx.xxx.xxx.0 0.0.0.255

access-list 101 remark Traffic allowed to enter the router from Internet

access-list 101 deny ip 10.0.0.0 0.255.255.255 any

access-list 101 deny ip 172.16.0.0 0.15.255.255 any

access-list 101 deny ip 192.168.0.0 0.0.255.255 any

access-list 101 deny ip any host 255.255.255.255

access-list 101 permit udp any eq isakmp any eq isakmp

access-list 101 permit gre any any

access-list 101 permit icmp any any unreachable

access-list 101 permit icmp any any echo-reply

access-list 101 permit icmp any any packet-too-big

access-list 101 permit icmp any any time-exceeded

access-list 101 permit icmp any any traceroute

access-list 101 permit icmp any any administratively-prohibited

access-list 101 permit icmp any any echo

access-list 101 deny ip any any log

access-list 102 remark Traffic allowed to enter the router from the Ethernet

access-list 102 deny udp any any eq tftp

access-list 102 permit ip xxx.xxx.xxx.0 0.0.0.255 any

access-list 102 permit ip any host xxx.xxx.xxx.254

access-list 102 permit ip any host 255.255.255.255

access-list 102 deny ip any any log

dialer-list 1 protocol ip permit

!

line con 0

stopbits 1

line vty 0 4

login

!

scheduler max-task-time 5000

end

- - - - - - - - - - - - - - - - - - - - - - - - - -

Does anyone have any advice on what could be causing this and if there are any workarounds.

any help/advice would be apreciated as this is driving me nuts

3 REPLIES
Bronze

Re: 827H ip/fw ios - dsl operating-mode auto

The H model uses a different ADSL chipset than the 827 (newer version), so the "T" train is not yet supported. This setup should work fine with any 12.2(4)YA or newer code.

New Member

Re: 827H ip/fw ios - dsl operating-mode auto

Aaaah so that's it - I logged a case with TAC after I found that it would work with YJ or YJ1 and not T4/T5 but got nowhere fast.

New Member

Re: 827H ip/fw ios - dsl operating-mode auto

Thanks a lot, that worked a treat. I've been tearing my hair out over this.

chris

154
Views
0
Helpful
3
Replies
CreatePlease to create content