Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

831 Router with PPPoE - No Dialer String error

Hi,

I've been trying to use a config template that appeared in this forum to configure PPPoE client on

an 831 to connect to an ADSL ISP. When I try to connect to the ISP the 'debug dialer' output is:

*Mar 2 03:07:29.629: Di1 DDR: Cannot place call, no dialer string set.

Anyone know what I'm doing wrong ?

I'm using IOS 12.2(13)ZG

The config in use is:

______________________________________________

version 12.2

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Router

!

logging buffered 4096 debugging

enable password cisco

!

ip subnet-zero

no ip domain lookup

!

ip urlfilter alert

ip audit notify log

ip audit po max-events 100

vpdn enable

!

vpdn-group 1

request-dialin

protocol pppoe

!

!

!

interface Loopback1

ip address 10.10.10.1 255.255.255.255

!

interface Ethernet0

ip address 10.220.46.96 255.255.255.0

ip nat inside

no ip route-cache

no ip mroute-cache

hold-queue 100 out

!

interface Ethernet1

no ip address

no ip route-cache

no ip mroute-cache

duplex full

pppoe enable

pppoe-client dial-pool-number 1

hold-queue 100 out

!

interface Dialer1

ip address negotiated

ip mtu 1492

ip nat outside

encapsulation ppp

dialer pool 1

dialer-group 1

ppp authentication pap

ppp pap sent-username user@domain password encr-pass

!

ip classless

ip route 0.0.0.0 0.0.0.0 Dialer1

ip http server

no ip http secure-server

!

!

dialer-list 1 protocol ip permit

!

line con 0

password *******

no modem enable

stopbits 1

line aux 0

stopbits 1

line vty 0 4

password ******

login

!

scheduler max-task-time 5000

end

3 REPLIES
VIP Purple

Re: 831 Router with PPPoE - No Dialer String error

Hello,

try to add the following to your (global) configuration and see what happens:

ip nat inside source list 101 interface Dialer1 overload

access-list 101 permit ip 10.220.46.0 0.255.255.255 any

Regards,

GP

New Member

Re: 831 Router with PPPoE - No Dialer String error

I've added this but still no luck...

Still getting the following debug output:

Di1 DDR: Cannot place call, no dialer string set

New Member

Re: 831 Router with PPPoE - No Dialer String error

Hi,

I think you have to configure a dialer string. number doesn't matter.

try to add on dialer interface:

dialer string 555

ppp authentication pap callin

ppp ipcp dns request

ppp ipcp wins request

regards

420
Views
0
Helpful
3
Replies
CreatePlease login to create content