Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

837 ADSL Problem

I am trying to configure an 837. It works fine when I configure it using CRWS. However, when I use the SDM, I am unable to connect to the Internet. When I debug dialer events, I get the following error

UTC: Di0 DDR: Cannot place call, no dialer string set

What does this mean?? I have configured another 837 at the customers other site and it works fine.

Regards

Graham

4 REPLIES
Bronze

Re: 837 ADSL Problem

The dialer string is the number needed to dial the destination. For DSL, it might be the VPI/VCI needed to communicate. You can use the 'show running-config' command to check the difference in the configuration while configured with CRWS and SDM. This could be an issue with the hardware/software version that you are using. Check this link :

http://www.cisco.com/univercd/cc/td/doc/product/access/acs_fix/826/swg/routconf.htm

VIP Purple

Re: 837 ADSL Problem

Hi Graham,

have you used CRWS before you started using SDM on the same router ? If that is the case, I assume you have followed the switchover procedure ?

Can you post the config of the router ?

Regards,

Georg

New Member

Re: 837 ADSL Problem

I have followed the switch over. I think my problem now is that the exchange is different. This is because I can take the router to another ADSL circuit and it works fine configured under SDM. The main difference between the configs is the encapsulation, PPPoA and PPPoE.

The reason why I want to use the SDM is so that I can configure Site to Site VPN. I tried doing this through the CLI but it would not accept some the Crpto commands. Anyway, here is my config.

TTUpminster_ADSL#sho run

Building configuration...

Current configuration : 2533 bytes

!

version 12.2

no service pad

service tcp-keepalives-in

service tcp-keepalives-out

service timestamps debug datetime msec localtime show-timezone

service timestamps log datetime msec localtime show-timezone

service password-encryption

service sequence-numbers

!

hostname TTUpminster_ADSL

!

logging queue-limit 100

logging buffered 51200 debugging

logging console critical

enable secret xxxxxx

!

username xxxxx privilege 15 password xxxxx

ip subnet-zero

no ip source-route

ip tcp synwait-time 10

ip domain name dslconnect.co.uk

ip name-server x.x.253.50

ip name-server x.x.253.58

ip dhcp excluded-address x.x.2.1 192.1.2.50

ip dhcp excluded-address x.x.2.81 192.1.2.254

!

ip dhcp pool sdm-pool1

network x.x.2.0 255.255.255.0

default-router 192.1.2.47

domain-name dslconnect.co.uk

dns-server x.x.x.50 80.225.253.58

!

!

no ip bootp server

ip cef

ip audit notify log

ip audit po max-events 100

ip ssh time-out 60

ip ssh authentication-retries 2

no ftp-server write-enable

!

!

!

!

!

!

!

interface Ethernet0

description $FW_INSIDE$$ETH-LAN$

ip address x.x.x.47 255.255.255.0

no ip redirects

no ip unreachables

no ip proxy-arp

ip nat inside

ip route-cache flow

ip tcp adjust-mss 1452

hold-queue 100 out

!

interface ATM0

no ip address

no ip redirects

no ip unreachables

no ip proxy-arp

ip route-cache flow

no atm ilmi-keepalive

dsl operating-mode auto

!

interface ATM0.1 point-to-point

pvc 0/38

pppoe-client dial-pool-number 1

!

!

interface Dialer0

ip address 80.46.xxx.xxx 255.255.255.0

ip mtu 1452

ip nat outside

encapsulation ppp

dialer pool 1

dialer-group 1

no cdp enable

ppp authentication chap callin

ppp chap hostname xxxxxxxxxxx_tsl@dslconnect.co.uk

ppp chap password xxxxxxx

!

ip nat inside source list 1 interface Dialer0 overload

ip classless

ip route 0.0.0.0 0.0.0.0 Dialer0

ip http server

ip http authentication local

ip http secure-server

!

logging trap debugging

access-list 1 remark INSIDE_IF=Ethernet0

access-list 1 remark SDM_ACL Category=2

access-list 1 permit 192.1.2.0 0.0.0.255

dialer-list 1 protocol ip permit

no cdp run

banner login ^CAuthorized access only!

Disconnect IMMEDIATELY if you are not an authorized user!

^C

!

line con 0

login local

no modem enable

transport output telnet

stopbits 1

line aux 0

login local

transport output telnet

stopbits 1

line vty 0 4

privilege level 15

login local

transport input telnet ssh

!

scheduler max-task-time 5000

scheduler interval 500

!

end

Cisco Employee

Re: 837 ADSL Problem

The config does not look correct to me. It should be something like this:

vpdn enable

no vpdn logging

!

vpdn-group pppoe

request-dialin

protocol pppoe

!

!

interface ATM0.1 point-to-point

pvc 1/1

pppoe-client dial-pool-number 1

!

interface Dialer1

ip address negotiated

mtu 1492

ip nat outside

encapsulation ppp

dialer pool 1 <--- ties to atm interface

ppp authentication chap callin

ppp chap hostname client1

ppp chap password 7 020508520E081B70

216
Views
0
Helpful
4
Replies
CreatePlease to create content