Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Attention: The Cisco Support Community site will be in read only mode on Dec14, 2017 from 12:01am PST to 11:30am for standard maintenance. Sorry for the inconvenience.

New Member

A bridge too far ?

Hello all,

I am looking to bridge 2 cisco 2620's over a leased line but I have never had to do this before and am having trouble finding out how it should be done. Does anyone have a good link i can look at or even just a list of the basic commands i should use ?

cheers

13 REPLIES
Bronze

Re: A bridge too far ?

hi

Here the configuration guides for the different bridging you can configure.

I guess the one you need is the transparent bridging guide.

Still if you can i would not implement bridging. if you can i would go with routing.

http://www.cisco.com/univercd/cc/td/doc/product/software/ios122/122cgcr/fibm_c/bcfpart1/index.htm

Hope that helps

Roger

Re: A bridge too far ?

Hi,

here is a config example (this was used for Frame-relay WAN but leased line should be similar):

!

ip subnet-zero

no ip routing

!

interface Ethernet0

ip address ......

no ip route-cache

bridge-group 5

!

interface Serial0

no ip address

encapsulation frame-relay

no ip route-cache

cdp enable

frame-relay lmi-type ansi

bridge-group 5

!

interface Serial0.x point-to-point

ip address ........

no ip route-cache

frame-relay interface-dlci x

bridge-group 5

!

ip default-gateway y.y.y.y

ip classless

!

bridge 5 protocol ieee

!

This was for router which bridges only, not routing at all.

If you want to configure Integrated Routing and Bridging see http://www.cisco.com/warp/public/473/741_10.pdf

For Concurent Routing and Bridging see

http://www.cisco.com/univercd/cc/td/doc/product/software/ios122/122cgcr/fibm_c/bcfpart1/bcftb.htm#1002978

which is a part of

http://www.cisco.com/univercd/cc/td/doc/product/software/ios122/122cgcr/fibm_c/bcfpart1/bcftb.htm

document containing all possible details about IOS bridging.

Regards,

Milan

Re: A bridge too far ?

Hi,

here is a config example (this was used for Frame-relay WAN but leased line should be similar):

!

ip subnet-zero

no ip routing

!

interface Ethernet0

ip address ......

no ip route-cache

bridge-group 5

!

interface Serial0

no ip address

encapsulation frame-relay

no ip route-cache

cdp enable

frame-relay lmi-type ansi

bridge-group 5

!

interface Serial0.x point-to-point

ip address ........

no ip route-cache

frame-relay interface-dlci x

bridge-group 5

!

ip default-gateway y.y.y.y

ip classless

!

bridge 5 protocol ieee

!

This was for router which bridges only, not routing at all.

If you want to configure Integrated Routing and Bridging see http://www.cisco.com/warp/public/473/741_10.pdf

For Concurent Routing and Bridging see

http://www.cisco.com/univercd/cc/td/doc/product/software/ios122/122cgcr/fibm_c/bcfpart1/bcftb.htm#1002978

which is a part of

http://www.cisco.com/univercd/cc/td/doc/product/software/ios122/122cgcr/fibm_c/bcfpart1/bcftb.htm

document containing all possible details about IOS bridging.

Regards,

Milan

New Member

Re: A bridge too far ?

Hello,

thanks for your replies so far. I have a basic bridge now working (see below)but I have run into a problem. All was working well and I could see the arp table picking up mac addresses until I rebooted the cisco's. They have now stopped bridging and I have noticed that the entry 'no ip mroute-cache' has been added to the interfaces. What does this command do ? When I try to remove the command I get the following message :

IP unicast fastswitching has to be enabled on a physical interface

What does this mean and am I missing some commands?

A copy of the config of one of the routers is below, they are both v similar. Any help would be greatly appreciated:

version 12.2

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname xyxyxyx

!

no logging console

!

ip subnet-zero

no ip routing

!

!

no ip domain-lookup

!

!

!

!

interface FastEthernet0/0

ip address x.x.x.x y.y.y.y

no ip route-cache

no ip mroute-cache

duplex auto

speed auto

bridge-group 1

!

interface Serial0/0

ip unnumbered FastEthernet0/0

encapsulation ppp

no ip route-cache

no ip mroute-cache

no fair-queue

clockrate 64000

bridge-group 1

!

ip classless

ip http server

ip pim bidir-enable

!

!

bridge 1 protocol ieee

banner motd ^C

#########################################################################

abababababababababababababababababababababababababab

#########################################################################

^C

!

line con 0

password xxxxx

login

line aux 0

line vty 0 4

password xxxxxxx

!

!

end

Thanks

Richard

Bronze

Re: A bridge too far ?

hi

The ip mroute-cache command enables multicast fastswitching.

It is the same for the ip route-cache command.

http://www.cisco.com/univercd/cc/td/doc/product/software/ios122/122cgcr/fswtch_r/xrfscmd2.htm#1065558

As the command reference says the fastswitching is for ip routing. so i guess if you disable ip routing on the router it will automatically disable fastswitching.

But it should not have an impact for you.

Does the bridging not work anymore?

Regards

Roger

New Member

Re: A bridge too far ?

Roger,

the bridge is not working at the moment. It was working last night and i did a 'copy r s'and powered down the routers for the night. This morning they have both booted ok but will not talk to each other. The only difference I can see is that the command 'no ip mroute-cache' has been added to all interfaces on both routers. I can only assume that this is the problem but do not know how to rectifiy this,

Thanks

Richard

New Member

Re: A bridge too far ?

Chaps,

I have just run 'debug arp' and received the following response :

IP ARP throttled out the ARP request for IP x.x.x.x

Does anyone know what this means and how to fix it ?

regards

Re: A bridge too far ?

Hi,

I beleive the problem is PPP.

Try to use HLDC or LAPB multi instead of it.

See http://www.cisco.com/univercd/cc/td/doc/product/software/ios122/122cgcr/fibm_c/bcfpart1/bcftb.htm#1002850

for config example.

Regards,

Milan

New Member

Re: A bridge too far ?

Hi

you have specified an ip address on the ethernet interface. for bridging that isn't necessary. do you really want the router to be ip addressable (for instance to telnet to it)?

if you have an ip address specified, the ip protocol gets automatically routed (you can check it with the command "show int crb").

therefore, you can either remove the ip address or you can the router "force" to bridge ip:

with

bridge 1 no route ip

regards

HRB

New Member

Re: A bridge too far ?

Hello,

many thanks for the previous replies to my problem. I have tried to change the encaps but this does not seem to make a difference, I still get the same debug messages. I have also tried the 'bridge 1 no route ip' command but it will not accept it. I have issued the no ip routing command, does this have the same effect ?

I have issued the 'sh int crb' command and get the following response :

1. Both int f0/0 and s0/0 sh ip protocol active and the the only mac addresses that has any traffic stats is the physical broadcasts. All other counters are zero.

I am only trying to set up a simple bridge ( i.e no routing at all on the router ) so I am not sure what else I can try. Any ideas ???

Bronze

Re: A bridge too far ?

Hi

What is your actual config? Can you post it?

Regards

Roger

New Member

Re: A bridge too far ?

Roger,

the config of the 2 routers is as above. I have tried little extras but they havent worked so I have removed them,

regards

Richard

New Member

Re: A bridge too far ?

All you need is at both ends;

no ip routing

int fast 0

bridge-group 1

no ip address

int serial 0

no ip address

bridge-group 1

bridge 1 protocol ieee

I see that IP addresses are existing on physical ports. These are really not needed.

You can also check whether bridging is active or not by using

show bridge

command. This would help you to see one side's MAC address table at the other side and vice versa.

Hope this helps,

Turkeer

164
Views
0
Helpful
13
Replies
CreatePlease to create content