Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

a problem of configuring a modem on aux port for exec dialin connectivity.

a Cisco 2501.configration line this:

Current configuration:

!

version 11.0

service udp-small-servers

service tcp-small-servers

!

hostname Router

!

!

chat-script dialout ABORT ERROR BUSY "" "AT" OK "ATDT\T" TIMEOUT 45 CONNECT\c

!

interface Ethernet0

ip address 192.168.0.253 255.255.255.0

!

interface Serial0

no ip address

shutdown

no fair-queue

!

interface Serial1

no ip address

shutdown

!

interface Async1

ip unnumbered Ethernet0

no ip directed-broadcast

encapsulation ppp

async default routing

async mode interactive

peer default ip address pool dialin_pool

no cdp enable

ppp authentication chap pap callin

!

ip local pool dialin_pool 192.168.0.100

ip route 0.0.0.0 0.0.0.0 Ethernet0

!

line con 0

line aux 0

script dialer dialout

modem InOut

autocommand ppp

transport input all

stopbits 1

rxspeed 38400

txspeed 38400

flowcontrol hardware

line vty 0 4

login

!

end

when callin use a terminal ,the state of async 1 like this:

Async1: Async protocol mode started for 192.168.0.100

Async1: Carrier dropped while interface starting up

%LINK-5-CHANGED: Interface Async1, changed state to reset

Async1: Async protocol mode stopped for 0.0.0.0

%LINK-3-UPDOWN: Interface Async1, changed state to down

Async1: Async protocol mode started for 192.168.0.100

%LINK-3-UPDOWN: Interface Async1, changed state to up

%LINK-5-CHANGED: Interface Async1, changed state to reset

Async1: Async protocol mode stopped for 0.0.0.0

%LINK-3-UPDOWN: Interface Async1, changed state to down

Async1: Async protocol mode started for 192.168.0.100

%LINK-3-UPDOWN: Interface Async1, changed state to up

%LINK-5-CHANGED: Interface Async1, changed state to reset

Async1: Async protocol mode stopped for 0.0.0.0

%LINK-3-UPDOWN: Interface Async1, changed state to down

Async1: Async protocol mode started for 192.168.0.100

%LINK-3-UPDOWN: Interface Async1, changed state to up

%LINK-5-CHANGED: Interface Async1, changed state to reset

Async1: Async protocol mode stopped for 0.0.0.0

%LINK-3-UPDOWN: Interface Async1, changed state to down

---------------

why?and what shall i do?

4 REPLIES
Cisco Employee

Re: a problem of configuring a modem on aux port for exec dialin

When you call in using a terminal and because of "autocommand ppp" configured under the line 1, router will start ppp after successful modem connection. So you will not get Router> prompt at terminal after connection and since the terminal can't start PPP, the async interface will reset after timeout.

To fix this, you need to use "autoselect ppp" instead. So enter

autoselect ppp

under the line 1. That will give you Router> prompt in the terminal

Silver

Re: a problem of configuring a modem on aux port for exec dialin

If you are trying an exec connection, remove the "autocommand ppp" from under the line aux 0 & add "autoselect ppp" instead. Need to see deb modem / deb ppp nego.

Thanks, Mak.

Community Member

Re: a problem of configuring a modem on aux port for exec dialin

I have done.use autoselect ppp instead.but the Terminal stop at the prompt

connect 33600 and some strange letter,then modem disconnect.

what's wrong?

thank you.

Silver

Re: a problem of configuring a modem on aux port for exec dialin

Has this ever worked before for an exec dialin? The strange letter could be due to a speed mismatch...try changing the speed on the dialup side.

If you have enough memory, try upgrading to maybe 11.3 atleast from the present 11.0.

Thanks, Mak.

1282
Views
0
Helpful
4
Replies
CreatePlease to create content