cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
335
Views
0
Helpful
4
Replies

About ISDN config

davidliji
Level 1
Level 1

customer asked for user-defined username instead of the default hostname of the router to configure two router connected by ISDN, generally, we configured router like:

RA(1.1.1.1)------(1.1.1.2)RB

-----

hostname RA

username RB pass xx

int bri0

dialer map ip 1.1.1.2 name RB b xxxx

-------

hostname RB

username RA pass xx

int bri0

dialer map ip 1.1.1.2 name RA b xxxx

but customer required implement another username, how can I do?

Thanks.

1 Accepted Solution

Accepted Solutions

!

hostname RouterA

!

username PeerB password cisco

!

isdn switch-type basic-dms100

!

interface Ethernet0

ip address 192.168.1.1 255.255.255.0

!

interface BRI0

ip address 172.16.20.1 255.255.255.0

encapsulation ppp

dialer map ip 172.16.20.2 name PeerB 1234

dialer-group 1

ppp authentication chap

ppp chap hostname PeerA

!

ip route 192.168.2.0 255.255.255.0 172.16.20.2

!

dialer-list 1 protocol ip permit

!

line con 0

line aux 0

line vty 0 4

password test

login

!

end

!

hostname RouterB

!

enable password test

!

username PeerA password cisco

!

interface Ethernet0

ip address 192.168.2.1 255.255.255.0

!

interface BRI0

ip address 172.16.20.2 255.255.255.0

encapsulation ppp

dialer idle-timeout 300

dialer map ip 172.16.20.1 name PeerA 5678

dialer-group 1

ppp authentication chap

ppp chap hostname PeerB

!

ip route 192.168.1.0 255.255.255.0 172.16.20.1

!

dialer-list 1 protocol ip permit

!

line con 0

line aux 0

line vty 0 4

password test

login

!

end

Hope this helps,

Harold Ritter
Sr Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México

View solution in original post

4 Replies 4

Harold Ritter
Cisco Employee
Cisco Employee

With CHAP, configure "ppp chap hostname xxx" under the bri interface, where xxx is the alternate username you want to use.

With PAP, you can use "ppp pap sent-username xxx password yyy"

Hope this helps,

Harold Ritter
Sr Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México

could you give me a complete configure?

thanks

!

hostname RouterA

!

username PeerB password cisco

!

isdn switch-type basic-dms100

!

interface Ethernet0

ip address 192.168.1.1 255.255.255.0

!

interface BRI0

ip address 172.16.20.1 255.255.255.0

encapsulation ppp

dialer map ip 172.16.20.2 name PeerB 1234

dialer-group 1

ppp authentication chap

ppp chap hostname PeerA

!

ip route 192.168.2.0 255.255.255.0 172.16.20.2

!

dialer-list 1 protocol ip permit

!

line con 0

line aux 0

line vty 0 4

password test

login

!

end

!

hostname RouterB

!

enable password test

!

username PeerA password cisco

!

interface Ethernet0

ip address 192.168.2.1 255.255.255.0

!

interface BRI0

ip address 172.16.20.2 255.255.255.0

encapsulation ppp

dialer idle-timeout 300

dialer map ip 172.16.20.1 name PeerA 5678

dialer-group 1

ppp authentication chap

ppp chap hostname PeerB

!

ip route 192.168.1.0 255.255.255.0 172.16.20.1

!

dialer-list 1 protocol ip permit

!

line con 0

line aux 0

line vty 0 4

password test

login

!

end

Hope this helps,

Harold Ritter
Sr Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México

thank you very much

:-)

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: