Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

about NAT - one local IP and two global IP

Hello,

I have a server in HQ. And it has only unique private ip address - 1.1.1.1 and it serves unique tcp port 701.

I have two branches- branch A and branch B.

My HQ has a 2620 router with two WIC-1ADSL. Each ADSL has one global ip address.

One ADSL-1 ip is 111.111.111.111 and the other ADSL-2 ip is 222.222.222.222.

By the way, I want to do traffic sharing -

Branch A use ADSL-1 and branch B use ADSL-2.

How should I do it?

1 ACCEPTED SOLUTION

Accepted Solutions
Bronze

Re: about NAT - one local IP and two global IP

You will need to set up static nat with route-maps. This feature is available on the 2620 in 12.2(4)T or higher...

http://www.cisco.com/univercd/cc/td/doc/product/software/ios122/122newft/122t/122t4/ftnatrt.htm

For example:

interface e0

ip address 1.1.1.2 255.255.255.0

ip nat inside

interface e1

ip address 111.111.111.111

ip nat outside

interface e2

ip address 222.2222.222.222

ip nat outside

ip nat inside source static 1.1.1.1 111.111.111.1 route-map ISP1

ip nat inside source static 1.1.1.1 222.222.222.2 route-map ISP2

route-map ISP1 permit 10

match ip address 100

route-map ISP2 permit 10

match ip address 101

access-list 100 permit 1.1.1.0 0.0.0.255 111.0.0.0 0.0.0.255

access-list 101 permit 1.1.1.0 0.0.0.255 222.0.0.0 0.0.0.255

1 REPLY
Bronze

Re: about NAT - one local IP and two global IP

You will need to set up static nat with route-maps. This feature is available on the 2620 in 12.2(4)T or higher...

http://www.cisco.com/univercd/cc/td/doc/product/software/ios122/122newft/122t/122t4/ftnatrt.htm

For example:

interface e0

ip address 1.1.1.2 255.255.255.0

ip nat inside

interface e1

ip address 111.111.111.111

ip nat outside

interface e2

ip address 222.2222.222.222

ip nat outside

ip nat inside source static 1.1.1.1 111.111.111.1 route-map ISP1

ip nat inside source static 1.1.1.1 222.222.222.2 route-map ISP2

route-map ISP1 permit 10

match ip address 100

route-map ISP2 permit 10

match ip address 101

access-list 100 permit 1.1.1.0 0.0.0.255 111.0.0.0 0.0.0.255

access-list 101 permit 1.1.1.0 0.0.0.255 222.0.0.0 0.0.0.255

90
Views
0
Helpful
1
Replies
CreatePlease to create content