Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Community Member

about OSPF routing.

SITE A (S0)----(64K DDN)---- (S0) SITE B (S1)----(512K FR)----(s0) SITE C (E0)

SITE A:

--------------------------------------------------------

interface e0

ip address 202.101.1.0 255.255.255.192

interface s0

ip address 202.101.224.2 255.255.255.252

ip route 192.1.1.0 255.255.255.0 202.101.224.1

SITE B:

----------------------------------------------------------

interface s0

ip address 202.101.224.1 255.255.255.252

interface s1

encapsulation frame-relay ietf

bandwidth 512

ip address 202.101.1.2 255.255.255.252

frame-relay map ip 202.101.1.1 387

router ospf 101

network 202.101.1.0 0.0.0.3 area 35

network 202.101.224 0.0.0.3 area 35

ip route 202.101.1.0 255.255.255.192 202.101.224.2

SITE C

---------------------------------------------------------------

interface s0

encapsulation frame-relay ietf

ip address 202.101.1.1 255.255.255.252

fram-relay map ip 202.101.1.2 935

router ospf 101

network 202.101.1.0 0.0.0.3 area 35

network 192.1.1.0 0.0.0.255 area 35

Now, from SITE C I can ping the s0 of SITE A, but can't ping E0 of SITE A, why? OSPF can't study route from static routing?

thks!

4 REPLIES
Silver

Re: about OSPF routing.

You've got at least two errors in your config. You have 202.101.1.0/30 assigned to a serial link and 202.101.1.0/26 assigned to the ethernet on router A. That is not going to work. Plus you have not told OSPF on router B to advertise static routes (look up the redistribute static command).

There may be more, but I stopped looking. Good luck and good hunting!

Vincent C Jones

www.networkingunlimited.com

Bronze

Re: about OSPF routing.

You are using the same network address on the ethernet in router A and the serial link between routers B and C, ie 202.101.1. This is not valid. The different masks do not make any difference.

Bronze

Re: about OSPF routing.

David,

In addition to what the two previous responders said, include the keyword "broadcast" at the end of the frame relay map statements so that broadcast and multicast packets (necessary for any routing protocol) will be sent accross the frame relay link.

Good Luck!

Mark

Community Member

Re: about OSPF routing.

Hi David,

The reason you can reach the serial port on Router A and not the Ethernet is that when a packet arrives at Router B it will see the serial 0 of Router A as being being directly connected and so pass the packet, however as it has no knowledge on how to get to the Ethernet of router A it will drop the packet.

As indicated by the previous writers you may want to redistribute static routes into OSPF on router B and also renumber your serial link (B to C) ,this should resolve your problem.

84
Views
0
Helpful
4
Replies
CreatePlease to create content