Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

About pppoe&adsl modem

Hi,all

Could you tell me whether pppoe can work well with all types of adsl modem or not ?Can I use cisco1720 plus wic-1enet card with adsl modem connected to internet?

  • Other Network Infrastructure Subjects
5 REPLIES
Cisco Employee

Re: About pppoe&adsl modem

YES..1700 with Ethernet WIC card can work as a PPPoE client with Adsl modem in Bridging mode..See the following url for more information about config etc

http://www.cisco.com/warp/public/794/wic_1enet_natclient.html

New Member

Re: About pppoe&adsl modem

tepatel,thanks for your reponse! Now,another problem comes up.Yesterday,I tried using router1720 as pppoe client but failed.When using 'debug vpdn pppoe-event' command,I got the following info:

00:05:54: %DIALER-6-UNBIND: Interface Vi1 unbound from profile Di1

ad50045108#debug vpdn pppoe-event

00:06:14: Sending PADI: Interface = Ethernet0

00:06:16: PPPOE: we've got our pado and the pado timer went off

00:06:16: OUT PADR from PPPoE tunnel

00:06:16: IN PADS from PPPoE tunnel

00:06:16: %DIALER-6-BIND: Interface Vi1 bound to profile Di1

00:06:16: PPPoE: Virtual Access interface obtained.

00:06:16: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to up

00:06:16: IN PADT from PPPoE tunnel

00:06:16: PPPoE : Shutting down client session

00:06:16: OUT PADT from PPPoE tunnel

When using 'show vpdn' command,I got the info:

ad50045108#sh vpdn

%No active L2TP tunnels

%No active L2F tunnels

%No active PPTP tunnels

PPPoE Tunnel and Session Information Total tunnels 1 sessions 1

PPPoE Tunnel Information

Session count: 1

PPPoE Session Information

SID RemMAC LocMAC Intf VASt OIntf VP/VC

983 0003.4b1a.4045 0004.dd0c.6982 Vi1 DOWN Et0

Could you give me some advice?

Thks

Cisco Employee

Re: About pppoe&adsl modem

pppoe-enents looks fine before we get PADT..We do get PADS from other side so after that we need to look on following debug before we get PADT.

debug ppp negotiation

debug ppp authentication

Pl. post it here..with config too..Thx..Tejal

New Member

Re: About pppoe&adsl modem

!******************cisco_router_1720_configuration**********************

ad50045108#sh run

Building configuration...

Current configuration : 2219 bytes

!

version 12.1

no service single-slot-reload-enable

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname ad50045108

!

boot system flash

no logging buffered

no logging buffered

logging rate-limit console 10 except errors

enable password cisco

!

memory-size iomem 25

ip subnet-zero

no ip finger

no ip domain-lookup

!

vpdn enable

no vpdn logging

!

vpdn-group pppoe

request-dialin

protocol pppoe

!

interface Ethernet0

no ip address

no ip route-cache

no ip mroute-cache

no keepalive

full-duplex

pppoe enable

pppoe-client dial-pool-number 1

!

interface FastEthernet0

description connected to lan

ip address 192.168.2.1 255.255.255.0

ip nat inside

speed auto

!

interface Dialer1

description connected to internet

ip address negotiated

ip mtu 1492

ip nat outside

rate-limit output access-group 101 64000 8000 8000 conform-action set-prec-continue 4 exceed-action drop

rate-limit output access-group 102 64000 8000 8000 conform-action set-prec-continue 4 exceed-action drop

encapsulation ppp

no ip route-cache

no ip mroute-cache

dialer pool 1

dialer-group 2

ppp authentication chap pap callin

ppp pap sent-username ad50045108 password 7 utyutty

!

router rip

version 2

passive-interface Dialer1

network 192.168.2.0

!

ip nat inside source list 1 interface Dialer1 overload

ip kerberos source-interface any

ip classless

ip route 0.0.0.0 0.0.0.0 Dialer1

no ip http server

!

access-list 1 permit 192.168.2.0 0.0.0.255

access-list 100 permit ip 192.168.2.0 0.0.0.255 192.168.1.0 0.0.0.255

access-list 101 permit ip any 202.96.192.16 0.0.0.3

access-list 101 permit ip any 192.168.1.0 0.0.0.255

access-list 102 permit tcp any 202.96.192.16 0.0.0.3

access-list 102 permit tcp any 192.168.1.0 0.0.0.255

dialer-list 2 protocol ip permit

!

line con 0

transport input none

line aux 0

line vty 0 4

password cisco

login

!

end

!****************************configuration_end**********************************

!****************************debug_ppp_authen********************************

ad50045108#debug ppp auth

PPP authentication debugging is on

ad50045108#

01:24:59: Vi1 Debug: Condition 1, interface Di1 triggered, count 1

01:24:59: %DIALER-6-BIND: Interface Vi1 bound to profile Di1

01:24:59: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to up

01:24:59: Vi1 PPP: Treating connection as a callout

01:24:59: Vi1 PAP: O AUTH-REQ id 219 len 19 from "ad50045108"

01:25:00: Vi1 PAP: I AUTH-NAK id 219 len 5

01:25:00: %DIALER-6-UNBIND: Interface Vi1 unbound from profile Di1

01:25:00: Vi1 Debug: Condition 1, interface Di1 cleared, count 0

01:25:22: Vi1 Debug: Condition 1, interface Di1 triggered, count 1

01:25:22: %DIALER-6-BIND: Interface Vi1 bound to profile Di1

01:25:22: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to up

01:25:22: Vi1 PPP: Treating connection as a callout

01:25:22: Vi1 PAP: O AUTH-REQ id 220 len 19 from "ad50045108"

01:25:22: Vi1 PAP: I AUTH-NAK id 220 len 5

01:25:22: %DIALER-6-UNBIND: Interface Vi1 unbound from profile Di1

01:25:22: Vi1 Debug: Condition 1, interface Di1 cleared, count 0

ad50045108#

*********************************************************************************

**********************************debug_ppp_negotiation*********************

ad50045108#debug ppp nego

PPP protocol negotiation debugging is on

ad50045108#

1d00h: Vi1 Debug: Condition 1, interface Di1 triggered, count 1

1d00h: %DIALER-6-BIND: Interface Vi1 bound to profile Di1

1d00h: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to up

1d00h: Vi1 PPP: Treating connection as a callout

1d00h: Vi1 PPP: Phase is ESTABLISHING, Active Open [0 sess, 1 load]

1d00h: Vi1 LCP: O CONFREQ [Closed] id 1 len 14

1d00h: Vi1 LCP: AuthProto PAP (0x0304C023)

1d00h: Vi1 LCP: MagicNumber 0x0A03E44F (0x05060A03E44F)

1d00h: Vi1 LCP: I CONFREQ [REQsent] id 25 len 18

1d00h: Vi1 LCP: MagicNumber 0x344B3D80 (0x0506344B3D80)

1d00h: Vi1 LCP: MRU 1500 (0x010405DC)

1d00h: Vi1 LCP: AuthProto PAP (0x0304C023)

1d00h: Vi1 LCP: O CONFACK [REQsent] id 25 len 18

1d00h: Vi1 LCP: MagicNumber 0x344B3D80 (0x0506344B3D80)

1d00h: Vi1 LCP: MRU 1500 (0x010405DC)

1d00h: Vi1 LCP: AuthProto PAP (0x0304C023)

1d00h: Vi1 LCP: I CONFREJ [ACKsent] id 1 len 8

1d00h: Vi1 LCP: AuthProto PAP (0x0304C023)

1d00h: Vi1 LCP: O CONFREQ [ACKsent] id 2 len 14

1d00h: Vi1 LCP: AuthProto PAP (0x0304C023)

1d00h: Vi1 LCP: MagicNumber 0x0A03E44F (0x05060A03E44F)

1d00h: Vi1 LCP: I CONFREJ [ACKsent] id 2 len 8

1d00h: Vi1 LCP: AuthProto PAP (0x0304C023)

1d00h: Vi1 LCP: O CONFREQ [ACKsent] id 3 len 14

1d00h: Vi1 LCP: AuthProto PAP (0x0304C023)

1d00h: Vi1 LCP: MagicNumber 0x0A03E44F (0x05060A03E44F)

1d00h: Vi1 LCP: I CONFREJ [ACKsent] id 3 len 8

1d00h: Vi1 LCP: AuthProto PAP (0x0304C023)

1d00h: Vi1 LCP: O CONFREQ [ACKsent] id 4 len 14

1d00h: Vi1 LCP: AuthProto PAP (0x0304C023)

1d00h: Vi1 LCP: MagicNumber 0x0A03E44F (0x05060A03E44F)

1d00h: Vi1 LCP: I CONFREJ [ACKsent] id 4 len 8

1d00h: Vi1 LCP: AuthProto PAP (0x0304C023)

1d00h: Vi1 LCP: O CONFREQ [ACKsent] id 5 len 14

1d00h: Vi1 LCP: AuthProto PAP (0x0304C023)

1d00h: Vi1 LCP: MagicNumber 0x0A03E44F (0x05060A03E44F)

1d00h: Vi1 LCP: I CONFREJ [ACKsent] id 5 len 8

1d00h: Vi1 LCP: AuthProto PAP (0x0304C023)

1d00h: Vi1 LCP: O CONFREQ [ACKsent] id 6 len 14

1d00h: Vi1 LCP: AuthProto PAP (0x0304C023)

1d00h: Vi1 LCP: MagicNumber 0x0A03E44F (0x05060A03E44F)

1d00h: Vi1 LCP: I CONFREJ [ACKsent] id 6 len 8

1d00h: Vi1 LCP: AuthProto PAP (0x0304C023)

1d00h: Vi1 LCP: O CONFREQ [ACKsent] id 7 len 14

1d00h: Vi1 LCP: AuthProto PAP (0x0304C023)

1d00h: Vi1 LCP: MagicNumber 0x0A03E44F (0x05060A03E44F)

1d00h: Vi1 LCP: I CONFREJ [ACKsent] id 7 len 8

1d00h: Vi1 LCP: AuthProto PAP (0x0304C023)

1d00h: Vi1 LCP: O CONFREQ [ACKsent] id 8 len 14

1d00h: Vi1 LCP: AuthProto PAP (0x0304C023)

1d00h: Vi1 LCP: MagicNumber 0x0A03E44F (0x05060A03E44F)

1d00h: Vi1 LCP: I CONFREJ [ACKsent] id 8 len 8

1d00h: Vi1 LCP: AuthProto PAP (0x0304C023)

1d00h: Vi1 LCP: O CONFREQ [ACKsent] id 9 len 14

1d00h: Vi1 LCP: AuthProto PAP (0x0304C023)

1d00h: Vi1 LCP: MagicNumber 0x0A03E44F (0x05060A03E44F)

1d00h: Vi1 LCP: I CONFREJ [ACKsent] id 9 len 8

1d00h: Vi1 LCP: AuthProto PAP (0x0304C023)

1d00h: Vi1 LCP: O CONFREQ [ACKsent] id 10 len 14

1d00h: Vi1 LCP: AuthProto PAP (0x0304C023)

1d00h: Vi1 LCP: MagicNumber 0x0A03E44F (0x05060A03E44F)

1d00h: Vi1 LCP: I CONFREJ [ACKsent] id 10 len 8

1d00h: Vi1 LCP: AuthProto PAP (0x0304C023)

1d00h: Vi1 LCP: O CONFREQ [ACKsent] id 11 len 14

1d00h: Vi1 LCP: AuthProto PAP (0x0304C023)

1d00h: Vi1 LCP: MagicNumber 0x0A03E44F (0x05060A03E44F)

1d00h: Vi1 LCP: I CONFREJ [ACKsent] id 11 len 8

1d00h: Vi1 LCP: AuthProto PAP (0x0304C023)

1d00h: Vi1 LCP: Failed to negotiate with peer

1d00h: Vi1 LCP: O TERMREQ [ACKsent] id 12 len 4

1d00h: Vi1 LCP: I TERMACK [TERMsent] id 12 len 4

1d00h: Vi1 LCP: State is Closed

1d00h: Vi1 PPP: Phase is DOWN [0 sess, 1 load]

1d00h: %DIALER-6-UNBIND: Interface Vi1 unbound from profile Di1

1d00h: Vi1 Debug: Condition 1, interface Di1 cleared, count 0

************************************************************************************

Thks for your response in time!

Cisco Employee

Re: About pppoe&adsl modem

From the PPP negotiations, isp is keep rejecting PAP..You can see the following

1d00h: Vi1 LCP: I CONFREJ [ACKsent] id 2 len 8

1d00h: Vi1 LCP: AuthProto PAP (0x0304C023)

But isp wants to do PAP with us..Its odd to get "CONFREJ" for PAP.

Try only chap using

ppp authentication chap callin

ppp chap hostname

ppp chap password

Also using pap only.

See if that makes any difference..

321
Views
0
Helpful
5
Replies