Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Accessing my switch

Hello

Can someone explain why I get a colon symbol ( switch : ) insteady of the greater than symbol ( switch > ) when I try to access the 2900 series catalyst switch thru Putty.

1 ACCEPTED SOLUTION

Accepted Solutions

The switch is in rommon mode.

The switch is in rommon mode.

issue a "flash_init" then a "load_helper" followed by a "boot" to get it to come back up. Thsi will work as long as there is a valid image in flash and flash is good. Flash does go bad from time to time.

Rate useful posts and mark answers as correct if applicable.

Please rate useful posts and mark answers as correct if applicable.
6 REPLIES

The switch is in rommon mode.

The switch is in rommon mode.

issue a "flash_init" then a "load_helper" followed by a "boot" to get it to come back up. Thsi will work as long as there is a valid image in flash and flash is good. Flash does go bad from time to time.

Rate useful posts and mark answers as correct if applicable.

Please rate useful posts and mark answers as correct if applicable.
Bronze

Hello,there are 2 options:1st

Hello,
there are 2 options:
1st - you don´t have IOS in flash and you must perform IOS recovery.

2nd - you have enabled "manual boot". Here is nice example how to turn off manual boot:
https://supportforums.cisco.com/document/11701/cisco-catalyst-2940-2950-2955-2900xl-3550-3500xl-or-3750-switch-does-not-boot

If commands from above post helped, it means that you have IOS in flash and you only performed manual boot. Follow manual on link in my post to enable automatic boot.

New Member

What are the steps to perform

What are the steps to perform a IOS recovery ?

New Member

Google is an amazing tool... 

Google is an amazing tool... 

http://networking.ringofsaturn.com/Cisco/catalyst2900XLpassword.php

Bronze

Google is amazing but you

Google is amazing but you found password recovery, not IOS.

1st question is that if you got command prompt "Switch:" and you typed commands flash_init and boot, if switch booted normally or not.
If switch booted normally then follow manual how to turn off manual boot on link in my first post.

Otherwise you will need IOS recovery.
At first you will need to have IOS (file with appendix .bin or something like that) for your switch.You will also need application which supports xmodem file transfer (putty doesn´t have it, but MS Hyperterminal has it - it is part of MS Windows XP).

Then if you have "Switch:" prompt:
(you can type:
switch:flash_init
and
switch:format flash:
to erase all data in flash)

1. To speed up whole process it is recommended to increase console speed with command:
switch:set BAUD 115200
After this command you will lose console connection. You must end application (putty, Hyperterminal) and start it again with parameters speed 115200/8 data bit/1 stop bit/no HW controll/no parity

2. Then type command:
switch:copy xmodem: flash:name_of_your_ios.bin

3. In Hyperterminal click on menu "Transfer" and select "Send File". Select protocol "Xmodem" and file - your IOS for switch.

4. Click "Send" to send file

5. (optional) Go to kitchen and make a cup of coffee (because transfer of file via xmodem takes a long time)

6. Type command (to boot your new IOS):
switch: boot flash:name_of_your_ios.bin

7. You can return back console speed to 9600 baud with command:
switch:set BAUD 9600
or
switch:unset BAUD

you lose console connection and you must reconnect with correct speed. This reverts settings from step 1.

You needn´t do step 1 and 7 but whole process takes very long time.

New Member

If switch didn't boot

If switch didn't boot normally, then you have a corrupt IOS or the IOS is not existent.. Usually after a flash_init, i'll do dir flash: just to see what is on the flash.

Also to take it one step farther. Accessing the switch, you had already done by even accessing into ROMMON mode. Your issue is in regards to be booting an image on your switch.

208
Views
0
Helpful
6
Replies
CreatePlease to create content