Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

AclmServer is "Running but busy flag set " after installation

In the Process Status, AclmServer is allways "Running but busy flag set ",and it can not work, what's the matter of it?

thanks firstly.

9 REPLIES
Cisco Employee

Re: AclmServer is "Running but busy flag set " after installatio

These are some of the states of the AclmServer process

"Administrator has shut down this server": implies AclmServer is not running

"Program started - No mgt msgs received": implies AclmServer is in the process of coming up

"Running but busy flag set ": implies that AclmServer is up and running (one can safely ignore the part "busy flag set"). All functionalities of ACLM like "Edit ACLs", "Edit Templates", etc will now be available.

In your case, AclmServer is in the running state and so you should be able to access the AclmServer via "Edit Acls", "Edit Templates", etc. Do let us know if you are facing any problem.

Meanwhile, can you please let us know the version of AclManager.

Thanks

Rajesh

New Member

Re: AclmServer is "Running but busy flag set " after installatio

The problem is that I can not access the AclmServer via "Edit Acls", "Edit Templates", etc.

I have reinstall the CD1 and RME and ACL again, the problem is still there.

Cisco Employee

Re: AclmServer is "Running but busy flag set " after installatio

Hi Chu,

Can you please forward your mail to cs-aclm@cisco.com with the following info (you get a wider audience here)

- any messages/errors when clicking on "Edit ACLs" like "Failed to connect to AclmServer"

- any messages in aclm.log present under

/objects/aclm in solaris or

\objects\aclm in windows

- any messages in the Java console

- versions of AclManager, RME

Thanks,

Rajesh

New Member

Re: AclmServer is "Running but busy flag set " after installatio

# pwd

/opt/CSCOpx/objects/aclm

# ls -l

total 16

-rw-r----- 1 casuser casusers 207 May 16 11:33 aclm.log

-rw-r----- 1 casuser casusers 256 May 16 11:29 aclm.log1

drwxr-xr-x 2 casuser casusers 512 May 16 10:38 bin

drwxr-xr-x 3 casuser casusers 512 May 16 10:38 com

drwxr-xr-x 7 casuser casusers 512 May 16 10:40 data

drwxr-xr-x 3 casuser casusers 512 May 16 10:38 etc

drwxr-xr-x 2 casuser casusers 512 May 16 10:38 jarfiles

drwxr-xr-x 2 casuser casusers 512 May 16 10:38 patch

# more aclm.log1

Informational: AclmServer starting Cisco Process Manager communication thread

EnableFirewall property is set to use firewall in aclm.properties.

Initializing ACLM server...

Initializing ACLM server...done.

ShutDown requested from the Cisco Process Manager

# more aclm.log

Informational: AclmServer starting Cisco Process Manager communication thread

EnableFirewall property is set to use firewall in aclm.properties.

Initializing ACLM server...

Initializing ACLM server...done.

software version:

ACL Manager 1.4

Resource Manager Essentials 3.4

when clicking on "Edit ACLs, it seemed that something are running but there is nothing on the

screen will occure.

when clicking on RME->Administration->ACL Management->Edit ACL Templates, it is "Running

Template Manager..."

Select Resource Manager Essentials > Administration > Job Approval > Edit Preferences, at the

ACL Manager tab, there is a "Unable to connect to ACLM server".

Cisco Employee

Re: AclmServer is "Running but busy flag set " after installatio

Can you tell us the browser versions? Are you observing similar symtoms on both IE and netscape?

It will be great if you can direct your messages to cs-aclm@cisco.com

Thanks,

Rajesh

New Member

Re: AclmServer is "Running but busy flag set " after installatio

Yes, I observed similar symtoms on both IE and netscape. IE version:6.0 netscape version:4.76

I have sent a mail to cs-aclm@cisco.com

Does it matter that the NMS server was access from browser through NAT, means that NMS server's IP is 10.*.*.*, map to a IP 211.*.*.* ?

thanks

New Member

Re: AclmServer is "Running but busy flag set " after installatio

Hi,

ACLM does not work over NAT. This is because CORBA does not work under such circumstances.

Thanks,

~oreetham

New Member

Re: AclmServer is "Running but busy flag set " after installatio

It seemed that NAT is not the reason.

When just reboot the server, nothing has been done, I can see the status of aclm is busy yet.

thanks

Cisco Employee

Re: AclmServer is "Running but busy flag set " after installatio

"ACLM does not work over NAT" implies that the CLIENT cannot connect to AclmServer. That is why you are not able to see any activity after asserting

"Edit ACLs" or "Edit Templates". Nevertheless, the AclmServer appears to be working fine which is rightly indicated by "Running but Busy flag set" (you can ignore the "busy" mentioned in the message) and the log messages.

Thanks,

Rajesh

230
Views
0
Helpful
9
Replies
CreatePlease to create content