Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

adding routes onto 3550

If I configuring intervlan routing on my 3550, by giving the vlans ip addresses, how do I get these different vlans to go the the internet via my internet router, do I need to put a valid ip on my router and then just add a default route to this on the 3550 ?

thanks

3 REPLIES
VIP Purple

Re: adding routes onto 3550

Hello,

exactly. Let´s say your 3550 looks like this:

3550

!

interface Vlan1

ip address 192.168.1.1 255.255.255.0

!

interface Vlan2

ip address 192.168.2.1 255.255.255.0

!

interface Vlan3

ip address 192.168.3.1 255.255.255.0

And your router looks like this (provided that router is directly connected to the 3550):

Internet_Router

!

interface FastEthernet0/0

description connected to 3550

ip address 172.16.1.1 255.255.255.0

Now, on the 3550, you would put a static route in, pointing to the IP address of FastEthernet0/0 on the Internet_Router:

3550

!

ip routing

!

ip route 0.0.0.0 0.0.0.0 172.16.1.1

The Internet_Router itself obviously needs a route as well pointing to the Internet...

Does that make sense ?

Regards,

GP

Re: adding routes onto 3550

Carl,

You pretty much you have the right idea here is an example. I created 4 vlans on the switch set a default route pointed to the router and created routes pointing back to the switch for the different vlans not connected to the router.

Routercfg#

interface fa0/0

description connected to vlan 1

ip address 10.1.1.2 255.255.255.0

interface fa0/1

description connected to internet

ip address x.x.x.x 255.255.255.x

ip route 10.1.2.0 255.255.255.0 10.1.1.1

ip route 10.1.3.0 255.255.255.0 10.1.1.1

ip route 10.1.4.0 255.255.255.0 10.1.1.1

ip route 0.0.0.0 0.0.0.0 x.x.x.x

3550cfg#

ip routing

!

interface vlan 1

description vlan 1

ip address 10.1.1.1 255.255.255.0

interface vlan 2

ip address 10.1.2.1 255.255.255.0

interface vlan 3

ip address 10.1.3.1 255.255.255.0

interface vlan 4

ip address 10.1.4.1 255.255.255.0

!

ip route 0.0.0.0 0.0.0.0 10.1.1.2

Please remember to rate posts that are helpful.

New Member

Re: adding routes onto 3550

So I gather you can just put the router on any address of any of the vlans, and then put all the routes back to one of the vlans, the switch will then route the traffic back to that particular vlan ?

Am I correct !!

423
Views
0
Helpful
3
Replies
CreatePlease to create content