Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

adsl failover to ISDN

My primary line is running on ADSL and will failover to ISDN with config below but unfortnately inorder to get every ws to access internet,we need to removed IP NAT source list 1 interface dialer1 inorder to get it run but once removed the ADSL connection will not work again.Any advise.

Building configuration...

Current configuration : 1930 bytes

!

version 12.3

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname Router1721

!

enable secret xxxxx

!

no aaa new-model

ip subnet-zero

!

!

!

isdn switch-type basic-net3

!

!

!

!

interface ATM0

--More-- no ip address

backup delay 1 1

backup interface Dialer2

no atm ilmi-keepalive

pvc 0/35

encapsulation aal5mux ppp dialer

dialer pool-member 1

!

dsl operating-mode auto

hold-queue 224 in

!

interface BRI0

no ip address

ip nat outside

encapsulation ppp

dialer rotary-group 2

dialer-group 2

isdn switch-type basic-net3

!

interface FastEthernet0

ip address 192.168.186.223 255.255.255.0

ip nat inside

speed auto

--More-- !

interface Dialer1

description Connection to ADSL

ip address negotiated

ip nat outside

encapsulation ppp

dialer pool 1

dialer-group 1

ppp authentication pap callin

ppp chap hostname xxxx

ppp chap password xxxx

ppp pap sent-username xxxpassword xxxx!

interface Dialer2

description Backup ISDN

ip address negotiated

ip nat outside

encapsulation ppp

no ip split-horizon

dialer in-band

dialer idle-timeout 300

dialer string 1525

dialer hold-queue 10

--More-- dialer-group 2

ppp authentication chap pap callin

ppp chap hostname assbpg

ppp chap password xxxxx

ppp pap sent-username xxxx password xxxxxxxxxxxx ppp multilink

!

router rip

network 192.168.186.0

!

ip nat inside source list 1 interface Dialer1 overload

ip nat inside source list 2 interface Dialer2 overload

ip classless

ip route 0.0.0.0 0.0.0.0 Dialer1

ip route 0.0.0.0 0.0.0.0 Dialer2

no ip http server

!

access-list 1 permit 192.168.186.0 0.0.0.255

access-list 2 permit 192.168.186.0 0.0.0.255

dialer-list 1 protocol ip permit

dialer-list 2 protocol ip permit

!

line con 0

--More-- line aux 0

line vty 0 4

password xxxx

login

!

no scheduler allocate

!

end

  • Other Network Infrastructure Subjects
3 REPLIES
New Member

Re: adsl failover to ISDN

Looks like you are using dialer 1 as the primary interface, but the backup interface command is on the ATM physical interface itself.

Can you try putting the "backup interface" command on dialer 1 istead?

New Member

Re: adsl failover to ISDN

just done some checking.. you can't actually issue "backp interface" on the dialer... is it possible to use the physical interface instead of dialer 1 for the adsl?

New Member

Re: adsl failover to ISDN

try it by setting this config on dialer1.By exchanging ADSL as the primary line and my ISDN as backup line.

backup delay 1 1

backup interface dialer2

Any advise.

76
Views
0
Helpful
3
Replies
This widget could not be displayed.