Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

ADSL with ISDN dial backup

I am attempting to configure a 1721 router (12.2.13t3) with an ADSL connection and an ISDN backup. Individually both parts of the config work fine, but when I put them together I have been unable to get the backup working. The ATM will go down, and the dialer1 initialises, but does not attempt to dial. Any suggestions would be appreciated.

ip subnet-zero

!

!

isdn switch-type basic-ts013

!

!

!

interface ATM0

bandwidth 1500

no ip address

backup delay 10 120

backup interface Dialer1

no atm ilmi-keepalive

pvc 8/35

encapsulation aal5mux ppp dialer

dialer pool-member 1

!

dsl operating-mode auto

!

interface BRI0

description connected to Internet

no ip address

encapsulation ppp

dialer pool-member 2

isdn switch-type basic-ts013

no cdp enable

!

interface FastEthernet0

ip address x.x.x.x 255.255.255.248

speed auto

!

interface Dialer0

ip address x.x.x.x 255.255.255.0

encapsulation ppp

dialer pool 1

no cdp enable

ppp authentication chap callin

ppp chap hostname ********

ppp chap password ********

!

interface Dialer1

description connected to Internet

ip address x.x.x.x 255.255.255.192

ip accounting output-packets

encapsulation ppp

no ip split-horizon

dialer pool 2

dialer idle-timeout 600

dialer enable-timeout 120

dialer string xxxxxxx

dialer hold-queue 10

no cdp enable

ppp authentication chap pap callin

ppp chap hostname ********

ppp chap password ********

ppp pap sent-username ********

ppp multilink

multilink load-threshold 1 either

!

ip classless

ip route 0.0.0.0 0.0.0.0 Dialer0

ip route 0.0.0.0 0.0.0.0 Dialer1 10

dialer-list 1 protocol ip permit

9 REPLIES
New Member

Re: ADSL with ISDN dial backup

You have given back up interface as dialer interface under the atm interface.

This should be bri 0. Coz, this is the D channel which is responsible for call set up and call tear down and call maintainance.

Also specify the ppp multilink under the bri 0 interface.

-Deepau

Cisco Employee

Re: ADSL with ISDN dial backup

The config scheme is fine.. You can use backup interface to dialer 1 as dialer 1 is linked with the bri interface using "dialer pool .." command. Its basically a dialer profile config.

Now once the atm interface will go down, you will see the dialer 1 interface comeout of "standby" mode and become "up/up spoofing" After that the interesting traffic should be able to trigger the dialout using dialer 1 interface.

But looking on the config under the interface dialer 1, command "dialer-group 1" is missing. You also need to add the remote-name presented by isp using "dialer remote-name xyz" where xyz is the name presented by isp side during authentication. Add "ppp authentication chap callin" under the bri interface too so the the call will be binded to dialer 1 during authentication.

Also you need to remove "ip route 0.0.0.0 0.0.0.0 Dialer0" as dialer 0 is not used anyway for dialout.

So once you add that, the backup should work fine.

Here is the link which discuss the isdn backup using backup interface command and using dialer profile

http://www.cisco.com/warp/public/129/bri-back-dp.html

New Member

Re: ADSL with ISDN dial backup

Hi,

I think the configuration is almost correcr. I faced the same problem here also. I noticed that when the atm interface 0 is down, but the dialer 0 is still active and spfooping, that why the floating static route can not kickon and the isdn can not dial. any idea how to make the dialer0 become down ,down when the atm 0 is down

New Member

Re: ADSL with ISDN dial backup

I suspect Dialer1 needs the dialer-group 1 command in order for interesting traffic to dial the destination.

See second disadvantage of Backup Interfaces in http://www.cisco.com/warp/public/123/backup-main.html

Silver

Re: ADSL with ISDN dial backup

Hate to burst your bubble, but even if you get this configuration to work, it won't help much because the approach is fundamentally flawed. Most of the time that DSL goes down, the interface stays up and backup interface will never kick in.

You need to use "ping based routing" to detect link down and establish the replacement default route. You can then use dial on demand for the dial backup. If you have a cco login, go to www.cisco.com/en/US/customer/products/sw/iosswrel/ps5413/products_feature_guide09186a00801d862d.html

(replace "customer" in the URL with "partner" if that is your kind of login). If you don't have a login, try searching on ping based routing or object tracking. Note that this feature requires IOS 12.3(8)T at a minimum.

Good luck and have fun!

Vincent C Jones

http://www.networkingunlimited.com

New Member

Re: ADSL with ISDN dial backup

Good one, vcjones. I was wondering if "Reliable static routing backup using object tracking" works with PPPoA. The document only mentions its use for PPPoE and IPSec VPN.

New Member

Re: ADSL with ISDN dial backup

Good one, vcjones. I was wondering if "Reliable static routing backup using object tracking" works with PPPoA. The document only mentions its use for PPPoE and IPSec VPN.

New Member

Re: ADSL with ISDN dial backup

Did you get your configuration with "backup routing using object tracking" working.

I´m trying to do the same with a 836 but having problems with it.

As soon as I configure it like it is described in this document, the tracked route will never come up.

New Member

Re: ADSL with ISDN dial backup

Unfortunately, I have not configured it yet as I have some other problem preventing me from configuring it.

When you say the tracked route, I suppose you mean the primary route. Are you saying that the backup route is constantly up?

286
Views
3
Helpful
9
Replies