Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Aironet 1230b roaming issue with Catalyst Express 500

We have five 1200 series APs connected to a network. Three access points are connected via the Catalyst 500. Two others are physically separated and connect via other (unknown) switches to the network.

When the wireless client roams between an access point on the Catalyst to one of the other two, IP communications survive. However, when a wireless client roams between two APs connected to the Catalyst the IP level connection is dropped.

The port type for all three WAPs is "Access Point".

The access points see that the client has roamed (this appears in the log of each).

On looking at the log on the Catalyst I see the error "Access denied to one or more connecting devices" - the MAC address shown is that of the test laptop. The security setting on the Catalyst is set to default (low).

Is there something we have missed?

6 REPLIES
New Member

Re: Aironet 1230b roaming issue with Catalyst Express 500

In further testing we have noticed that when we view the status of the switch using Cisco Network Assistant the IP address of the device apparently connected to the port shows up as the wireless *client's IP address* and NOT the *access point's IP address*.

It *appears* that the switch associates the port with the wireless client rather than the access point itself. If this is true, it explains the "access denied" error (as obviously you cannot connect the same mac/ip to two different ports).

Either way, a speedy resolution would be appreciated.

New Member

Re: Aironet 1230b roaming issue with Catalyst Express 500

I am having the same error. I have 9 AP 1100 and when the 7920 roams audio is lost. However when you walk back to the original AP audio comes back. The logs on the AP says that the 7920 is roaming.

I am troubleshooting, if I discover something I'll let you know.

I might not gave you a solution but at least now you know that you are not the only one with this problem.

New Member

Re: Aironet 1230b roaming issue with Catalyst Express 500

Gents,

I have been having a similar problem with 7920s, 1242APs and Express500s. I raised it with TAC and apparantly there is new software for the Express500 due out that should fix it. I await with baited breath.

Steve

New Member

Re: Aironet 1230b roaming issue with Catalyst Express 500

The new version of software has been released today.

Steve

Green

Re: Aironet 1230b roaming issue with Catalyst Express 500

Are you using Wireless Services / WDS?

I'm not sure it's significant your situation, but thought I'd toss it in as a possibility.

In general, the Inter-Access Point Protocol (IAPP) should handle the hand off and cause the disassociation from AP1 before / at the same time as the association with AP2.

All of that may be happening, but it seems that the switch is not clearing the ARP cache when it sees the same MAC appear at a different port.

Perhaps it's a security setting, perhaps it's a setting for the ARP handling on the e500.

There is/was a similar problem with Symbol wireless devices talking through a 6500 switch (two ports with the same MAC produced errors that caused "Port Flapping" errors on the switch).

Anyway, what I'm thinking is that perhaps you need to have WDS active to activate the IAPP, then the "Wireless Aware" switch could snoop the IAPP messages and clear the disassociated port's ARP (and other tables to ensure proper dispositon of the traffic).

LIke I said, I'm not sure it would help/hurt, but I thought I'd toss it out as another possibility.

Good Luck

Scott

New Member

Re: Aironet 1230b roaming issue with Catalyst Express 500

I have the similiar problem in using AP1121 & CE500. WDS is created and other APs works as infrastructure AP. But client devices still having problem in roaming situation. All roaming (fixed IP but not dhcp) clients can "ping" the access point but traffic can't be passed through to LAN. Contacted TAC support but still no answer.

196
Views
0
Helpful
6
Replies
CreatePlease to create content