cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
436
Views
0
Helpful
5
Replies

Analyze the STP problem

ericlinji
Level 1
Level 1

There are three cisco switches in my network, which are connected as following:

3550-12T <--------> 3550-24-EMI

\ /

\ /

\ /

2950T-24

I configured 802.1q trunk between the two 3550 switches, and links between 2950 and 3550 are access layer type. The configuration of each switch is attached at the end. I set 3550-12T as primary root switch for VLAN15, and 3550-24-EMI as secondary root switch for VLAN15, and 2950T-24 is connected to the access ports of 3550 switches( belong to VLAN15). When I checked the spanning tree status of the three switches, I found the port of 3550-24-EMI connecting to 2950T-24 is in the block state, while in 2950T-24, the corresponding port is still in the forwarding state. And I also found the STP instances of the two switches are different. Can anyone help me analyze the problem? And give me some advices. Thanks in advance.

3550-12T:

...

hostname cnccb-sw1

spanning-tree extend system-id

spanning-tree vlan 1 priority 24576

spanning-tree vlan 9 priority 24576

spanning-tree vlan 10 priority 24576

spanning-tree vlan 11 priority 24576

spanning-tree vlan 12 priority 24576

spanning-tree vlan 13 priority 24576

spanning-tree vlan 15 priority 24576

!

interface GigabitEthernet0/1

switchport access vlan 13

switchport mode access

no ip address

!

interface GigabitEthernet0/2

switchport access vlan 13

switchport mode access

no ip address

!

interface GigabitEthernet0/3

switchport mode access

no ip address

!

interface GigabitEthernet0/4

switchport mode access

no ip address

!

interface GigabitEthernet0/5

switchport access vlan 9

switchport mode access

no ip address

!

interface GigabitEthernet0/6

switchport access vlan 10

switchport mode access

no ip address

!

interface GigabitEthernet0/7

switchport access vlan 9

switchport mode access

no ip address

!

interface GigabitEthernet0/8

switchport access vlan 15

switchport mode access

no ip address

!

interface GigabitEthernet0/9

description connected to WS-C2950T-24 (Port GigabitEthernet0/1)

switchport access vlan 15

switchport mode access

no ip address

!

interface GigabitEthernet0/10

description connected to WS-C3550-24-EMI (Port FastEthernet0/24)

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1-12,15-4094

switchport mode trunk

no ip address

!

interface GigabitEthernet0/11

no ip address

!

interface GigabitEthernet0/12

no ip address

!

interface Vlan1

no ip address

shutdown

!

interface Vlan9

ip address 172.31.9.253 255.255.255.0

no ip redirects

no ip route-cache

no ip mroute-cache

standby 9 ip 172.31.9.254

standby 9 priority 200

standby 9 preempt

standby 9 track Vlan9 40

!

interface Vlan10

ip address 172.31.10.253 255.255.255.0

no ip redirects

no ip route-cache

no ip mroute-cache

standby 10 ip 172.31.10.254

standby 10 priority 200

standby 10 preempt

standby 10 track Vlan10 40

!

interface Vlan11

ip address 172.31.11.253 255.255.255.0

no ip redirects

no ip route-cache

no ip mroute-cache

standby 11 ip 172.31.11.254

standby 11 priority 200

standby 11 preempt

standby 11 track Vlan11 40

!

interface Vlan12

ip address 172.31.12.253 255.255.255.0

no ip redirects

no ip route-cache

no ip mroute-cache

standby 12 ip 172.31.12.254

standby 12 priority 200

standby 12 preempt

standby 12 track Vlan12 40

!

interface Vlan13

ip address 172.31.13.254 255.255.255.0

no ip route-cache

no ip mroute-cache

!

interface Vlan15

ip address 172.31.15.253 255.255.255.0

no ip redirects

no ip route-cache

no ip mroute-cache

standby 15 ip 172.31.15.254

standby 15 priority 200

standby 15 preempt

standby 15 track Vlan15 40

!

router ospf 110

log-adjacency-changes

redistribute static subnets

network 172.31.9.0 0.0.0.255 area 0

network 172.31.10.0 0.0.0.255 area 0

network 172.31.11.0 0.0.0.255 area 0

network 172.31.12.0 0.0.0.255 area 0

network 172.31.13.0 0.0.0.255 area 0

network 172.31.15.0 0.0.0.255 area 0

!

...

VTP Configuration:

cnccb-sw1#show vtp status

VTP Version : 2

VTP Operating Mode : Server

VTP Domain Name : Soliton

VTP Pruning Mode : Disabled

VTP V2 Mode : Enabled

VTP Traps Generation : Disabled

3550-24-EMI:

...

hostname cnccb-sw2

spanning-tree extend system-id

spanning-tree vlan 1 priority 28672

spanning-tree vlan 9 priority 28672

spanning-tree vlan 10 priority 28672

spanning-tree vlan 11 priority 28672

spanning-tree vlan 12 priority 28672

spanning-tree vlan 14 priority 24576

spanning-tree vlan 15 priority 28672

!

!

!

interface FastEthernet0/1

switchport access vlan 14

switchport mode access

no ip address

no cdp enable

!

interface FastEthernet0/2

switchport access vlan 14

switchport mode access

no ip address

no cdp enable

!

interface FastEthernet0/3

switchport mode access

no ip address

no cdp enable

!

interface FastEthernet0/4

switchport mode access

no ip address

no cdp enable

!

interface FastEthernet0/5

switchport access vlan 9

switchport mode access

no ip address

no cdp enable

!

interface FastEthernet0/6

switchport access vlan 11

switchport mode access

no ip address

no cdp enable

!

interface FastEthernet0/7

switchport access vlan 9

switchport mode access

no ip address

no cdp enable

!

interface FastEthernet0/8

switchport access vlan 11

switchport mode access

no ip address

no cdp enable

!

interface FastEthernet0/9

description connected to WS-C2950T-24 (Port FastEthernet0/24)

switchport access vlan 15

switchport mode access

no ip address

no cdp enable

!

interface FastEthernet0/10

switchport mode access

no ip address

no cdp enable

!

...

interface FastEthernet0/24

decription connected to WS-C3550-12T (Port GigabitEthernet0/10)

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 1-12,15-4094

switchport mode trunk

no ip address

no cdp enable

!

interface GigabitEthernet0/1

no ip address

no cdp enable

!

interface GigabitEthernet0/2

no ip address

no cdp enable

!

interface Vlan1

no ip address

no ip mroute-cache

shutdown

!

interface Vlan9

ip address 172.31.9.252 255.255.255.0

no ip redirects

no ip mroute-cache

ip ospf cost 20

standby 9 ip 172.31.9.254

standby 9 priority 100

standby 9 preempt

!

interface Vlan10

ip address 172.31.10.252 255.255.255.0

no ip redirects

no ip mroute-cache

ip ospf cost 20

standby 10 ip 172.31.10.254

standby 10 priority 100

standby 10 preempt

!

interface Vlan11

ip address 172.31.11.252 255.255.255.0

no ip redirects

no ip mroute-cache

ip ospf cost 20

standby 11 ip 172.31.11.254

standby 11 priority 100

standby 11 preempt

!

interface Vlan12

ip address 172.31.12.252 255.255.255.0

no ip redirects

no ip mroute-cache

ip ospf cost 20

standby 12 ip 172.31.12.254

standby 12 priority 100

standby 12 preempt

!

interface Vlan14

ip address 172.31.14.254 255.255.255.0

no ip mroute-cache

ip ospf cost 20

!

interface Vlan15

ip address 172.31.15.252 255.255.255.0

no ip redirects

no ip mroute-cache

ip ospf cost 20

standby 15 ip 172.31.15.254

standby 15 priority 100

standby 15 preempt

!

router ospf 110

log-adjacency-changes

redistribute static subnets

network 172.31.9.0 0.0.0.255 area 0

network 172.31.10.0 0.0.0.255 area 0

network 172.31.11.0 0.0.0.255 area 0

network 172.31.12.0 0.0.0.255 area 0

network 172.31.14.0 0.0.0.255 area 0

network 172.31.15.0 0.0.0.255 area 0

!

...

cnccb-sw2#show vtp status

VTP Version : 2

VTP Operating Mode : Server

VTP Domain Name : Soliton

VTP Pruning Mode : Disabled

VTP V2 Mode : Enabled

VTP Traps Generation : Disabled

WS-C2950T-24

...

hostname cnccb-sw3

spanning-tree extend system-id

!

interface FastEthernet0/1

switchport mode access

no ip address

storm-control broadcast level 70.00

storm-control multicast level 70.00

storm-control action shutdown

storm-control action trap

!

...(FastEthernet0/2 - 0/23 is configured the same as port 0/1)

!

interface FastEthernet0/24

decription connected to WS-C3550-24-EMI (Port FastEthernet0/9)

switchport mode access

no ip address

!

interface GigabitEthernet0/1

decription connected to WS-C3550-12T(Port GigabitEthernet0/9)

switchport mode access

no ip address

!

interface GigabitEthernet0/2

switchport mode access

no ip address

storm-control broadcast level 70.00

storm-control multicast level 70.00

storm-control action shutdown

storm-control action trap

!

interface Vlan1

ip address 172.31.15.247 255.255.255.0

no ip route-cache

!

ip default-gateway 172.31.15.254

Spanning tree status:

cnccb-sw1 (2550-12T)

VLAN0015

Spanning tree enabled protocol ieee

Root ID Priority 32769

Address 000b.5f8c.55c0

Cost 4

Port 9 (GigabitEthernet0/9)

Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

Bridge ID Priority 32783 (priority 32768 sys-id-ext 15)

Address 000b.5f79.8380

Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

Aging Time 300

Interface Port ID Designated Port ID

Name Prio.Nbr Cost Sts Cost Bridge ID Prio.Nbr

---------------- -------- --------- --- --------- -------------------- --------

Gi0/9 128.9 4 FWD 0 32769 000b.5f8c.55c0 128.25

Gi0/10 128.10 19 FWD 4 32783 000b.5f79.8380 128.10

cnccb-sw2 (3550-24-EMI):

VLAN0015

Spanning tree enabled protocol ieee

Root ID Priority 32769

Address 000b.5f8c.55c0

Cost 19

Port 9 (FastEthernet0/9)

Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

Bridge ID Priority 32783 (priority 32768 sys-id-ext 15)

Address 000b.5f42.0d00

Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

Aging Time 300

Interface Port ID Designated Port ID

Name Prio.Nbr Cost Sts Cost Bridge ID Prio.Nbr

---------------- -------- --------- --- --------- -------------------- --------

Fa0/9 128.9 19 FWD 0 32769 000b.5f8c.55c0 128.24

Fa0/24 128.24 19 BLK 4 32783 000b.5f79.8380 128.10

cnccb-sw3 (2950T-24)

cnccb-sw3#show spanning-tree

VLAN0001

Spanning tree enabled protocol ieee

Root ID Priority 32769

Address 000b.5f8c.55c0

This bridge is the root

Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

Bridge ID Priority 32769 (priority 32768 sys-id-ext 1)

Address 000b.5f8c.55c0

Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

Aging Time 300

Interface Port ID Designated Port ID

Name Prio.Nbr Cost Sts Cost Bridge ID Prio.Nbr

---------------- -------- --------- --- --------- -------------------- --------

Fa0/3 128.3 19 FWD 0 32769 000b.5f8c.55c0 128.3

Fa0/4 128.4 19 FWD 0 32769 000b.5f8c.55c0 128.4

Fa0/7 128.7 19 FWD 0 32769 000b.5f8c.55c0 128.7

Fa0/8 128.8 19 FWD 0 32769 000b.5f8c.55c0 128.8

Fa0/9 128.9 19 FWD 0 32769 000b.5f8c.55c0 128.9

Fa0/18 128.18 19 FWD 0 32769 000b.5f8c.55c0 128.18

Fa0/19 128.19 19 FWD 0 32769 000b.5f8c.55c0 128.19

--More--

Interface Port ID Designated Port ID

Name Prio.Nbr Cost Sts Cost Bridge ID Prio.Nbr

---------------- -------- --------- --- --------- -------------------- --------

Fa0/20 128.20 19 FWD 0 32769 000b.5f8c.55c0 128.20

Fa0/21 128.21 19 FWD 0 32769 000b.5f8c.55c0 128.21

Fa0/23 128.23 19 FWD 0 32769 000b.5f8c.55c0 128.23

Fa0/24 128.24 19 FWD 0 32769 000b.5f8c.55c0 128.24

Gi0/1 128.25 4 FWD 0 32769 000b.5f8c.55c0 128.25

5 Replies 5

ericlinji
Level 1
Level 1

Sorry the diagram is:

3550-12T <--------> 3550-24-EMI

\ /

\ /

\ /

2950T-24

Just some notes. It seems that your objective for the root bridge was not

achieved. Based on the spanning-tree information, the elected root bridge

is the 2950. From the spanning-tree output, all switches are using the

default priority of 32768 and the 2950 became the root bridge because it

has the lowest MAC address. There's an inconsistency with your config and

the output of the show spanning-tree. For example in the 3550-12T, you have

configured a priority of 24576 but the spanning-tree shows 32783.

You might want to try the following config:

[3550-12T or (cnccb-sw1)]

no spanning-tree vlan 15 priority 24576

spanning-tree vlan 15 root primary

[3550-24 or (cnccb-sw2)]

no spanning-tree vlan 15 priority 28672

spanning-tree vlan 15 root secondary

HTH.

Thank you very much!

Sorry, i pasted the early command output. The output corresponding with the configuration is as following:

cnccb-sw1:

VLAN0015

Spanning tree enabled protocol ieee

Root ID Priority 24591

Address 000b.5f79.8380

This bridge is the root

Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

Bridge ID Priority 24591 (priority 24576 sys-id-ext 15)

Address 000b.5f79.8380

Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

Aging Time 15

Interface Port ID Designated Port ID

Name Prio.Nbr Cost Sts Cost Bridge ID Prio.Nbr

---------------- -------- --------- --- --------- -------------------- --------

Gi0/9 128.9 4 FWD 0 24591 000b.5f79.8380 128.9

Gi0/10 128.10 19 FWD 0 24591 000b.5f79.8380 128.10

cnccb-sw2:

VLAN0015

Spanning tree enabled protocol ieee

Root ID Priority 24591

Address 000b.5f79.8380

Cost 19

Port 24 (FastEthernet0/24)

Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

Bridge ID Priority 28687 (priority 28672 sys-id-ext 15)

Address 000b.5f42.0d00

Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

Aging Time 300

Interface Port ID Designated Port ID

Name Prio.Nbr Cost Sts Cost Bridge ID Prio.Nbr

---------------- -------- --------- --- --------- -------------------- --------

Fa0/9 128.9 19 BLK 4 32769 000b.5f8c.55c0 128.24

Fa0/24 128.24 19 FWD 0 24591 000b.5f79.8380 128.10

cnccb-sw3:

VLAN0001

Spanning tree enabled protocol ieee

Root ID Priority 24591

Address 000b.5f79.8380

Cost 4

Port 25 (GigabitEthernet0/1)

Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

Bridge ID Priority 32769 (priority 32768 sys-id-ext 1)

Address 000b.5f8c.55c0

Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

Aging Time 300

Interface Port ID Designated Port ID

Name Prio.Nbr Cost Sts Cost Bridge ID Prio.Nbr

---------------- -------- --------- --- --------- -------------------- --------

Fa0/3 128.3 19 FWD 4 32769 000b.5f8c.55c0 128.3

Fa0/4 128.4 19 FWD 4 32769 000b.5f8c.55c0 128.4

Fa0/7 128.7 19 FWD 4 32769 000b.5f8c.55c0 128.7

Fa0/8 128.8 19 FWD 4 32769 000b.5f8c.55c0 128.8

Fa0/9 128.9 19 FWD 4 32769 000b.5f8c.55c0 128.9

Fa0/18 128.18 19 FWD 4 32769 000b.5f8c.55c0 128.18

--More--

Interface Port ID Designated Port ID

Name Prio.Nbr Cost Sts Cost Bridge ID Prio.Nbr

---------------- -------- --------- --- --------- -------------------- --------

Fa0/19 128.19 19 FWD 4 32769 000b.5f8c.55c0 128.19

Fa0/20 128.20 19 FWD 4 32769 000b.5f8c.55c0 128.20

Fa0/21 128.21 19 FWD 4 32769 000b.5f8c.55c0 128.21

Fa0/23 128.23 19 FWD 4 32769 000b.5f8c.55c0 128.23

Fa0/24 128.24 19 FWD 4 32769 000b.5f8c.55c0 128.24

Gi0/1 128.25 4 FWD 0 24591 000b.5f79.8380 128.9

I noted in cnccb-sw3, there runs a different spanning-tree instance with itself as the root switch. How can i place them in one spanning-tree instance without changing the ports connecting 2950 to 3550 switches to trunk ports?

Just to make it clear, when you mentioned "I noted in cnccb-sw3, there runs a different

spanning-tree instance with itself as the root switch.", are you talking about ports

Fa0/3-4,7-9,... which are in forwarding state? The "FWD" status for ports connected to

hosts or servers is normal. From the STP output, cnccb-sw3 is running VLAN 1 only.

I think the problem is with the 2950's configuration. In your post you have the ff:

!

interface FastEthernet0/24

decription connected to WS-C3550-24-EMI (Port FastEthernet0/9)

switchport mode access

no ip address

!

interface GigabitEthernet0/1

decription connected to WS-C3550-12T(Port GigabitEthernet0/9)

switchport mode access

no ip address

!

The above configuration uses VLAN 1 the default VLAN.

You have to assign Fa0/24 and Gi0/1 to VLAN 15 also:

!

interface FastEthernet0/24

switchport access vlan 15

!

interface GigabitEthernet0/1

switchport access vlan 15

!

You should alo check the status of trunks ports and the allowed VLANs on those trunks.

I mean in the show spanning-tree command output in 2950, there says "this bridge is the root" for vlan 1, so I think the STP instance runs in 2950 is different from STP instance runs in 3550 switches. Because if all the three switches run one STP instance, there should have only one root switch for vlan 1.

If I set the f0/24 and g0/1 to vlan 15, i have to set all other ports in 2950 to vlan 15. I am not sure this will combine the two STP instances. I will test it.

Thanks very much.