Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Appletalk and VLAN's

I'm trying to implement a series of VLAN's on the Xavier campus. For the most part they have been successful. However, there are some faculty and staff members who use Mac and Apple computers. They all seem to work fine within VLAN 1 (default) but not so well in the ones I've created. The follwoing is a report from the routers:

Appletalk for VLAN 1:

AppleTalk cable range is 500-501

AppleTalk address is 500.116, Valid

AppleTalk primary zone is "ACADEM"

AppleTalk additional zones: "ISS"

AppleTalk discarded 318 packets due to input errors

AppleTalk address gleaning is disabled

AppleTalk route cache is enabled

Vlan34 is up, line protocol is up

AppleTalk port disabled, Acquiring port net information

AppleTalk address is 500.116, Valid

AppleTalk zone is not set.

AppleTalk discovery mode is enabled

AppleTalk address gleaning is disabled

AppleTalk route cache is disabled by configuration

Can someone tell me what I'm doing wrong? The IPX portion works fine, but I have no zones.

When I turn off discovery, and add the zones, they still do not show up.

4 REPLIES
New Member

Re: Appletalk and VLAN's

Post a copy of the show run for the vlans

show run vlan 1

show run vlan 34

we assume that apple-talk rounting is enabled?

New Member

Re: Appletalk and VLAN's

interface Vlan1

description Infrastructure VLAN

ip address 205.133.157.253 255.255.255.0 secondary

ip address 205.133.158.253 255.255.255.0 secondary

ip address 205.133.159.253 255.255.255.0 secondary

ip address 205.133.160.253 255.255.255.0 secondary

ip address 205.133.161.252 255.255.255.0 secondary

ip address 205.133.162.252 255.255.255.0 secondary

ip address 205.133.163.253 255.255.255.0 secondary

ip address 205.133.164.252 255.255.255.0 secondary

ip address 205.133.167.124 255.255.255.192 secondary

ip address 205.133.167.188 255.255.255.192 secondary

ip address 205.133.167.252 255.255.255.192 secondary

ip address 206.21.168.253 255.255.255.0 secondary

ip address 192.153.34.125 255.255.255.128 secondary

ip address 205.133.165.29 255.255.255.224 secondary

ip address 205.133.165.61 255.255.255.224 secondary

ip address 205.133.165.93 255.255.255.224 secondary

ip address 205.133.165.125 255.255.255.224 secondary

ip address 205.133.165.156 255.255.255.224 secondary

ip address 205.133.165.188 255.255.255.224 secondary

ip address 205.133.165.220 255.255.255.224 secondary

ip address 205.133.165.252 255.255.255.224 secondary

ip address 206.21.169.253 255.255.255.0 secondary

ip address 206.21.170.125 255.255.255.128 secondary

ip address 206.21.170.252 255.255.255.128 secondary

ip address 206.21.171.253 255.255.255.0 secondary

ip address 192.153.34.250 255.255.255.128

ip helper-address 192.153.34.3

ip helper-address 192.153.34.4

no ip redirects

ip pim dense-mode

appletalk cable-range 500-501 500.116

appletalk zone ACADEM

appletalk zone ISS

ipx network B encapsulation SAP

ipx network A encapsulation NOVELL-ETHER secondary

standby 4 priority 40 preempt

standby 4 ip 205.133.157.254

standby 5 priority 40 preempt

standby 5 ip 205.133.158.254

standby 6 priority 40 preempt

standby 6 ip 205.133.159.254

standby 7 priority 40 preempt

standby 7 ip 205.133.160.254

standby 8 priority 40 preempt

standby 8 ip 205.133.163.254

standby 17 priority 40 preempt

standby 17 ip 206.21.168.254

standby 18 priority 40 preempt

standby 18 ip 206.21.170.126

standby 19 priority 40 preempt

standby 19 ip 206.21.171.254

standby 21 priority 20 preempt

standby 21 ip 205.133.161.254

standby 22 priority 20 preempt

standby 22 ip 205.133.162.254

standby 23 priority 20 preempt

standby 23 ip 205.133.164.254

standby 24 priority 40 preempt

standby 24 ip 205.133.165.30

standby 25 priority 40 preempt

standby 25 ip 205.133.165.62

standby 26 priority 40 preempt

standby 26 ip 205.133.165.94

standby 27 priority 40 preempt

standby 27 ip 205.133.165.126

standby 28 ip 205.133.167.62

standby 29 priority 20 preempt

standby 29 ip 205.133.167.126

standby 30 priority 20 preempt

standby 30 ip 205.133.167.190

standby 35 priority 20 preempt

standby 35 ip 206.21.169.254

standby 36 priority 20 preempt

standby 36 ip 206.21.170.254

standby 37 priority 20 preempt

standby 37 ip 205.133.167.254

standby 38 priority 20 preempt

standby 38 ip 205.133.165.158

standby 39 priority 20 preempt

standby 39 ip 205.133.165.190

standby 40 priority 20 preempt

standby 40 ip 205.133.165.222

standby 41 priority 20 preempt

standby 41 ip 205.133.165.254

standby 50 priority 40 preempt

standby 50 ip 192.153.34.126

standby 51 priority 20 preempt

standby 51 ip 192.153.34.254

interface Vlan34

description cin567000 cintas 4b conf room

ip address 205.133.167.60 255.255.255.192

ip helper-address 192.153.34.3

ip helper-address 192.153.34.4

no ip redirects

ip pim dense-mode

appletalk address 500.116

appletalk discovery

no appletalk route-cache

ipx network 34A encapsulation SAP

standby priority 20 preempt

New Member

Re: Appletalk and VLAN's

The following is a sh run on the router:

version 12.1

no service pad

service timestamps debug datetime

service timestamps log datetime

service password-encryption

!

hostname ROCRTR1

!

boot system flash bootflash:c6msfc-js-mz.121-3a.E4.bin

aaa new-model

aaa authentication login default group tacacs+ enable

aaa authentication enable default group tacacs+ enable

enable password

!

clock timezone est -5

clock summer-time edt recurring

ip subnet-zero

no ip domain-lookup

!

ip multicast-routing

ip cef

appletalk routing

ipx routing 0001.6471.7224

cns event-service server

!

!

!

interface Group-Async0

physical-layer async

no ip address

New Member

Re: Appletalk and VLAN's

Each Vlan must have a unique appletalk address. It looks like you are using 500 for Vlan 1 and also for Vlan 34. You must also put the appletalk zone in each Vlan. Following is an example of Vlan configurations:

interface Vlan34

ip address 10.43.32.1 255.255.224.0

ip helper-address 198.214.192.186

no ip directed-broadcast

ip pim sparse-mode

no ip route-cache cef

ip cgmp

appletalk cable-range 4340-4340 4340.106

appletalk zone RBMS

ipx encapsulation SAP

ipx network B340

!

interface Vlan66

ip address 10.43.64.1 255.255.224.0

ip helper-address 198.214.192.186

no ip directed-broadcast

ip pim sparse-mode

no ip route-cache cef

ip cgmp

appletalk cable-range 4660-4660 4660.246

appletalk zone RBMS

ipx encapsulation SAP

ipx network B660

!

Hope this helps. Also be aware that appletalk has routing issues with secondary addresses on interfaces.

271
Views
0
Helpful
4
Replies
CreatePlease to create content