Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Apply a policy-map on an ATM interface

Hi all,

I have a router (2811 with IOS 12.4(15)T1)with an E1 atm interface and 2 sub-interface in order to split voice and data traffic on two different pvcs.

I applied a service-policy to the main atm interface to strict prioritize sip/rtp traffic and fairly queueing the rest of the traffic.

Below an abstract of the router configuration:

... omissis ...

!

controller E1 0/0/0

mode atm aim 0

!

!

class-map match-all CM_VOICE

description ***Mapping Voice Traffic***

match access-group 1

match protocol sip

match protocol rtp

!

policy-map PM_VOICE

description ***Policy Map***

class CM_VOICE

priority 450

class class-default

fair-queue

!

... omissis ...

!

interface ATM0/0/0

bandwidth 1920

no ip address

logging event subif-link-status

load-interval 30

scrambling-payload

no atm ilmi-keepalive

service-policy output PM_VOICE

!

interface ATM0/0/0.1 point-to-point

description *** VOICE PVC ***

ip address dhcp client-id FastEthernet0/0

ip nat outside

ip virtual-reassembly

atm route-bridged ip

pvc 1/52

vbr-rt 1920 450

oam-pvc manage 5

encapsulation aal5snap

!

!

interface ATM0/0/0.2 point-to-point

description *** DATA PVC ***

ip address 10.130.45.43 255.255.255.240

ip nat outside

ip virtual-reassembly

atm route-bridged ip

pvc 2/52

abr 1920 1170

oam-pvc manage 5

encapsulation aal5snap

!

... omissis ...

!

ip nat inside source list 1 interface ATM0/0/0.1 overload

ip nat inside source static 192.168.1.94 interface ATM0/0/0.2

!

access-list 1 permit 192.167.10.0 0.0.0.255

!

... omissis ...

When applying both type of traffic the policy-map seems to be inactive because when showing statistics the counters remain at 0 including data traffic rate as shown below:

0002811CPE1_E#sh policy-map interface atm 0/0/0

ATM0/0/0

Service-policy output: PM_VOICE

Class-map: CM_VOICE (match-all)

0 packets, 0 bytes

30 second offered rate 0 bps, drop rate 0 bps

Match: access-group 1

Match: protocol sip

Match: protocol rtp

Queueing

Strict Priority

Output Queue: Conversation 264

Bandwidth 450 (kbps) Burst 11250 (Bytes)

(pkts matched/bytes matched) 0/0

(total drops/bytes drops) 0/0

Class-map: class-default (match-any)

0 packets, 0 bytes

30 second offered rate 0 bps, drop rate 0 bps

Match: any

Queueing

Flow Based Fair Queueing

Maximum Number of Hashed Queues 256

(total queued/total drops/no-buffer drops) 0/0/0

May someone help me to understand how correctly apply the service policy?

thanks in advance

Daniele

6 REPLIES

Re: Apply a policy-map on an ATM interface

This kind of setup has puzzled me also in the past. My conclusion was that you need to have IP enabled on the interface to allow the policy to be processed. As your ATM interface itself has no ip adress, ip processing will be disabled on it which I assume is why the policy map does work as expected.

The solution would be to assign the policy to the subinterfaces instead.

regards,

Leo

Community Member

Re: Apply a policy-map on an ATM interface

Thanks Leo,

considering the written configuration, do you know if the policy-map could work if applied to the two separate PVC where the data traffic and voice traffic are processed separately?

Regards,

Daniele

Hall of Fame Super Gold

Re: Apply a policy-map on an ATM interface

Daniele,

leo is correct, the service policy must be applied to individual subinterfaces and not on the main interface.

Note that with a proper QoS configuration there is no need to separate voice and data on different PVCs, a single one will work just fine.

Re: Apply a policy-map on an ATM interface

In accordance with the above, you would need to apply the policy to the subinterface.

As my collegue clearly depicts, you should be able to combine the two pvc's into one, that would also be the scenario where the policy comes in action. When you are sending voice over a dedicated pvc there is little need to prioritize the flow. This equals the configuration where you have a dedicated leased line for voice.

regards,

Leo

Community Member

Re: Apply a policy-map on an ATM interface

This scenario requires two PVCs because the voice & data traffic are terminated on two differents broadband aggregator (not Cisco). The engineering unit, which provided this kind of solution, considers this topology as mandatory so I guess that this policy-map will not be applicable.

Thanks

Daniele

Hall of Fame Super Gold

Re: Apply a policy-map on an ATM interface

You may or may not need the service-policy if you want to do some QoS for data. For voice, is not needed as you have separate PVC.

Thanks for the rating and good luck!

291
Views
8
Helpful
6
Replies
CreatePlease to create content