Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Applying dialer map causes routing to fail

Scenario is central site 2600 router with e1 pri interface and 6 remote sites with 801 BRI routers.

Remote sites are configured for dial-in central site is configured to accept incomming calls. However when i configure the central site router to make outbound calls with the dialer map statement it causes routing to fail i.e. cannot ping anything even though the connection is made and up - copy of central site config and 1 remote site included below. It appears that when a static dialer map statement is added (exactly the same as the dynamic map created when site dials in except it includes a tel no) it causes the routing to fail.

Can anyone help with this?

CENTRAL SITE CONFIG

!

version 12.0

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname CSD_EPSOM

!

logging buffered 500000 debugging

aaa new-model

aaa authentication login default local

aaa authentication login console enable

aaa authentication login vty local

aaa authentication login dialin local

aaa authentication ppp default local

aaa authentication ppp dialin if-needed local

enable secret 5 $1$l1AB$uWgZ.leG.eI2UmOx1GmRV/

enable password 7 0820584B080A00

!

username admin password 7 0005070305480E57

username csd_maple password 7 1218111213180955

username csd_caterham password 7 050A120A205F4B58

username csd_oxted password 7 104F1D1C0404175A

username csd_merstham password 7 130403170A1F017B

username csd_horley password 7 011212015A18035E

username csd_lingfield password 7 094D5A0C18161243

ip subnet-zero

no ip finger

no ip domain-lookup

isdn switch-type primary-net5

call-history-mib retain-timer 500

call-history-mib max-size 500

!

!

controller E1 1/0

pri-group timeslots 1-16

!

!

interface Ethernet0/0

description Ethernet Link to LAN

ip address 195.106.51.254 255.255.255.0

ip broadcast-address 195.106.51.255

no ip directed-broadcast

no ip mroute-cache

!

interface Serial1/0:15

description connected to ESPCT Community Sites

no ip address

no ip directed-broadcast

encapsulation ppp

dialer rotary-group 0

isdn switch-type primary-net5

no cdp enable

!

interface Dialer0

description Dialer Group for ESPCT Comminty Sites

ip unnumbered Ethernet0/0

no ip directed-broadcast

encapsulation ppp

no ip mroute-cache

dialer in-band

dialer map ip 194.189.4.33 name CSD_OXTED 01883730839

dialer-group 1

no peer default ip address

no cdp enable

ppp authentication chap

ppp multilink

!

ip default-gateway 195.106.51.1

ip classless

ip route 0.0.0.0 0.0.0.0 195.106.51.1

ip route 194.189.4.0 255.255.255.224 194.189.4.1

ip route 194.189.4.1 255.255.255.255 Dialer0

ip route 194.189.4.32 255.255.255.224 194.189.4.33

ip route 194.189.4.33 255.255.255.255 Dialer0

ip route 194.189.4.64 255.255.255.224 194.189.4.65

ip route 194.189.4.65 255.255.255.255 Dialer0

ip route 194.189.4.96 255.255.255.224 194.189.4.97

ip route 194.189.4.97 255.255.255.255 Dialer0

ip route 194.189.4.128 255.255.255.224 194.189.4.129

ip route 194.189.4.129 255.255.255.255 Dialer0

ip route 194.189.4.160 255.255.255.224 194.189.4.161

ip route 194.189.4.161 255.255.255.255 Dialer0

ip route 194.189.4.192 255.255.255.224 194.189.4.193

ip route 194.189.4.193 255.255.255.255 Dialer0

!

dialer-list 1 protocol ip permit

snmp-server community public RO

!

line con 0

login authentication consoleport

transport input none

line aux 0

line vty 0 4

password 7 0005070305480E

login authentication vty

transport input telnet rlogin

!

no scheduler allocate

end

REMOTE SITE CONFIG

!

version 12.1

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname CSD_CATERHAM

!

logging buffered 500000 debugging

!

!

username CSD_EPSOM password atease1

!

!

!

ip subnet-zero

no ip domain-lookup

!

isdn switch-type basic-net3

!

call-history-mib retain-timer 500

!

!

interface BRI0

description Link to EPSON

no ip address

encapsulation ppp

dialer pool-member 1

isdn switch-type basic-net3

ppp authentication chap

ppp multilink

!

interface Ethernet0

ip address 192.168.4.1 255.255.255.0

ip nat inside

no cdp enable

!

interface Dialer0

ip address negotiated

ip nat outside

encapsulation ppp

dialer remote-name CSD_EPSOM

dialer pool 1

dialer string 01372723300

dialer-group 1

no cdp enable

ppp authentication chap

ppp multilink

!

!

ip nat inside source list 102 interface Dialer0 overload

ip classless

ip route 0.0.0.0 0.0.0.0 Dialer0

no ip http server

!

access-list 101 permit ip any any

access-list 102 permit ip 192.168.4.0 0.0.0.255 any

dialer-list 1 protocol ip list 101

!

line con 0

transport input none

line aux 0

line vty 0 4

password atease1

login

!

end

11 REPLIES
Cisco Employee

Re: Applying dialer map causes routing to fail

If the config posted above for 801 is the one in which the central 2600 will dial into, we have mismatch in dialer map statement. You have configured

dialer map ip 194.189.4.33 name CSD_OXTED 01883730839

while the name of the 801 will be CSD_CATERHAM. so if you change that in that dialer map i think it should work.

You will be able to see the problem once we have the following debug on at central router

debug dialer

debug ppp nego

debug isdn q931

debug ppp authentication

Pl. post it here if problem is still there with config change too.

New Member

Re: Applying dialer map causes routing to fail

Thanks for your reply.

I know the config for the 801 is not the router that is configured in the central site config I just used it as an example their are 6 of them. The debugs I have tried - as I said the routers connect and authenticate ppp fine it's just that when you add the dialer map statement on the central site router and the remote site dials in it connot ping anything. If I remove the dialer map on the central router the router dialing works fine!

Re: Applying dialer map causes routing to fail

Did you try adding broadcast on to end of the dialer map statement?

The reason I say this is, in your config the remote site has static pointing to dialer0. doing statics this way uses proxy-arp. this means it's going to ARP to find where that is and since central site doesn't allow broadcasts a return ARP isn't going to be sent thus he doesn't know where that is. You can try putting next hop IP address instead of interface as well.

Cisco Employee

Re: Applying dialer map causes routing to fail

Need to now the reason why you ned to add the static dialer map once the dynamic dialer map is already there. If you need to add the static dialer map, you need to add it before the dialing occurs..

New Member

Re: Applying dialer map causes routing to fail

I need to add add the static dialer map on the central site to allow it to bring up the connection and dial the remote site, i.e. 2 way ddr. The dynamic map is created on the central site when the remote site dials in but obviuosly if the central site dials out then the static map needs to be used for the telephone number.

I will try the broadcast command as suggested.

Thanks Guys

Cisco Employee

Re: Applying dialer map causes routing to fail

You are right..You need to add the dialer map to dialout. So when you add the dialer map and the central site dialout on first channel to remote site, the central site is not able to ping the remote..right?

We need to know what dialer map you are adding along with the debug i have requested earlier. Also the "broadcast" in the dialermap is used for to send the routing updates over the link. So you may not need it if you are not using the routing protocol over the link.

New Member

Re: Applying dialer map causes routing to fail

The central site config I included has a dialer map statement for one of the remote sites. I included thia as an example. I will try and get the debug out put over the next few days and post. Do you think this will help being as it's not the connection that fails only routing. i.e. the connection comes up ok - I can see the router dialing in and attaching ok. The brodcast command was suggested by someone else - see earlier mail response. Do you think that the problem may be down to using IP Unnumbered? I must admit I did not try using IP addresses for the dialer profiles.

Cisco Employee

Re: Applying dialer map causes routing to fail

The debug will help to see any issues with IPCP leyer along with the hostname received from remote side..That hostname is case sensitive so we need to have it exactly matches in dialer map..Mismatch in hostname will make the routing fail..You will see encapsulation faied when you have "debug ip icmp" at the time of ping.

So need to have the debug with the dialermap statement you are using.

New Member

Re: Applying dialer map causes routing to fail

Hi,

This is issue is now resloved after resolving another related issue with outbound dialing on the PRI.

Thanks for the input on this.

Chris Morrall

Anonymous
N/A

Re: Applying dialer map causes routing to fail

I have the same problem that you had, could you please till me how did you solve it. thanls a lot

New Member

Re: Applying dialer map causes routing to fail

The issue that was two fold. firstly outbound dialing was not working from the central site router - the ISDN switch on the service providers nework was sending a message back saying it was unabel to allocate a channel to make the outbound call. But also when this was happening and the remote sites dialed in - with the dialermap statement on the central site configure the remote sie was unable to ping. When we sorted out the first issue (BT gave us incorrect info on the number of timeslots enabeled initialy) and reapplied the dialer maps it all worked! Unorftunately the client fixed this on their own after we resolved the timeslots issue. But it may have been down to case sensitiviy of the router names - make sure they are the same on the dialer maps, user/password and router!

182
Views
0
Helpful
11
Replies
CreatePlease login to create content