Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

ARP issues - Trunked 3620 - 2950

Hi,

I have a bit of an issue in that I can't get dot1q trunking going between a 3620 and a 2950.

Equipment: 3620 - 10mbps ETHERNET connected to a 2950 - 100mbps FE.

==============================

Interface config on 3620.

!

interface Ethernet1/0

description #### Trunk link to Syktower2950 ####

no ip address

no ip redirects

no ip route-cache

no ip mroute-cache

load-interval 30

half-duplex

no cdp enable

!

interface Ethernet1/0.1

description #### Native VLAN1 ####

encapsulation dot1Q 1 native

ip address 10.5.5.1 255.255.255.0

no ip redirects

no ip route-cache

no ip mroute-cache

no cdp enable

!

==============================

Ports all seem to be up fine.

If I put an IP address on Ethernet 1/0, can access the 2950 VLAN1 no probs.

When I put the IP address on a subinterface, I start getting ARP error messages.

01:23:09: IP ARP: creating incomplete entry for IP address: 10.5.5.2 interface E

thernet1/0.1

01:23:09: IP ARP: sent req src 10.5.5.1 00d0.bad9.c511,

dst 10.5.5.2 0000.0000.0000 Ethernet1/0.1

01:23:09: IP ARP: sent req src 10.5.5.1 00d0.bad9.c511,

dst 10.5.5.2 0000.0000.0000 Ethernet1/0.1

01:23:09: IP ARP rep filtered src 10.5.5.2 000f.3425.5b40, dst 10.5.5.1 00d0.bad

9.c511 wrong cable, interface Ethernet1/0

01:23:09: IP ARP rep filtered src 10.5.5.2 000f.3425.5b40, dst 10.5.5.1 00d0.bad

9.c511 wrong cable, interface Ethernet1/0

I'm pretty sure it isn't a cable problem because when the IP address is on the interface all goes well. When on the sub-interface it fails.

For some reason, the 3620 is filtering the ARP response.

Any ideas?

Thanks

Steven Schmidt.

1 REPLY

Re: ARP issues - Trunked 3620 - 2950

Hi,

I'd try to check:

1) duplex

There is half-duplex on the router side. Is it also on the switch side?

2) switch trunk config

Don't forget 2950 is desirable by default on 802.1q trunk ports.

Use switch(config-if)#switchport nonegotiate

while connecting to a router.

3) proper IOS on the router.

802.1q requires IP Plus Feature Set generally.

I rmemeber some older IOS versions had problems with native VLAN configuration (encapsulation ... native option was missing).

The workaround was similar to your config - not configuring native VLAN subinterface, using native VLAN IP address on the interface.

Regards,

Milan

197
Views
0
Helpful
1
Replies
CreatePlease to create content