Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

AS5300 configuration assistance

I need to configure an AS5300 for dialin access to a corporate network. There will be a PRI circuit associated with a 1-800 hunt group. What is required to connect the AS5300 PRI interface to the service provider network (csu/dsu)?

Does anyone have a known working AS5300 configuration with PRI interface(s) for dialin that they can share with me as a reference?

Thank you in advance,

Dan

23 REPLIES
Silver

Re: AS5300 configuration assistance

New Member

Re: AS5300 configuration assistance

So connecting the AS5300 PRI is similar to connecting a WIC-1T-DSU, a straight-through RJ54 from the access server to the provider's network?

Thanks to both of you, Mak and ndoshi, for your feedback.

Dan

Silver

Re: AS5300 configuration assistance

WIC-1DSU-T1 ...One T1 CSU/DSU WAN Interface Card provides full or fractional T1 service. It does not do channelized T1 or ISDN PRI.

The connecting cable type is the same..RJ45.

Thanks, Mak.

New Member

Re: AS5300 configuration assistance

Yes, thank you, Mak. I realize the technical difference between the WIC-1DSU-T1 and the PRI. I was trying to reference the interconnectivity of the PRI with the service provider's network. As with the referenced WIC-1DSU, the PRI does not require an external DSU to connect to the WAN.

Thanks again for your assistance.

Regards,

Dan

New Member

Re: AS5300 configuration assistance

Here is my working copy of an AS5300 used for dialin access. I did however remove some network specific info like ip address and passwords. I also use a Cisco Secure ACS for authentication but I think you can modify it for use with local users. Hopefully this helps

version 12.0

no service pad

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname AS5300

!

aaa new-model

aaa authentication login default enable

aaa authentication login no_tacacs enable

aaa authentication ppp default group tacacs+

aaa authorization network default group tacacs+

aaa accounting commands 1 default stop-only group tacacs+

aaa accounting commands 15 default stop-only group tacacs+

aaa accounting network default start-stop group tacacs+

enable secret 5 ***REMOVED***

enable password 7 ***REMOVED***

!

spe 1/0 1/7

firmware location flash:pw2721.ios

!

!

resource-pool disable

!

!

!

!

!

clock timezone EST -4

ip subnet-zero

no ip source-route

no ip finger

ip domain-name ***REMOVED***

ip name-server ***REMOVED***

ip name-server ***REMOVED***

!

no ip bootp server

ip address-pool dhcp-proxy-client

ip dhcp-server ***REMOVED***

async-bootp dns-server ***REMOVED*** ***REMOVED***

async-bootp nbns-server ***REMOVED*** ***REMOVED***

isdn switch-type primary-5ess

isdn voice-call-failure 0

cns event-service server

mta receive maximum-recipients 0

!

!

controller T1 0

framing esf

clock source line primary

linecode b8zs

pri-group timeslots 1-24

fdl ansi

!

controller T1 1

clock source line secondary 1

!

controller T1 2

clock source line secondary 2

!

controller T1 3

clock source line secondary 3

!

!

!

!

interface Loopback0

no ip address

no ip directed-broadcast

!

interface Ethernet0

no ip address

no ip directed-broadcast

no ip mroute-cache

shutdown

!

interface Serial0

no ip address

no ip directed-broadcast

no ip mroute-cache

shutdown

no fair-queue

clockrate 2015232

!

interface Serial1

no ip address

no ip directed-broadcast

no ip mroute-cache

shutdown

no fair-queue

clockrate 2015232

!

interface Serial2

no ip address

no ip directed-broadcast

no ip mroute-cache

shutdown

no fair-queue

clockrate 2015232

!

interface Serial3

no ip address

no ip directed-broadcast

no ip mroute-cache

shutdown

no fair-queue

clockrate 2015232

!

interface Serial0:23

no ip address

no ip directed-broadcast

encapsulation ppp

dialer rotary-group 1

dialer-group 1

isdn switch-type primary-5ess

isdn incoming-voice modem

no fair-queue

no cdp enable

!

interface FastEthernet0

ip address ***REMOVED*** 255.255.255.0

no ip directed-broadcast

no ip mroute-cache

duplex auto

speed auto

no mop enabled

!

interface Group-Async1

ip unnumbered FastEthernet0

no ip directed-broadcast

encapsulation ppp

dialer in-band

dialer idle-timeout 600

dialer-group 1

async dynamic address

async dynamic routing

async mode interactive

peer default ip address dhcp

no cdp enable

ppp authentication ms-chap chap

group-range 1 48

!

interface Dialer1

ip unnumbered Loopback0

no ip directed-broadcast

encapsulation ppp

no ip mroute-cache

dialer in-band

dialer idle-timeout 600

dialer-group 1

no peer default ip address

no fair-queue

no cdp enable

ppp authentication ms-chap chap

ppp multilink

!

ip default-gateway ***REMOVED***

ip classless

ip route 0.0.0.0 0.0.0.0 ***REMOVED***

ip http server

ip http authentication local

!

dialer-list 1 protocol ip permit

!

tacacs-server host ***REMOVED***

tacacs-server key ***REMOVED***

snmp-server engineID local 00000009020000D0BA8035D8

snmp-server community public RO

!

!

line con 0

password 7 ***REMOVED***

login authentication no_tacacs

transport input none

line 1 24

autoselect during-login

autoselect ppp

modem InOut

rotary 1

transport preferred lat pad mop telnet rlogin udptn v120 lapb-ta nasi

transport input all

transport output lat pad mop telnet rlogin udptn v120 lapb-ta nasi

line 25 48

autoselect during-login

autoselect ppp

modem InOut

transport preferred lat pad mop telnet rlogin udptn v120 lapb-ta nasi

transport input all

transport output lat pad mop telnet rlogin udptn v120 lapb-ta nasi

line aux 0

password 7 ***REMOVED***

line vty 0 4

password 7 ***REMOVED***

!

ntp clock-period 17179405

ntp update-calendar

ntp server 129.127.28.4 prefer

scheduler interval 1000

end

New Member

Re: AS5300 configuration assistance

Thank you for the sample config. Can I provide a dialin account with local authentication to perform maintenance on the AS5300? Do I need to give special privileges to the administrator dialin account? I am familiar with doing this on routers and firewalls, but have not worked much with access servers in this regard.

Thanks Again,

Dan

Silver

Re: AS5300 configuration assistance

Can do an exec dialin into the as5300 for admin purpose (do not need do PPP)...after enable access the admin can carry out all router commands.

aaa authentication login default local.... will do that.

Thanks, Mak.

New Member

Re: AS5300 configuration assistance

Thank you for the info, Mak. Using this command will allow me to dialin via the PRI? Once connected, how do I login to the access server and get into enable mode so that I can configure the device?

What is my flexibility in configuring the incoming PRI channels? Can I connect specific channels to certain internal modems? Can I force certain modems to connect at 1200 bps and others at 9600 bps?

If you know of a source for detailed configuration info I would like to review the commands available for this device. Your assistance is greatly appreciated.

Regards,

Dan

Silver

Re: AS5300 configuration assistance

With commands "asyn mode interactive" (under int group-asy 1) & " autoselect ppp" under the lines.....if we do an exec dialin (say using hyperterm, ATDTxxxx) the NAS will sniff the first packet & will know whether it's a PPP call or exec....the exec call will be terminated on the router itself, where the user will be prompted for username/password (actually depends on what AAA commands we have).

After successful authentication the user will be at a "routername>" prompt.....now if we enter in enable mode we are good to carry out commands on the router.

Yes, we can dialin using the PRI (based on bearercap call will transfered to modem).

No, we cannot map certain DS0s to certain modems.

Yes, we can configure certain modem for 1200 / 9600 pbs speeds.

Thanks, Mak.

New Member

Re: AS5300 configuration assistance

Thanks again, Mak.

I'm looking for a reference to help with the modem speed config and other more detailed info so that I can bring myself up to speed on this device. The client tells me that they will have three phone numbers. They want the first one to be tied to the 3 1200bps modems, the second to the 10 9600bps. I'm not real sure how to do this, or how to make it work. Does the service provider direct certain phone numbers over certain PRI channels? How do we ensure that, say, the 1200bps users get connected to the modems we have configured for 120bps?

Are there any command references available for OS ver. 12.0 for this device? I have been scouring CCO and have found the following URL's:

www.cisco.com/en/US/products/hw/univgate/ps501/products_configuration_guide_chapter09186a008007dfeb.html

www.cisco.com/en/US/partner/products/hw/univgate/ps505/products_configuration_example09186a0080094a49.shtml

www.cisco.com/en/US/products/hw/univgate/ps501/products_configuration_guide_book09186a008007dfbb.html

Any further references would be appreciated.

Regards,

Dan

Silver

Re: AS5300 configuration assistance

Since we have 3 different phone number for the incomming calls we can do modem pooling to send the calls based on DNIS to different groups of modems.

http://www.cisco.com/warp/public/793/access_dial/pri_dnis_mpool.html

http://www.cisco.com/warp/public/793/access_dial/modem_pooling.html

Further, we can use a modemcap that will fine tune the characterstics of a modem (we will have 3 different pools with different chacterstics)...this is achived by changing the "S" registers on the modems (using modemcap):

http://www.cisco.com/univercd/cc/td/doc/product/access/acs_serv/5300/sw_conf/sw_ports/at_set/atcmnds.htm#4376

s29, s30,s31 etc

Thanks, Mak.

New Member

Re: AS5300 configuration assistance

Thanks again, Mak. I will sift through the URLs you gave me.

Regards,

Dan

New Member

Re: AS5300 configuration assistance

I got most of this stuff ironed out. I can route certain calls - based on "called-number" - to a specific group of modems. My remaining question is where do I go to set the "S" registers for the modems that I want to run at, say, 1200 bps or 9600bps? How do I save these initialization files to ensure that the modems get initialized properly upon reboot?

Thank You,

Dan

Silver

Re: AS5300 configuration assistance

s29, s30, s31 are the S registers of interest here:

http://www.cisco.com/univercd/cc/td/doc/product/access/acs_serv/5300/sw_conf/sw_ports/at_set/atcmnds.htm#4376

In order to apply a modemcap please refer to:

http://www.cisco.com/warp/public/471/recc_modemcaps.html

Thanks, Mak.

New Member

Re: AS5300 configuration assistance

Mak,

I have used the modem-pool command to direct incoming calls to the appropriate mica modems (line), and the modemcap command to set the autoanswer to "immediate" and the s30 register to the appropriate maximum speed (1200/9600). This is desired in order to minimize the negotiation time for the dial client connection.

Below is a copy of the config. Would it be possible for you to review it and verify that I have configured the modem-pool and modemcap commands correctly?

Thank You,

Dan

version 12.1

no service single-slot-reload-enable

no service pad

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname as5300

!

logging rate-limit console 10 except errors

aaa new-model

aaa authentication login default local

aaa authentication ppp default local

aaa authorization network default local

enable secret 5 removed

enable password removed

!

username admin password 0 removed

username ccuunit password 0 removed

username scuunit password 0 removed

username meiunit password 0 removed

spe 1/0 1/7

firmware location flash:mica-modem-pw.2.7.2.0.bin

spe 2/0 2/7

firmware location flash:mica-modem-pw.2.7.2.0.bin

!

!

resource-pool disable

!

modem-pool m1200

pool-range 1-3

called-number 333-333-3333 max-conn 3

!

modem-pool m9600

pool-range 4-13

called-number 444-444-4444 max-conn 10

!

modem-pool default

pool-range 14-23

called-number 555-555-5555 max-conn 10

!

clock timezone EST -5

clock summer-time EDT recurring

modem country mica usa

ip subnet-zero

no ip source-route

no ip finger

ip domain-name cisco.com

ip name-server

ip name-server

!

no ip bootp server

async-bootp dns-server 129.41.128.5

isdn switch-type primary-4ess

modemcap entry 1200bps:AA=0:MSC=S30=1200

modemcap entry 9600bps:AA=0:MSC=S30=9600

!

!

controller T1 0

framing esf

clock source line primary

linecode b8zs

pri-group timeslots 1-24

!

controller T1 1

clock source line secondary 1

!

controller T1 2

clock source line secondary 2

!

controller T1 3

clock source line secondary 3

!

!

interface Loopback0

ip address 192.168.1.1 255.255.255.0

!

interface Ethernet0

no ip address

no ip mroute-cache

shutdown

!

interface Serial0

no ip address

no fair-queue

clockrate 2015232

!

interface Serial1

no ip address

shutdown

no fair-queue

clockrate 2015232

!

interface Serial2

no ip address

shutdown

no fair-queue

clockrate 2015232

!

interface Serial3

no ip address

shutdown

no fair-queue

clockrate 2015232

!

interface Serial0:23

no ip address

encapsulation ppp

dialer rotary-group 1

isdn switch-type primary-4ess

isdn incoming-voice modem

no fair-queue

no cdp enable

ppp authentication chap pap ms-chap

!

interface Group-Async1

ip unnumbered Loopback0

encapsulation ppp

no ip mroute-cache

dialer in-band

dialer idle-timeout 300

dialer-group 1

async mode interactive

peer default ip address pool dialin_pool

ppp authentication chap pap ms-chap

group-range 1 24

!

interface Dialer1

ip unnumbered Loopback0

encapsulation ppp

no ip mroute-cache

dialer in-band

dialer idle-timeout 600

dialer-group 1

peer default ip address pool dialin_pool

no fair-queue

no cdp enable

ppp authentication ms-chap chap

!

ip local pool dialin_pool 192.168.1.2 192.168.1.25

ip default-gateway xx.xx.xx.xx

ip classless

ip route 0.0.0.0 0.0.0.0 xx.xx.xx.xx

no ip http server

!

dialer-list 1 protocol ip permit

!

line con 0

password removed

transport input none

line 1 3

autoselect during-login

autoselect ppp

modem InOut

modem autoconfigure type 1200bps

transport input all

line 4 13

autoselect during-login

autoselect ppp

modem InOut

modem autoconfigure type 9600bps

transport input all

line 14 24

autoselect during-login

autoselect ppp

modem InOut

transport input all

line 25 96

line aux 0

exec-timeout 15 0

password removed

line vty 0 4

password removed

!

end

Silver

Re: AS5300 configuration assistance

In the modempool commands do not have any "-" between the numbers... keep the called number as 5555555555.

Apply the modemcap as follows:

router#conf term

router(config)#modemcap edit MODEMCAPNAME misc INITSTRING

router(config)#line BEGIN END

router(config-line)#modem autoconfigure type MODEMCAPNAME

Thanks, Mak.

New Member

Re: AS5300 configuration assistance

Thank you, Mak. I corrected the called-number entries. The documentation I have read talks about beginning the init string with &F$D2. I have simply added S0=1200 and S0=9600 in the Misc field. I have also set the autoanswer (AA) field to 0. Is what I have sufficient to properly initialize the modems?

My goal is to minimize the connection time for the dialin users to have the modem answer as soon as it detects an incoming call, and not have to negotiate the connection speed. Is there anything else I need to consider?

Regards,

Dan

Silver

Re: AS5300 configuration assistance

modemcap entry 9600:MSC=&f&d2s29=0s30=9600

This will train with the top modulation being V.34 at 9600 bps

modemcap entry v32only:MSC=&f&d2s64=5

This will train using only V.32 (top rate 9600 bps)...NOTE:By using the S64 register, MICA is forced to try ONLY the standard specified in S64 & if that does not connect then the call will fail, there is no fallback with s64.

Thanks, Mak.

New Member

Re: AS5300 configuration assistance

The modemcap commands also have subcommands to set AA (autoanswer) and SPEED. Do these set the S0 and S30 registers?

Silver

Re: AS5300 configuration assistance

Yes, you can add s0=0 or s0=1(we default to 2) if need be.

&f&d2s0=0s29=0s30=9600

Thanks, Mak.

New Member

Re: AS5300 configuration assistance

Thanks again, Mak. I was having some difficulty yesterday getting a modem working on the aux port. Not quite sure if it's a problem with the modem, the aux port, or my configuration. I'm hoping to revisit it today with a new USR Sportster 33600 modem. Below is the latest version of my aux port config.

Dan

line aux 0

exec-timeout 15 0

password removed

login

modem InOut

transport input all

flowcontrol hardware

rxspeed 33600

txspeed 33600

stopbits 1

exec

Silver

Re: AS5300 configuration assistance

For USR, reverse telnet into the modem & add the following init string...have dip switches 3 & 8 down , rest up.

at&f1s0=1&c1&d1&a1&w

On the line try with & w/o the speed commands.

Thanks, Mak.

293
Views
0
Helpful
23
Replies
CreatePlease login to create content