Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
You may experience some slow load times, errors, and slight inconsistencies. We ask for your patience as we finalize the launch. Thank you.

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

rob
New Member

Assigning a static IP address to async dialup

I've got customers dialing up to our AS5200 for internet access. They get IP addresses just fine and can browse the Internet. I've got one customer that needs a static IP address when he dials into our router. What is the easiest way to do this?

Here is my current config:

version 12.0

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname AS5200

!

logging buffered 128000 debugging

no logging console

no logging monitor

!

username test password test

ip subnet-zero

ip host Schumacher 63.228.167.1

ip name-server 209.181.204.1

ip name-server 204.147.80.5

!

!

controller T1 0

framing esf

clock source line primary

linecode b8zs

cas-group 1 timeslots 1-24 type e&m-fgd

fdl att

!

controller T1 1

shutdown

clock source line secondary

!

!

interface Ethernet0

ip address 63.230.153.1 255.255.255.0

ip access-group 100 in

no ip directed-broadcast

ip accounting mac-address input

ip accounting mac-address output

!

interface Serial0

no ip address

no ip directed-broadcast

encapsulation frame-relay

frame-relay lmi-type ansi

!

interface Serial0.21 point-to-point

ip address 10.10.21.1 255.255.255.0

no ip directed-broadcast

frame-relay interface-dlci 21

!

interface Serial1

no ip address

no ip directed-broadcast

shutdown

!

interface Group-Async1

ip unnumbered Ethernet0

no ip directed-broadcast

encapsulation ppp

ip tcp header-compression passive

async mode interactive

peer default ip address pool DialPool

no cdp enable

ppp authentication chap pap callin

group-range 1 24

!

interface Group-Async2

physical-layer async

no ip address

no ip directed-broadcast

!

ip local pool DialPool 63.230.153.126 63.230.153.149

no ip classless

ip route 0.0.0.0 0.0.0.0 10.10.21.2

ip route 10.27.1.0 255.255.255.0 10.10.21.2

ip route 63.0.0.0 255.0.0.0 Serial0.21

ip route 63.228.167.0 255.255.255.0 Serial0.21

ip route 172.27.1.0 255.255.255.0 Serial0.21

ip route 209.25.118.0 255.255.255.0 63.230.153.254

ip route 209.25.119.0 255.255.255.0 63.230.153.254

ip route 209.25.120.0 255.255.255.0 63.230.153.254

ip route 209.25.121.0 255.255.255.0 63.230.153.254

!

access-list 100 deny ip host 63.230.153.254 any

access-list 100 deny ip 209.25.0.0 0.0.255.255 any

access-list 100 permit ip any any

!

line con 0

logging synchronous

transport input none

line 1 24

autoselect during-login

autoselect ppp

login local

modem InOut

transport input all

  • Other Network Infrastructure Subjects
2 REPLIES
Silver

Re: Assigning a static IP address to async dialup

interface Group-Async1

dialer map ip name

Thanks, Mak.

rob
New Member

Re: Assigning a static IP address to async dialup

That did it!

Thanks, Rob

96
Views
0
Helpful
2
Replies