Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Associating dialer interfaces with BRI?

Hi

I am having a problem on a 2522 with 2 dialer interfaces associated with a single BRI.The first dialer interface is setup for dialin and the second dials into a remote site with a NAT overlaod.The problem I am experiencing is that when you dial in it associates the incomming connection with the second dialer (nat) and obviously doesn't work. If I shut the second dialer down and debug, I get an error that the incomming connection can't bind to an interface. How does the router know which dialer interface to associate an incomming call with?

  • Other Network Infrastructure Subjects
6 REPLIES
Bronze

Re: Associating dialer interfaces with BRI?

An incomming call is bound to a dialer interface that has either (or both)

- a "dialer caller " command for which the matches the CLID of the calling device (if your telco supports Caller ID)

- a "dialer remote-name " command for which the matches the chap/pap username that the remote site uses to identify itself.

If there is no matching dialer, the call will bind to a dialer that has none of the above commands, or fail to bind if such a dialer is not present.

In your case, maybe both dialers are considered 'default' and it chooses the highest numbered one? Or maybe the remote-name is incorrect on the first dialer?

If you want, post your config and we'll have a look?

hth

Herbert

New Member

Re: Associating dialer interfaces with BRI?

Thanks Herbert

I will be giving it a try today. If I am still unsuccessful I will paste the config.

Wayne

New Member

Re: Associating dialer interfaces with BRI?

Hi Herbert

Still no luck!

Here is the config and the debug

Current configuration : 5153 bytes

!

version 12.1

no service single-slot-reload-enable

service timestamps debug datetime localtime

service timestamps log datetime localtime

service password-encryption

service udp-small-servers

service tcp-small-servers

!

hostname CT

!

enable password xxxx

!

username xxxx password xxxx

username xxx password xxxx

username xxxx password 7xxxx

username xxxx password xxxx

username xxx password xxx

username xxx password xxxx

username xxxx password xxx

username xxxx password xxxx

!

!

!

!

ip subnet-zero

no ip domain-lookup

ip host JHB 172.16.16.2

!

ip address-pool dhcp-proxy-client

ip dhcp-server 172.16.0.2

async-bootp subnet-mask 255.255.248.0

async-bootp gateway 172.16.0.1

async-bootp time-server 172.16.0.2

async-bootp dns-server 172.16.0.2

async-bootp nbns-server 172.16.0.2

isdn switch-type basic-net3

modemcap entry USR &F1S02

!

!

!

interface Ethernet0

description connected to EthernetLan

ip address 172.16.0.1 255.255.248.0

ip helper-address 172.16.0.2

ip nat inside

!

interface Serial0

ip address 168.209.21.206 255.255.255.252

ip access-group 100 in

shutdown

no fair-queue

!

interface Serial1

description Link to JHB

bandwidth 64

ip address 172.16.16.1 255.255.248.0

ip mtu 256

no ip route-cache

no ip mroute-cache

compress stac

!

interface Serial2

physical-layer async

description connected to Remote Users

ip unnumbered Ethernet0

encapsulation ppp

ip tcp header-compression

no ip mroute-cache

async mode interactive

peer default ip address dhcp

no cdp enable

ppp authentication chap pap callin if-needed

!

interface Serial3

physical-layer async

description connected to Remote Users

ip unnumbered Ethernet0

encapsulation ppp

ip tcp header-compression

no ip mroute-cache

async mode interactive

peer default ip address dhcp

no cdp enable

ppp authentication chap pap callin if-needed

!

interface Serial4

no ip address

shutdown

!

interface Serial5

no ip address

shutdown

!

interface Serial6

no ip address

shutdown

!

interface Serial7

no ip address

shutdown

!

interface Serial8

no ip address

shutdown

!

interface Serial9

no ip address

shutdown

!

interface BRI0

no ip address

encapsulation ppp

no ip route-cache

no ip mroute-cache

dialer pool-member 1

dialer pool-member 2

dialer pool-member 3

isdn switch-type basic-net3

no fair-queue

no cdp enable

!

interface Dialer1

ip address 172.16.32.1 255.255.248.0

encapsulation ppp

no ip route-cache

no ip mroute-cache

shutdown

dialer in-band

dialer map ip 172.16.32.2 name JHB broadcast

dialer hold-queue 10

dialer load-threshold 10 outbound

dialer-group 1

no fair-queue

no cdp enable

ppp authentication chap

ppp multilink

!

interface Dialer3

description ftp ISDN

ip address negotiated

ip nat outside

encapsulation ppp

dialer pool 1

dialer idle-timeout 30

dialer string 011xxxxxxx

dialer hold-queue 10

dialer-group 3

no cdp enable

ppp pap sent-username xxx password xxxxx!

interface Dialer4

description ISDN dialin

ip unnumbered Ethernet0

ip nat inside

encapsulation ppp

dialer pool 2

dialer remote-name whewetson

dialer-group 2

peer default ip address dhcp

fair-queue

no cdp enable

ppp authentication chap pap callin

!

router eigrp 1

passive-interface BRI0

passive-interface Dialer1

passive-interface Dialer3

passive-interface Dialer4

network 172.16.0.0

no auto-summary

no eigrp log-neighbor-changes

!

ip nat inside source list 5 interface Dialer3 overload

ip classless

ip route 0.0.0.0 0.0.0.0 172.16.0.8

ip route 196.26.120.0 255.255.255.0 Dialer3

ip route 196.26.120.242 255.255.255.255 Dialer3

no ip http server

!

access-list 5 permit 172.16.0.0 0.0.7.255

access-list 100 deny eigrp any any

access-list 100 permit ip any any

access-list 100 permit icmp host 168.209.21.205 host 168.209.21.206

access-list 100 permit nos host 196.26.6.115 host 168.209.21.206

access-list 100 permit icmp 196.23.0.0 0.0.0.255 host 168.209.21.206

access-list 101 permit tcp any any eq ftp

dialer-list 1 protocol ip list 100

dialer-list 2 protocol ip permit

dialer-list 3 protocol ip list 101

snmp-server community 5q RO

!

line con 0

exec-timeout 0 0

password xxxxx

line 2 3

login local

modem InOut

autocommand ppp

transport input all

autoselect during-login

autoselect ppp

stopbits 1

speed 38400

flowcontrol hardware

line aux 0

transport input all

line vty 0 4

exec-timeout 0 0

password xxxx

login

!

end

************************************************

*Apr 11 22:19:58: ISDN BR0: Incoming call id = 0x009F, dsl 0

*Apr 11 22:19:58: ISDN BR0: received HOST_INCOMING_CALL call_id 0x9F

*Apr 11 22:19:58: ISDN BR0: HOST_INCOMING_CALL: (non-POTS) DATA

*Apr 11 22:19:58: ISDN BR0: HOST_INCOMING_CALL: (1) call_type = DATA

*Apr 11 22:19:58: ISDN BR0: HOST_INCOMING_CALL: voice_answer_data = FALSE call t

ype is DATA

*Apr 11 22:19:58: ISDN BR0:1: Incoming call rejected, unbindable

*Apr 11 22:19:58: ISDN BR0: process_disconnect(): call id 0x9F, call type is DAT

A, b_idb 0x1148FC, ces 1, cause Call rejected(0x15)

*Apr 11 22:19:58: ISDN BR0: HOST_INCOMING_CALL: DIALER ERROR 1: bchan 0, call id

9F

*Apr 11 22:19:58: ISDN BR0: received HOST_DISCONNECT_ACK call_id 0x9F

*Apr 11 22:19:58: ISDN BR0: HOST_DISCONNECT_ACK: call type is DATA

*Apr 11 22:20:04: ISDN BR0: Incoming call id = 0x00A0, dsl 0

*Apr 11 22:20:04: ISDN BR0: received HOST_INCOMING_CALL call_id 0xA0

*Apr 11 22:20:04: ISDN BR0: HOST_INCOMING_CALL: (non-POTS) DATA

*Apr 11 22:20:04: ISDN BR0: HOST_INCOMING_CALL: (1) call_type = DATA

*Apr 11 22:20:04: ISDN BR0: HOST_INCOMING_CALL: voice_answer_data = FALSE call t

ype is DATA

*Apr 11 22:20:04: ISDN BR0:1: Incoming call rejected, unbindable

*Apr 11 22:20:04: ISDN BR0: process_disconnect(): call id 0xA0, call type is DAT

A, b_idb 0x1148FC, ces 1, cause Call rejected(0x15)

*Apr 11 22:20:04: ISDN BR0: HOST_INCOMING_CALL: DIALER ERROR 1: bchan 0, call id

A0

*Apr 11 22:20:04: ISDN BR0: received HOST_DISCONNECT_ACK call_id 0xA0

*Apr 11 22:20:04: ISDN BR0: HOST_DISCONNECT_ACK: call type is DATA

*Apr 11 22:20:13: ISDN BR0: Incoming call id = 0x00A1, dsl 0

*Apr 11 22:20:13: ISDN BR0: received HOST_INCOMING_CALL call_id 0xA1

*Apr 11 22:20:13: ISDN BR0: HOST_INCOMING_CALL: (non-POTS) DATA

*Apr 11 22:20:13: ISDN BR0: HOST_INCOMING_CALL: (1) call_type = DATA

*Apr 11 22:20:13: ISDN BR0: HOST_INCOMING_CALL: voice_answer_data = FALSE call t

ype is DATA

*Apr 11 22:20:13: ISDN BR0:1: Incoming call rejected, unbindable

*Apr 11 22:20:13: ISDN BR0: process_disconnect(): call id 0xA1, call type is DAT

A, b_idb 0x1148FC, ces 1, cause Call rejected(0x15)

*Apr 11 22:20:13: ISDN BR0: HOST_INCOMING_CALL: DIALER ERROR 1: bchan 0, call id

A1

*Apr 11 22:20:13: ISDN BR0: received HOST_DISCONNECT_ACK call_id 0xA1

*Apr 11 22:20:13: ISDN BR0: HOST_DISCONNECT_ACK: call type is DATA

*Apr 11 22:20:19: ISDN BR0: Incoming call id = 0x00A2, dsl 0

*Apr 11 22:20:19: ISDN BR0: received HOST_INCOMING_CALL call_id 0xA2

*Apr 11 22:20:19: ISDN BR0: HOST_INCOMING_CALL: (non-POTS) DATA

*Apr 11 22:20:19: ISDN BR0: HOST_INCOMING_CALL: (1) call_type = DATA

*Apr 11 22:20:19: ISDN BR0: HOST_INCOMING_CALL: voice_answer_data = FALSE call t

ype is DATA

*Apr 11 22:20:19: ISDN BR0:1: Incoming call rejected, unbindable

*Apr 11 22:20:19: ISDN BR0: process_disconnect(): call id 0xA2, call type is DAT

A, b_idb 0x1148FC, ces 1, cause Call rejected(0x15)

*Apr 11 22:20:19: ISDN BR0: HOST_INCOMING_CALL: DIALER ERROR 1: bchan 0, call id

A2

*Apr 11 22:20:19: ISDN BR0: received HOST_DISCONNECT_ACK call_id 0xA2

*Apr 11 22:20:19: ISDN BR0: HOST_DISCONNECT_ACK: call type is DATA

Thanks

Wayne

New Member

Re: Associating dialer interfaces with BRI?

You could try putting a dummy caller ID on Dialers that you only ever dial out with - for instance on your Dialer3 you could add "dialer caller 12345" - that way it will never get matched for inbound calls. A bit "dirty" but it works.

You might want to consider putting an access-list on your "line vty 0 4" too since you posted your IP addresses and passwords.... Type 7 encryption is very easily cracked.

All the best,

Alex.

New Member

Re: Associating dialer interfaces with BRI?

Thanks

The router is on a private subnet, and I have overwritten most of the type 7 encryption. I will give the 'dialer call 12345' a try today.

Wayne

New Member

Re: Associating dialer interfaces with BRI?

If i understand the requirement correctly,

Try the "ISDN answer" command in the interface mode.

153
Views
0
Helpful
6
Replies
This widget could not be displayed.