Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Async interface on 3620's coming up but frame never goes down

Hi!

I'm having this problem, I have on site a FR switch with redundant E3 schema, any time one of the E3's come down, Async interfaces for all stores running on that E3 came up, the carrier doesn't think this could be possible if frame never comes down and according to them latency on FR SW is very small, in fact 3620's never detect a pvc state change, even that router asks async to get connected. These are 4 examples of logging in our equipment:

Site 1

Apr 2 13:33:09 CST: %LINK-3-UPDOWN: Interface Async65, changed state to up

Apr 2 13:33:11 CST: %LINEPROTO-5-UPDOWN: Line protocol on Interface Async65, c

anged state to up

Apr 2 13:38:49 CST: %LINEPROTO-5-UPDOWN: Line protocol on Interface Async65, c

anged state to down

Apr 2 13:38:51 CST: %LINK-5-CHANGED: Interface Async65, changed state to reset

Apr 2 13:38:56 CST: %LINK-3-UPDOWN: Interface Async65, changed state to down

Apr 2 18:07:18 CST: %LINK-3-UPDOWN: Interface Async65, changed state to up

Apr 2 18:07:19 CST: %LINEPROTO-5-UPDOWN: Line protocol on Interface Async65, c

anged state to up

Apr 2 18:12:19 CST: %LINEPROTO-5-UPDOWN: Line protocol on Interface Async65, c

anged state to down

Apr 2 18:12:21 CST: %LINK-5-CHANGED: Interface Async65, changed state to reset

Apr 2 18:12:26 CST: %LINK-3-UPDOWN: Interface Async65, changed state to down

Apr 2 23:20:20 CST: %LINK-3-UPDOWN: Interface Async65, changed state to up

Apr 2 23:20:21 CST: %LINEPROTO-5-UPDOWN: Line protocol on Interface Async65, c

anged state to up

Apr 2 23:20:49 CST: %LINEPROTO-5-UPDOWN: Line protocol on Interface Async65, c

anged state to down

Apr 2 23:20:50 CST: %LINK-5-CHANGED: Interface Async65, changed state to reset

Apr 2 23:20:56 CST: %LINK-3-UPDOWN: Interface Async65, changed state to down

Site 2

Apr 2 18:07:17 CST: %LINK-3-UPDOWN: Interface Async65, changed state to up

Apr 2 18:07:20 CST: %LINEPROTO-5-UPDOWN: Line protocol on Interface Async65, ch

anged state to up

Apr 2 18:12:17 CST: %LINEPROTO-5-UPDOWN: Line protocol on Interface Async65, ch

anged state to down

Apr 2 18:12:19 CST: %LINK-5-CHANGED: Interface Async65, changed state to reset

Apr 2 18:12:24 CST: %LINK-3-UPDOWN: Interface Async65, changed state to down

.Apr 2 23:22:51 CST: %LINK-3-UPDOWN: Interface Async65, changed state to up

.Apr 2 23:22:55 CST: %LINEPROTO-5-UPDOWN: Line protocol on Interface Async65, c

hanged state to up

.Apr 2 23:23:42 CST: %LINEPROTO-5-UPDOWN: Line protocol on Interface Async65, c

hanged state to down

.Apr 2 23:23:43 CST: %LINK-5-CHANGED: Interface Async65, changed state to reset

.Apr 2 23:23:49 CST: %LINK-3-UPDOWN: Interface Async65, changed state to down

Site 3

Apr 2 13:33:08 CST: %LINK-3-UPDOWN: Interface Async65, changed state to up

Apr 2 13:33:11 CST: %LINEPROTO-5-UPDOWN: Line protocol on Interface Async65, c

anged state to up

Apr 2 13:38:08 CST: %LINEPROTO-5-UPDOWN: Line protocol on Interface Async65, c

anged state to down

Apr 2 13:38:10 CST: %LINK-5-CHANGED: Interface Async65, changed state to reset

Apr 2 13:38:15 CST: %LINK-3-UPDOWN: Interface Async65, changed state to down

.Apr 2 16:15:34 CST: %AMDP2_FE-5-COLL: AMDP2/FE(0/0), Excessive collisions, TD

=4, TRC=0.

.Apr 2 18:07:17 CST: %LINK-3-UPDOWN: Interface Async65, changed state to up

.Apr 2 18:07:18 CST: %LINEPROTO-5-UPDOWN: Line protocol on Interface Async65,

hanged state to up

.Apr 2 18:12:17 CST: %LINEPROTO-5-UPDOWN: Line protocol on Interface Async65,

hanged state to down

.Apr 2 18:12:19 CST: %LINK-5-CHANGED: Interface Async65, changed state to rese

Apr 2 18:12:24 CST: %LINK-3-UPDOWN: Interface Async65, changed state to down

.Apr 2 19:15:31 CST: %AMDP2_FE-5-COLL: AMDP2/FE(0/0), Excessive collisions, TD

=3, TRC=0.

Apr 2 23:23:44 CST: %LINK-3-UPDOWN: Interface Async65, changed state to up

Apr 2 23:23:46 CST: %LINEPROTO-5-UPDOWN: Line protocol on Interface Async65, c

anged state to up

Apr 2 23:24:12 CST: %LINEPROTO-5-UPDOWN: Line protocol on Interface Async65, c

anged state to down

Apr 2 23:24:13 CST: %LINK-5-CHANGED: Interface Async65, changed state to reset

Apr 2 23:24:19 CST: %LINK-3-UPDOWN: Interface Async65, changed state to down

Site 4

Apr 2 18:07:17 CST: %LINK-3-UPDOWN: Interface Async65, changed state to up

Apr 2 18:07:19 CST: %LINEPROTO-5-UPDOWN: Line protocol on Interface Async65, ch

anged state to up

Apr 2 18:12:18 CST: %LINEPROTO-5-UPDOWN: Line protocol on Interface Async65, ch

anged state to down

Apr 2 18:12:20 CST: %LINK-5-CHANGED: Interface Async65, changed state to reset

Apr 2 18:12:25 CST: %LINK-3-UPDOWN: Interface Async65, changed state to down

Apr 2 23:53:23 CST: %LINK-3-UPDOWN: Interface Async65, changed state to up

Apr 2 23:53:24 CST: %LINEPROTO-5-UPDOWN: Line protocol on Interface Async65, ch

anged state to up

Apr 2 23:53:49 CST: %LINEPROTO-5-UPDOWN: Line protocol on Interface Async65, ch

anged state to down

Apr 2 23:53:50 CST: %LINK-5-CHANGED: Interface Async65, changed state to reset

Apr 2 23:53:56 CST: %LINK-3-UPDOWN: Interface Async65, changed state to down

I hope you can help.

Thanks!

8 REPLIES
Silver

Re: Async interface on 3620's coming up but frame never goes dow

Will need to see why the async generates a call out,

deb dialer / deb dialer detailed / deb chat / deb ppp nego / deb modem will be useful.

Looking at the timestamps do not se any particular pattern as to when the call is generated or torn down, will be interesting to see why the call is generated.

What backup scheme do you have, floating static routes/ dialer watch/ backup int? Will need to see the running config and the relevent "sh ip route" for the frame.

Thanks, Mak.

Bronze

Re: Async interface on 3620's coming up but frame never goes dow

you can also do a "sho dialer" while it is up and it will tell you what triggered the call.

New Member

Re: Async interface on 3620's coming up but frame never goes dow

I can't do that now because that caused the half of our network to switch from one E3 to the other, but the next time it happens, we'll verify that...

Thanks!

New Member

Re: Async interface on 3620's coming up but frame never goes dow

Thanks Mak, unfortunately I'm not allowed to make this kind of tests on a live network, but let me tell you that we're using EIGRP as routing protocol and dial on demand based backup, I wonder if it senses DTR on serial interface, but that's just a wonder. I'm enclosing the running config of it where you'll see an static route fro 1.1.1.1, we're using that to test Dial Backup without droping frame.

router#sh run

Building configuration...

Current configuration:

!

! No configuration change since last restart

!

version 11.2

service timestamps debug datetime localtime show-timezone

service timestamps log datetime localtime show-timezone

service password-encryption

service udp-small-servers

service tcp-small-servers

!

hostname router

!

boot system flash

boot system rom

enable password *DELETED*

!

username dial password *DELETED*

ip subnet-zero

ip domain-name *DELETED*

ip name-server *DELETED*

ip name-server *DELETED*

ip name-server *DELETED*

chat-script DBU "" "at*MX13 dt *DELETED*" TIMEOUT 120 "CONNECT"

clock timezone CST -6

clock summer-time CDT recurring

source-bridge ring-group 1015

dlsw local-peer peer-id *DELETED*

dlsw remote-peer 0 tcp *DELETED*

dlsw remote-peer 0 tcp *DELETED* backup-peer *DELETED* linger 30

dlsw icannotreach sap *DELETED*

dlsw bridge-group 1

dlsw bridge-group 2

!

interface Loopback0

no ip address

no logging event subif-link-status

!

interface Loopback1

no ip address

no logging event subif-link-status

!

interface Ethernet0/0

description IP ADDRESSES *DELETED*

ip address *DELETED* 255.255.255.192 secondary

ip address *DELETED* 255.255.255.192 secondary

ip address *DELETED* 255.255.255.192

ip helper-address *DELETED*

ip helper-address *DELETED*

no ip proxy-arp

no logging event subif-link-status

bridge-group 1

!

interface Serial0/0

no ip address

encapsulation frame-relay IETF

no logging event subif-link-status

bandwidth 56

priority-group 1

!

interface Serial0/0.1 point-to-point

description Frame Relay to Home Office

ip address *DELETED* 255.255.255.252

bandwidth 56

frame-relay interface-dlci *DELETED*

!

interface Serial0/1

no ip address

no logging event subif-link-status

no keepalive

!

interface Serial0/1.1

!

interface Ethernet1/0

description IP ADDRESSES *DELETED*

ip address *DELETED* 255.255.255.192

ip helper-address *DELETED*

ip helper-address *DELETED*

no ip proxy-arp

no logging event subif-link-status

bridge-group 1

!

interface TokenRing1/0

description IP ADDRESSES *DELETED*

no ip address

ip helper-address *DELETED*

ip ospf priority 0

no logging event subif-link-status

shutdown

ring-speed 4

source-bridge *DELETED*

source-bridge spanning

source-bridge proxy-explorer

!

interface Async65

ip unnumbered Ethernet0/0

encapsulation ppp

no logging event subif-link-status

async default routing

no peer default ip address

dialer in-band

dialer idle-timeout 300

dialer string *DELETED*

dialer-group 1

ppp authentication chap

ppp chap hostname *DELETED*

ppp chap password *DELETED*

!

router eigrp 1

network *DELETED*

network *DELETED*

no auto-summary

!

ip classless

ip route 0.0.0.0 0.0.0.0 Async65 175

ip route 1.1.1.1 255.255.255.255 Async65

ip ospf name-lookup

logging buffered 4096 debugging

logging trap notifications

logging *DELETED*

access-list 99 permit *DELETED*

access-list 99 permit *DELETED*

access-list 99 permit *DELETED*

access-list 99 permit *DELETED* 0.0.0.15

access-list 103 deny eigrp any any

access-list 103 deny tcp any any eq 161

access-list 103 deny udp any any eq snmp

access-list 103 deny udp any any eq ntp

access-list 103 permit ip any any

access-list 130 permit ip any *DELETED* 0.255.255.255

access-list 130 permit ip any *DELETED* 0.0.255.255

access-list 130 permit ip any *DELETED* 0.15.255.255

access-list 130 permit ip any *DELETED* 0.31.255.255

access-list 130 permit ip any *DELETED* 0.0.255.255

access-list 130 permit ip any *DELETED* 0.0.255.255

access-list 130 permit ip any *DELETED* 0.15.255.255

access-list 130 permit ip any *DELETED* 0.0.255.255

access-list 130 permit ip any *DELETED* 0.255.255.255

access-list 130 permit udp any any eq bootps

access-list 150 permit eigrp any any

access-list 160 permit tcp any any eq 2065

access-list 160 permit tcp any eq 2065 any

access-list 160 permit icmp any host *DELETED*

access-list 187 deny tcp any any eq www

access-list 187 permit ip any any

priority-list 1 protocol ip high list 150

priority-list 1 protocol ip medium list 160

snmp-server community public RO

snmp-server community S3Jks9OL RW

snmp-server trap-authentication

snmp-server location "*DELETED*"

snmp-server enable traps isdn call-information

snmp-server enable traps config

snmp-server enable traps envmon

snmp-server enable traps syslog

snmp-server enable traps bgp

snmp-server enable traps frame-relay

snmp-server enable traps rtr

snmp-server host *DELETED* public

dialer-list 1 protocol ip list 103

bridge 1 protocol ieee

bridge 2 protocol ieee

banner motd ^CC***********************************************************

This system is for Wal-Mart Stores, Inc. business use only

and is subject to monitoring. Any unauthorized use or

access is strictly prohibited. For questions about this

policy or to report suspected violations contact your

Technical Coordinator or e-mail SECADMIN.

***********************************************************

^C

!

line con 0

password *DELETED*

login

line aux 0

password *DELETED*

script dialer DBU

login

modem InOut

modem autoconfigure discovery

transport input all

speed 115200

flowcontrol hardware

line vty 0 4

password *DELETED*

login

!

end

Thanks for your help!

Cisco Employee

Re: Async interface on 3620's coming up but frame never goes dow

Again as Mak ponited, need to see the debugs but

I think you need to modify the config by adding the default route through the serial interface. (I assume that is the main primary interface) Like

ip route 0.0.0.0 0.0.0.0 serial0/0.1

Other default route via async interface with higher metric is fine.

With that default route via serial sub-interface will only make async65 dialout if that serial sub-interface goes down. In that case the default route via serial sub-interface will be flushed from the routing table and next route via async65 will be activated.

Pl. visit following url for more

http://www.cisco.com/warp/public/793/access_dial/hdlc_12497.html

You can also use next hop ip address in the floating static route too.

Silver

Re: Async interface on 3620's coming up but frame never goes dow

Two other possibilities (a "show ip route" will tell you if the core is not advertising a default route) in case lack of a default route is not the problem:

1 - Traffic is being generated to the test address (1.1.1.1), such as by a network management system which "auto learns" and is probing for the other end of the line.

2 - EIGRP is detecting a line problem which is not being reflected in a change of PVC status (quite common in frame relay networks). Turn on EIGRP logging of neighbor changes (under "router eigrp"). Then figure out why EIGRP is not properly exchanging hellos...

Good luck and good hunting!

Vincent C Jones

www.networkingunlimited.com

Bronze

Re: Async interface on 3620's coming up but frame never goes dow

Isnt EIGRP going to keep the line up? The async line is using the address of the ethernet interface which is up and I assume in EIGRP. Also, I have submitted questions asking for any solution other than static routes to keep EIGRP from calling and got no answers. I have come to the conclusion that EIGRP and DDR dont mix.

Silver

Re: Async interface on 3620's coming up but frame never goes dow

EIGRP will have no impact on line usage if you define it as "uninteresting traffic" in your dialer list. EIGRP mixes extremely well with DDR because you can filter the daylights out of advertisements to control who calls where and when. See my book High Availability Networking with Cisco for many examples of DDR with EIGRP under a wide range of conditions.

Good luck and have fun!

Vincent C Jones

www.networkingunlimited.com

123
Views
0
Helpful
8
Replies
CreatePlease to create content