Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Async Interface Problem

Dear All,

We have a RAS setup at our Central Office.

To setup the RAS network we are using Cisco 2514 router with 8 async interface.

To each async interface we have connected external Dlink modem.

Users were able to dial-in from remote location using windows dialup and external modem , and use to access the central site LAN from the assigned IP Pool configured in the central site router.

Problem we are facing now is that all the async lines are working but the Async interface is not coming UP.

Is this a IOS related bug.

Sample config for singe async interface is as given below

Hostname RAS

enable password cisco

!

interface Ethernet0

ip address 10.5.55.35 255.255.255.240

no ip directed-broadcast

no ip route-cache

!

!

interface Async1

ip unnumbered Ethernet0

no ip directed-broadcast

encapsulation ppp

no ip route-cache

keepalive 10

async mode interactive

peer default ip address 10.10.8.231

ppp authentication pap

line con 0

exec-timeout 0 0

password xxxx

transport input none

line 1 8

modem InOut

transport input all

rxspeed 57600

txspeed 57600

flowcontrol hardware

line aux 0

modem InOut

transport input all

flowcontrol hardware

line vty 0 4

!end

Any suggestion is welcomed

Thanks

6 REPLIES
Silver

Re: Async Interface Problem

Can you please explain what do you mean by "Problem we are facing now is that all the async lines are working but the Async interface is not coming UP"...do you mean by "working" means remote users can dialin & connect fine? OR do you mean that the call does not connect at all?

In the later case will need to see some debugs on the 2514: deb modem / deb ppp nego

Unless we have a complete PPP call terminated on the 2514 we will not see the interface asyn1 as UP/UP.

If we are to add the command "dialer in-band" (basically required if we need to dial out) under interface asyn1 then we will see the status as UP/UP(spoofing) without a call connected.

Thanks,Mak.

New Member

Re: Async Interface Problem

Calls get connected but disconnect immediately i.e Async interface comes up for few seconds and while the remote dialup client is in authentication mode async interface resets (Goes down) while authenticating remote client.

Neither it throws IP to the remote client.

Thanks

Deepak

Silver

Re: Async Interface Problem

We will need to see the following debugs on the router when a call is made & fails:

deb modem / deb ppp nego

Thanks,Mak.

New Member

Re: Async Interface Problem

You have missed some config steps in line mode . With your configuration router side modem CD ( Carrier ditect ) will not reflect on your router and line gets disconnected and async interface will not come up. CD is reflected on PC and Router for speed sync.

you try with this config

interface ethernet 0

ip address 10.11.1.1 255.255.255.0

interface Group-Async1

ip unnumbered Ethernet0

encapsulation ppp

async mode interactive

peer default ip address pool zoom

group-range 1 16

!

ip local pool zoom 10.11.1.215 10.11.1.226

ip classless

!

line con 0

line 1 16

autoselect ppp

login local

modem InOut

modem autoconfigure discovery

transport input all

Rourer(Config)#username zoom password zoom

hope it will help you

New Member

Re: Async Interface Problem

Hi,

Tried the posted config but still while authenticating the remote client async interface resets.(State of the interface changes from UP to reset and Down).

Remote Client not getting authenticated.

Correction Router is 2509

Thanks

New Member

Re: Async Interface Problem

Hi,

Tested the posted config , observed that after putting modem autoconfigure discovery it started working.

thanks.

160
Views
0
Helpful
6
Replies
CreatePlease to create content