Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

Async Serial PPP Dialup access.

I am trying to connect a 1602 router to an ISP via a PPP connection. On the 1602 end I have a Serial WAN interface card hooked up to a modem via a CAB-232FC cable. My questions are: How do I configure the router to make the call to the ISP and connect properly. My second question is, other then the gender of the DB25 end of my cable, is there a difference between the CAB-232FC and the CAB-232MT? As you may have guessed, I bought the wrong one.

17 REPLIES
Bronze

Re: Async Serial PPP Dialup access.

You will configure the router for "Easy IP" . Please see the following for that :

http://www.cisco.com/warp/customer/105/37.html

CAB-232FC is what it makes the router a DCE device while CAB-232MT is what its makes it

a DTE. So in your case you need the MT cable since your router is DTE.

New Member

Re: Async Serial PPP Dialup access.

Thanks ZULFIQAR,

My local Cisco Supplier was nice enough to trade an MT cable for a FC cable. Do you know if there is minimum length to the serial cable? I need to make mine as short as possible. Also, Can you point me to the best document that will walk me through setting my router up?

Bronze

Re: Async Serial PPP Dialup access.

Frankly I dont know if there is any minimum allowed length of this cable. But I would guess the minimum length should not matter much. Its the maximum length which should/does.

New Member

Re: Async Serial PPP Dialup access.

ZULFIQAR,

The link you suggest shows how to setup Easy IP on an Async interface. I have a Serial WIC connected to a modem. I have set the interface to async. After doing that I did a "show line" and found that line 2 is my async line. Do I just change the sample configuration to fit my setup or do I need to do something else entirely? I had though that I would need to use modem caps instead of chat-scripts.

Also this dial up line will be the primary and only circuit for this router.

Bronze

Re: Async Serial PPP Dialup access.

Once you do "physical-layer async" on a sync/async serial which is what you have, a tty line shows up not only in show line output but in the config as well. So all you need to do now is modify the sample config to fit accordingly into your setup. Nothing special you need to do on your serial

compared to a default async interface. This serial with the help of physical-layer async is just as good as a regular async line/interface. No modemcaps are required here. In async DDR, you use the chat-script to tell the router what to expect and what to send in response to what was expected. I believe even if you do not have one defined in the config, a default chat-script from the

IOS should play its part.

Sure. Many people use easy IP DDR as the sole connection method to the ISP.

New Member

Re: Async Serial PPP Dialup access.

hi,

i am a new member. i've found your discussion intresting. i have a problem using ddr between a 3620 with a 16 port analog network modem and a 2611 going through a motorola codex modem via a serial port. the connection is asynchronous, and in fact connection is established the problem is that no data is passed. when i debug i get the statement encapsulation failed. the encapsulation type is ppp. the 3620 can see the 2611 as a cdp nei. but the 2611 can not see the 3620, this shows that the connection is established.

Cisco Employee

Re: Async Serial PPP Dialup access.

"encap fail" could be also because of ipcp problems. We need to see the debug about the ppp negotiation. Looks to me that the IPCP during PPP may not be negotiated correctly..

So pl. turn on the following debug on the side receiving the call.

debug modem

debug dialer

debug ppp negotiation

debug ppp authentication

after that lets have the "sh run" and "sh ip route" after the connection is established..Thx..Tejal

New Member

Re: Async Serial PPP Dialup access.

i'll get you the info you requested. but i noticed that after a connection is established and i do a show interface the async interface has lcp open, ipcp open and cdpcp open

thanks

Bronze

Re: Async Serial PPP Dialup access.

With IPCP open , I dont think you need to care about the debugs anymore.

At this point you should open up a case with TAC for further troubleshooting.

~Zulfi

New Member

Re: Async Serial PPP Dialup access.

thanks. thats what i'll do this week.

New Member

Re: Async Serial PPP Dialup access.

hi,

i have a follow up to my problem. it turns out that it was an ios problem.

the ios on the 3640 was re-installed with a lower version that matched the one on the 2611. after this the connection started passing data.

thanks for the help.

New Member

Re: Async Serial PPP Dialup access.

tejal,

here's what you asked for: as you can see the two sides connect and it appears as if the ppp negotiation is successful. i hope you'll be able to figure something out

MODEM_BANK#clear line 34

[confirm]

[OK]

MODEM_BANK#termin

MODEM_BANK#terminal monitor

MODEM_BANK#clear line 34

[confirm]

[OK]

MODEM_BANK#

00:23:27: TTY34: Line reset by "Virtual Exec"

00:23:27: TTY34: Modem: IDLE->HANGUP

00:23:27: TTY34: no timer type 0 to destroy

00:23:27: TTY34: no timer type 1 to destroy

00:23:27: TTY34: no timer type 3 to destroy

00:23:27: TTY34: no timer type 4 to destroy

00:23:27: TTY34: no timer type 2 to destroy

00:23:27: TTY34: dropping DTR, hanging up

00:23:27: tty34: Modem: HANGUP->IDLE

MODEM_BANK#debug

00:23:32: TTY34: restoring DTR

00:23:33: TTY34: autoconfigure probe started

MODEM_BANK#debug diale

00:23:36: %TTY-3-AUTOCONFIG: TTY34: Modem auto-configuration failed

MODEM_BANK#debug dialer

Dial on demand events debugging is on

MODEM_BANK#debug modem

Modem control/process activation debugging is on

MODEM_BANK#debug ppp ne

MODEM_BANK#debug ppp negotiation

PPP protocol negotiation debugging is on

MODEM_BANK#

00:25:04: Modem 1/1 Mcom: in modem state 'Dialing/Answering'

00:25:04: Modem 1/1 Mcom: in modem state 'Incoming ring'

MODEM_BANK#

00:25:06: Modem 1/1 Mcom: in modem state 'Waiting for Carrier'

MODEM_BANK#

00:25:17: Modem 1/1 Mcom: in modem state 'Connected'

00:25:18: Modem 1/1 Mcom: CONNECT at 31200/31200(Tx/Rx), V34, LAPM, V42bis, Ansr

00:25:18: TTY34: DSR came up

00:25:18: Modem 1/1 Mcom: switching to PPP mode

00:25:18: TTY34: no timer type 1 to destroy

00:25:18: TTY34: no timer type 0 to destroy

00:25:18: tty34: Modem: IDLE->(unknown)

MODEM_BANK#

00:25:20: As34 LCP: I CONFREQ [Closed] id 140 len 20

00:25:20: As34 LCP: ACCM 0x000A0000 (0x0206000A0000)

00:25:20: As34 LCP: MagicNumber 0x0724BBC4 (0x05060724BBC4)

00:25:20: As34 LCP: PFC (0x0702)

00:25:20: As34 LCP: ACFC (0x0802)

00:25:20: As34 LCP: Lower layer not up, Fast Starting

00:25:20: As34 PPP: Treating connection as a callin

00:25:20: As34 PPP: Phase is ESTABLISHING, Passive Open [0 sess, 1 load]

00:25:20: Modem 1/1 Mcom: PPP escape map: Tx map = FFFFFFFF, Rx map = 0

00:25:20: As34 PPP: No remote authentication for call-in

00:25:20: As34 LCP: State is Listen

00:25:20: Modem 1/1 Mcom: PPP escape map: Tx map = FFFFFFFF, Rx map = 0

00:25:20: As34 PPP: No remote authentication for call-in

00:25:20: As34 LCP: O CONFREQ [Listen] id 106 len 20

00:25:20: As34 LCP: ACCM 0x000A0000 (0x0206000A0000)

00:25:20: As34 LCP: MagicNumber 0x30980D57 (0x050630980D57)

00:25:20: As34 LCP: PFC (0x0702)

00:25:20: As34 LCP: ACFC (0x0802)

00:25:20: As34 LCP: O CONFACK [Listen] id 140 len 20

00:25:20: As34 LCP: ACCM 0x000A0000 (0x0206000A0000)

00:25:20: As34 LCP: MagicNumber 0x0724BBC4 (0x05060724BBC4)

00:25:20: As34 LCP: PFC (0x0702)

00:25:20: As34 LCP: ACFC (0x0802)

00:25:20: %LINK-3-UPDOWN: Interface Async34, changed state to up

MODEM_BANK#

00:25:20: As34 DDR: Dialer statechange to up

00:25:20: As34 DDR: Dialer received incoming call from

MODEM_BANK#

00:25:22: As34 LCP: I CONFREQ [ACKsent] id 141 len 20

00:25:22: As34 LCP: ACCM 0x000A0000 (0x0206000A0000)

00:25:22: As34 LCP: MagicNumber 0x0724BBC4 (0x05060724BBC4)

00:25:22: As34 LCP: PFC (0x0702)

00:25:22: As34 LCP: ACFC (0x0802)

00:25:22: As34 LCP: O CONFACK [ACKsent] id 141 len 20

00:25:22: As34 LCP: ACCM 0x000A0000 (0x0206000A0000)

00:25:22: As34 LCP: MagicNumber 0x0724BBC4 (0x05060724BBC4)

00:25:22: As34 LCP: PFC (0x0702)

00:25:22: As34 LCP: ACFC (0x0802)

00:25:22: As34 LCP: TIMEout: State ACKsent

00:25:22: As34 LCP: O CONFREQ [ACKsent] id 107 len 20

00:25:22: As34 LCP: ACCM 0x000A0000 (0x0206000A0000)

00:25:22: As34 LCP: MagicNumber 0x30980D57 (0x050630980D57)

00:25:22: As34 LCP: PFC (0x0702)

00:25:22: As34 LCP: ACFC (0x0802)

00:25:22: As34 LCP: I CONFACK [ACKsent] id 107 len 20

00:25:22: As34 LCP: ACCM 0x000A0000 (0x0206000A0000)

00:25:22: As34 LCP: MagicNumber 0x30980D57 (0x050630980D57)

00:25:22: As34 LCP: PFC (0x0702)

00:25:22: As34 LCP: ACFC (0x0802)

00:25:22: As34 LCP: State is Open

00:25:22: Modem 1/1 Mcom: PPP escape map: Tx map = A0000, Rx map = 0

00:25:22: As34 PPP: Phase is UP [0 sess, 0 load]

00:25:22: As34 IPCP: O CONFREQ [Closed] id 2 len 10

00:25:22: As34 IPCP: Address 10.2.184.1 (0x03060A02B801)

00:25:22: As34 CDPCP: O CONFREQ [Closed] id 2 len 4

00:25:22: As34 IPCP: I CONFREQ [REQsent] id 2 len 10

00:25:22: As34 IPCP: Address 10.2.184.2 (0x03060A02B802)

00:25:22: As34 IPCP: O CONFACK [REQsent] id 2 len 10

00:25:22: As34 IPCP: Address 10.2.184.2 (0x03060A02B802)

00:25:22: As34 CDPCP: I CONFREQ [REQsent] id 2 len 4

00:25:22: As34 CDPCP: O CONFACK [REQsent] id 2 len 4

00:25:22: As34 IPCP: I CONFACK [ACKsent] id 2 len 10

00:25:22: As34 IPCP: Address 10.2.184.1 (0x03060A02B801)

00:25:22: As34 IPCP: State is Open

00:25:22: As34 DDR: dialer protocol up

00:25:22: As34 IPCP: Install route to 10.2.184.2

00:25:22: As34 CDPCP: I CONFACK [ACKsent] id 2 len 4

MODEM_BANK#

00:25:22: As34 CDPCP: State is Open

MODEM_BANK#

00:25:23: %LINEPROTO-5-UPDOWN: Line protocol on Interface Async34, changed statp

MODEM_BANK#ping 10.2.184.2

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 10.2.184.2, timeout is 2 seconds:

.....

Success rate is 0 percent (0/5)

MODEM_BANK#sh cdp nei

Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge

S - Switch, H - Host, I - IGMP, r - Repeater

Device ID Local Intrfce Holdtme Capability Platform Port ID

ddrtest Async34 132 R 2611 Ser 1/4

SCA041704X1(Backbone_switch1)

Eth 0/0 164 T S WS-C6509 5/17

MODEM_BANK#debug cdp ?

adjacency CDP neighbor info

events CDP events

ip CDP ip info

packets CDP packet-related information

MODEM_BANK#debug cdp events

CDP events debugging is on

MODEM_BANK#sh cdp

00:32:09: CDP-EV: Unrecognized type (12) seen in TLV

00:32:09: CDP-EV: Unrecognized type (13) seen in TLV

MODEM_BANK#sh cdp nei

Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge

S - Switch, H - Host, I - IGMP, r - Repeater

Device ID Local Intrfce Holdtme Capability Platform Port ID

ddrtest Async34 145 R 2611 Ser 1/4

SCA041704X1(Backbone_switch1)

Eth 0/0 177 T S WS-C6509 5/17

MODEM_BANK#

00:32:46: CDP-EV: Encapsulation on interface Async34 failed

00:32:46: CDP-EV: Encapsulation on interface Async34 failed

MODEM_BANK#sh i

00:33:09: CDP-EV: Unrecognized type (12) seen in TLV

00:33:09: CDP-EV: Unrecognized type (13) seen in TLV

00:33:46: CDP-EV: Encapsulation on interface Async34 failed

00:33:46: CDP-EV: Encapsulation on interface Async34 failed

MODEM_BANK#

00:34:09: Modem 1/1 Mcom: in modem state 'Connected'

00:34:09: Modem 1/1 Mcom: in modem state 'Retrain Accepted'

00:34:09: Modem 1/1 Mcom: Connection update 31200/26400 (Tx/Rx), V34

00:34:09: CDP-EV: Unrecognized type (12) seen in TLV

00:34:09: CDP-EV: Unrecognized type (13) seen in TLV

MODEM_BANK(config)#

00:34:46: CDP-EV: Encapsulation on interface Async34 failed

00:34:46: CDP-EV: Encapsulation on interface Async34 failed

MODEM_BANK#sh ip route 10.2.184.0

Routing entry for 10.2.184.0/22

Known via "connected", distance 0, metric 0 (connected, via interface)

Redistributing via rip

Advertised by rip

Routing Descriptor Blocks:

* directly connected, via Async34

Route metric is 0, traffic share count is 1

MODEM_BANK#sh line 34

Tty Typ Tx/Rx A Modem Roty AccO AccI Uses Noise Overruns Int

A 34 TTY - DialIn - - - 3 0 0/0 -

Ready

Line 34, Location: "DDR connection to ddrtest", Type: ""

Length: 24 lines, Width: 80 columns

Status: Ready, Active, No Exit Banner, Async Interface Active

HW PPP Support Active, Modem Detected, CTS Raised

Capabilities: Hardware Flowcontrol In, Hardware Flowcontrol Out

Modem RI is CD, Line is permanent async interface, Modem Autoconfigure

Integrated Modem

Modem state: Ready

modem(slot/port):1/1, csm_state:CONNECTED_STATE,

bchan_num:-1 csm_status: CALL_ACTIVE

Line is running PPP routing for address 10.2.184.2.

0 output packets queued, 0 input packets.

Async Escape map is 00000000000000000101000000000000

Modem hardware state: CTS DSR DTR RTS, Modem Configured

Special Chars: Escape Hold Stop Start Disconnect Activation

^^x none - - none

Timeouts: Idle EXEC Idle Session Modem Answer Session Dispatch

00:10:00 never none not set

Idle Session Disconnect Warning

never

Login-sequence User Response

00:00:30

Autoselect Initial Wait

not set

Modem type is microcom_hdms.

Session limit is not set.

Time since activation: 00:16:08

Editing is enabled.

History is enabled, history size is 10.

DNS resolution in show commands is enabled

Full user help is disabled

Allowed input transports are pad v120 lapb-ta telnet rlogin udptn.

Allowed output transports are pad v120 lapb-ta telnet rlogin.

Preferred transport is telnet.

No output characters are padded

No special data dispatching characters

MODEM_BANK#sh run

Building configuration...

Current configuration : 8059 bytes

!

version 12.2

no parser cache

no service single-slot-reload-enable

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname MODEM_BANK

!

logging rate-limit console 10 except errors

enable password cisco

ip subnet-zero

!

!

no ip domain-lookup

!

no ip dhcp-client network-discovery

chat-script async "" "AT" OK "ATDT\T" TIMEOUT 30 CONNECT \c

!

!

!

interface Loopback1

ip address 10.0.0.1 255.255.255.0

!

interface Ethernet0/0

ip address 10.50.1.1 255.255.252.0 secondary

ip address 10.0.12.3 255.255.252.0

half-duplex

!

interface Ethernet0/1

no ip address

shutdown

half-duplex

!

interface Ethernet0/1.1

!

interface Serial3/0

no ip address

shutdown

!

interface Serial3/1

no ip address

shutdown

no ignore-hw local-loopback

!

interface Serial3/2

no ip address

shutdown

no ignore-hw local-loopback

!

interface Serial3/3

no ip address

shutdown

no ignore-hw local-loopback

!

interface Serial3/4

no ip address

shutdown

no ignore-hw local-loopback

!

interface Serial3/5

no ip address

shutdown

no ignore-hw local-loopback

!

interface Serial3/6

no ip address

shutdown

no ignore-hw local-loopback

!

interface Serial3/7

no ip address

shutdown

no ignore-hw local-loopback

!

interface Async33

encapsulation ppp

no ip route-cache

no ip mroute-cache

shutdown

dialer in-band

dialer idle-timeout 180

dialer map ip 10.0.96.2 xxxx

dialer map ip 10.0.96.2 4971848

dialer-group 1

async mode dedicated

no peer default ip address

no fair-queue

!

interface Async34

description DDR connection to ddrtest

bandwidth 24

ip address 10.2.184.1 255.255.252.0

encapsulation ppp

loopback

dialer in-band

dialer idle-timeout 8000

async default routing

async mode dedicated

no peer default ip address

no fair-queue

cdp enable

!

router rip

passive-interface Async33

network 10.0.0.0

!

ip local pool ADDRESS 10.0.0.2 10.0.0.255

ip classless

ip route 10.0.76.0 255.255.252.0 10.0.80.2

ip route 10.0.80.2 255.255.255.255 Async38

ip route 10.0.92.0 255.255.252.0 10.0.96.2

ip route 10.0.96.2 255.255.255.255 Async33

ip route 10.1.36.0 255.255.252.0 10.1.40.2

ip route 10.1.40.0 255.255.255.255 Async36

ip route 10.1.60.0 255.255.252.0 10.1.64.2

ip route 10.1.64.2 255.255.255.255 Async40

ip route 10.1.124.0 255.255.252.0 10.1.128.2

ip route 10.1.128.2 255.255.255.255 Async39

ip route 10.2.0.0 255.255.252.0 10.2.72.2

ip route 10.2.68.0 255.255.252.0 10.2.72.2

ip route 10.2.72.2 255.255.255.255 Async48

ip route 10.2.76.0 255.255.252.0 10.2.80.2

ip route 10.2.80.2 255.255.255.255 Async35

ip route 10.2.116.0 255.255.252.0 10.2.120.2

ip route 10.2.120.2 255.255.255.255 Async37

ip route 10.2.180.0 255.255.252.0 10.2.184.2

no ip http server

!

logging trap notifications

logging 10.0.12.53

access-list 1 permit 0.0.0.0 255.255.252.0

dialer-list 1 protocol ip permit

snmp-server engineID local 000000090200003080D9F0C0

snmp-server community public RO

privilege configure level 3 username engineer

!

line con 0

line 33

modem InOut

modem autoconfigure type microcom_hdms

transport input all

flowcontrol hardware

line 34

modem Dialin

modem autoconfigure type microcom_hdms

transport input all

autoselect ppp

parity space

flowcontrol hardware

line 35 37

modem InOut

modem autoconfigure type microcom_hdms

transport input all

flowcontrol hardware

line 38

modem InOut

modem autoconfigure type microcom_hdms

transport input all

parity space

stopbits 1

flowcontrol hardware

line 39

modem InOut

modem autoconfigure type microcom_hdms

transport input all

flowcontrol hardware

line 40

modem InOut

modem autoconfigure type microcom_hdms

transport input all

parity space

flowcontrol hardware

line 41 47

modem InOut

transport input all

flowcontrol hardware

line 48

modem InOut

modem autoconfigure type microcom_hdms

transport input all

parity space

flowcontrol hardware

line 65 80

line aux 0

line vty 0 4

password cisco

logging synchronous

login

!

!

end

Cisco Employee

Re: Async Serial PPP Dialup access.

Dosen't look anything wrong with debug except.."loopback" under the interface async34..Any reason for that? Now the question is do you see anything wrong on calling side?

Pl. try to take a help from Cisco's TAC engineers via opening a case at

http://www.cisco.com/tac

Tejal

New Member

Re: Async Serial PPP Dialup access.

the calling side appears to be ok. i'll open a TAC case this week. thanks

New Member

Re: Async Serial PPP Dialup access.

hi,

i have a follow up to my problem. it turns out that it was an ios problem.

the ios on the 3640 was re-installed with a lower version that matched the one on the 2611. after this the connection started passing data.

thanks for the help.

Bronze

Re: Async Serial PPP Dialup access.

If you are using legacy DDR and have dialer maps on

both ends, make sure that the name of the other side

in dialer map is exactly what the other side's hostname is...It should be in the same uppercase or

lowercase. You can get encap failure due to this

common mistake too.

New Member

Re: Async Serial PPP Dialup access.

thanks.

we are initiating dial from the 2611 so we have a dialer string configured there. on the 3620 we do not have dialer maps configured to the async interface.

569
Views
0
Helpful
17
Replies
CreatePlease login to create content