Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

ATM and Dialer config for ADSL WIC for Newbie

Cisco 2621 w/ 1-port ADSL WIC running Cisco IOS 12.2(11)T1

Getting following errors after setting up atm 0/0 and Dailer:

00:04:05: %DIALER-6-BIND: Interface Vi4 bound to profile Di1

00:04:05: %LINK-3-UPDOWN: Interface Virtual-Access4, changed state to up

00:04:07: %DIALER-6-UNBIND: Interface Vi4 unbound from profile Di1

00:04:29: %DIALER-6-BIND: Interface Vi5 bound to profile Di1

00:04:29: %LINK-3-UPDOWN: Interface Virtual-Access5, changed state to up

00:04:31: %DIALER-6-UNBIND: Interface Vi5 unbound from profile Di1

At one point I saw a message about "Cannot connect, dialer string not set". Not sure what to put for dialer string as I'm taking off an example config the ISP provided. I show their sample config after my config.

Here's the config on my router:

Current configuration : 1510 bytes

!

version 12.2

service config

no service pad

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname cnb

!

enable secret 5 $1$n4u4$6a65dMJNFNayGDSJyZj8U0

enable password 7 02040D4F080E

!

username cnb privilege 15 password 7 045F1E0403284216

ip subnet-zero

!

!

ip name-server 159.134.237.6

ip name-server 159.134.237.17

!

vpdn enable

!

vpdn-group 1

request-dialin

protocol pppoe

!

!

!

voice call carrier capacity active

!

!

!

!

!

!

!

!

!

mta receive maximum-recipients 0

!

!

!

!

interface ATM0/0

no ip address

no atm ilmi-keepalive

pvc 8/35

encapsulation aal5snap

pppoe-client dial-pool-number 1

!

dsl operating-mode auto

no fair-queue

!

interface FastEthernet0/0

ip address 62.77.170.72 255.255.255.0

speed auto

half-duplex

no cdp enable

!

interface FastEthernet0/1

ip address 192.168.0.2 255.255.255.0

no ip proxy-arp

no ip route-cache

no ip mroute-cache

speed auto

half-duplex

no cdp enable

!

interface Dialer1

ip unnumbered FastEthernet0/0

encapsulation ppp

dialer pool 1

dialer remote-name redback

dialer-group 1

ppp authentication pap chap callin

ppp chap hostname cnb

ppp chap password 7 06021A2340470741

!

ip classless

ip route 0.0.0.0 0.0.0.0 Dialer1

no ip http server

ip pim bidir-enable

!

!

access-list 1 permit any

dialer-list 1 protocol ip list 1

!

no call rsvp-sync

!

!

mgcp profile default

!

dial-peer cor custom

!

!

!

!

line con 0

exec-timeout 0 0

line aux 0

line vty 0 4

password 7 104C080A1116000F

login

!

!

end

ISP Sample Configuration:

Building configuration...

Current configuration : 1257 bytes

!

version 12.2

no service pad

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname frankblack-gw

!

enable secret 5 $1$DNOj$g7.98XMP1rAlvPSih/Sbrfht0

!

username frankblack privilege 15 password 7 094NB4O10T61H70PP

ip subnet-zero

!

!

ip name-server 159.134.237.6

!

vpdn enable

!

vpdn-group 1

request-dialin

protocol pppoe

!

!

!

!

!

interface ATM0

no ip address

no atm ilmi-keepalive

pvc 8/35

encapsulation aal5snap

pppoe-client dial-pool-number 1

!

dsl operating-mode auto

no fair-queue

!

interface FastEthernet0

ip address 10.77.171.129 255.255.255.248

ip tcp adjust-mss 1452

speed auto

!

interface Dialer1

ip unnumbered FastEthernet0

encapsulation ppp

dialer pool 1

dialer remote-name redback

dialer-group 1

ppp authentication pap chap callin

ppp chap hostname frankblack

ppp chap password 7 1N5O17P0A3SE2SE75W

!

ip classless

ip route 0.0.0.0 0.0.0.0 Dialer1

no ip http server

! ! access-list 10 permit 10.77.171.128 0.0.0.7 access-list 10 permit 159.134.222.0 0.0.1.255 dialer-list 1 protocol ip list 1 !

!

line con 0

exec-timeout 50 0

password 7 08N64O410W10YB

login

stopbits 1

line aux 0

line vty 0 4

access-class 10 in

exec-timeout 5 0

login local

length 0

!

scheduler max-task-time 5000

end

2 REPLIES
Bronze

Re: ATM and Dialer config for ADSL WIC for Newbie

Here's a link to the access technical tips. There are some additional links at the bottom with helpful debug information.

http://www.cisco.com/warp/public/471/index.shtml

New Member

Re: ATM and Dialer config for ADSL WIC for Newbie

Turns out that the ISP hadn't set up our login yet or routed our IP range.

232
Views
0
Helpful
2
Replies
CreatePlease to create content