Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Community Member

Auto negotiation issues with a Cat6506 IOS

I am experiencing a problem with some user ports in two Cat 6506 switches with IOS.

After some time in use, some ports are unable to forward traffic. I have to hardcode the speed and duplex in the switch port to make them work. Some times at 100-full others at 10-half. Does anyone have come across this problem? The cards in the switch are WS-X6748-GE-TX and the IOS is IOS (tm) s72033_rp Software (s72033_rp-JK9SV-M), Version 12.2(18)SXD4, RELEASE SOFTWARE (fc1)

I have looked in the web site for any bug or reference to this problem but I haven't found anything. Much appreciated if someone can point me in the right direction.

Regards,

Arturo Maldonado

4 REPLIES
Community Member

Re: Auto negotiation issues with a Cat6506 IOS

Hi Arturo,

Generally these issues seem to more spcific to the NIC's that you use on the workstations/servers. Here is a link that will help you understand the issues and a NIC wise resolution for such issues.

http://www.cisco.com/en/US/partner/products/hw/switches/ps700/products_tech_note09186a00800a7af0.shtml

Hope this helps,

Regards,

Param

Community Member

Re: Auto negotiation issues with a Cat6506 IOS

Param,

Thank you for your comments. Yes! I had considered the possibility of a driver issue with the NICs since all the ports with problems have a Dell laptop attached to it. Now, not all ports have this problem, and it is ocassionally that the port stops forwarding traffic, that is why I thought I could resolve this problem by looking at the switch first.

Somebody else has sent me the bug reference number (CSCsa76031)that my problem relates to, and yes! I have to upgrade the IOS.

Thanks for your assistance and your time to read this.

Arturo Maldonado.

Purple

Re: Auto negotiation issues with a Cat6506 IOS

I would check bug cscsa76031 sounds like almost exactly what you are running into and yes you know what the answer is upgrade , looks like the fix is 12.2.18 SXD5 .

Headline 6748-GE-TX: Transmit fails on port hardcoded to 10/100 or auto mode

Product IOS

Feature OTHERS Components Duplicate of

Severity 2 Severity help Status Resolved Status help

First Found-in Version 12.2(18)SXD All affected versions First Fixed-in Version 12.2(18)SXE, 8.6(0.81)TAL, 8.4(2.8), 8.5(0.66)JAC, 8.4(2.9), 8.6(0.66)ROC01, 8.4(0.61)RCC09, 12.2(18)SXD05 Version help

Release Notes

On WS-X6748-GE-TX linecard ports, configured for speed 10 or 100 Mbps, may stop

transmitting frames. The out-Discard counter starts counting up. Mac address

learning on the port stops.

This occurs on hardware revision 2.1 when running 12.2(18)SXD3, or 8.4(1),

8.4(2), 8.4(2a) software. Older hardware revisions or older software do not

appear to be affected.

Workaround: Reset the linecard. This will resolve the stuck condition until

the port is reset again.

The issue can also happen configuring the speed to auto when the speed change on

the other peer

Workaround: toggle the speed from 10 Mbps to auto. This will resolve the stuck

condition until the port is reset again.

Community Member

Re: Auto negotiation issues with a Cat6506 IOS

Glen,

Thank you very much for sending me the bug reference number, I was almost certain that I had to upgrade but without any backing it was going to be difficult to get it approved.

Regards,

Arturo Maldonado.

219
Views
0
Helpful
4
Replies
CreatePlease to create content