Cisco Support Community
Community Member

auto smartport macro with non-cisco devices, 2960X / XR

I've been fighting with auto smart port detection macros for a while now and they just don't seem to work. Is this just a broken technology, or am I doing something wrong?

We have Panasonic VoIP phones that detect correctly by MAC address, but won't get a DHCP address if the switch is set to configure a vlan (it gets the IP on the default vlan, THEN the macro runs, then the phone has the wrong IP for the new voice subnet - the ports won't bounce after the vlan change, so the device never tries to get a correct IP). It also breaks if we try and enable trunking to the secondary ethernet port. Now none of our  2960XR switches will even run the macro when a phone is connected. I've had luck before rebooting the switch to restart the macro processes, but now the switch is in production and I don't have that luxury. 

We also have tried to get this working with Motorola (now Zebra) access points being detected with a macro that sets the ports for trunking. The APs get detected correctly, but are regularly un-detected. The 2960x will cycle back to the macro config; the 2960XR just sticks at the default access config. It appears to be triggered when packets from a wireless client come through and are detected by the macro. I've tried both MAC and LLDP detection and get similar results. I'm curious how it works differently when using Cisco AP detection - assuming that DOES actually work?

I've had a TAC case open for about a month for this and have gotten no where. I fought HARD to get cisco switches in the first place and now they aren't working as advertised, and I'm thoroughly PISSED. Does this shit actually work, or am I fighting a losing battle? 

I was hoping to just manually run the macro when a phone / AP gets connected, but it looks like that 'feature' was removed in IOS 15?

Everyone's tags (1)
Hall of Fame Super Blue

I was hoping to just manually

I was hoping to just manually run the macro when a phone / AP gets connected, but it looks like that 'feature' was removed in IOS 15?

Smartport Macro (not the auto-smartport macro) was "removed" after 12.2(58)SE.  


Smartport Macro is now a HIDDEN command.   Read below. 

macro name MACRO_NAME

To initiate an interface SmartPort Macro, you do the following combo: 

config t
interface [BLAH]
macro apply MACRO_NAME

To see a list of SmartPort Macro in your switch, use the enable command "sh parser macro brief".  And if you want to see the configuration of a your macro, use the command "sh parser macro named MACRO_NAME".  


Hope this helps.

Community Member

You'd better know much about

You'd better know much about Cisco 2960X to help you solve your problem.

CreatePlease to create content