Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

automatic redistribute static route that point on a serial...

hi,

On this CISCO URL :

http://www.cisco.com/univercd/cc/td/doc/product/software/ios122/122cgcr/fdial_r/drfeip.htm#xtocid20

We can read this part of explanation about how to use the command "ip route..."

****************************************************Static routes that point to an interface will be advertised using RIP,

IGRP, and other dynamic routing protocols, regardless of whether

redistribute static commands were specified for those routing protocols.

These static routes will be advertised because static routes that point

to an interface are considered to be connected in the routing table and

hence lose their static nature. However, if you define a static route to

an interface that is not in one of the networks defined in a network

command, no dynamic routing protocols will advertise the route unless a

redistribute static command is specified for these protocols.

****************************************************

I try to apply this theory and make a test

with this kind of configuration :

Router R1

eth0

ip address 192.168.1.1 255.255.255.0

!

router ospf 1

network 192.168.1.0 0.0.0.255 area 1

Router R2

eth0

ip addr 192.168.1.2 255.255.255.0

!

s0

ip address 172.16.1.1 255.255.255.252

!

ip route 10.10.10.0 255.255.255.0 s0

!

router ospf 1

network 192.168.1.0 0.0.0.255 area 1

network 10.10.10.0 0.0.0.255 area 1

So if I well read the text of CISCO,

I would see on the router R1 this OSPF route :

O 10.10.10.0 /24

But i don't see anything....

I must do a redistribute static on router R2

to see on R1 the route 10.10.10.0/24...

Do i miss something....

Thanks for your help.

Vincent.

19 REPLIES
New Member

Re: automatic redistribute static route that point on a serial..

At the end of what you posted is says: "if you define a static route to an interface that is not in one of the networks defined in a network command, no dynamic routing protocols will advertise the route unless a redistribute static command is specified for these protocols..."

so if that is correct, you need to add 'network 172.16.1.0 0.0.0.255 area 1', right?

New Member

Re: automatic redistribute static route that point on a serial..

Yes, you are right.

So the R2 is in fact :

router ospf 1

network 192.168.1.0 0.0.0.255 area 1

network 10.10.10.0 0.0.0.255 area 1

network 172.16.1.0 0.0.0.3 area 1

But the problem is still active on R1 :

R1>sho ip route

C 192.168.1.0 is directly connected, Ethernet0

172.16.0.0 255.255.255.255 is subnetted, 1 subnets

O 172.16.1.1 [110/11] via 192.168.1.2, 00:06:00, Ethernet0

New Member

Re: automatic redistribute static route that point on a serial..

The mistake is that network 10.10.10.0 is not directly connected to the R2 inorder to advertise it directly into the ospf

so u should remove the line "network 10.10.10.0 0.0.0.255 area 1"

and put this line

"redistribute static"

New Member

Re: automatic redistribute static route that point on a serial..

In fact no. The text well precise that you don't need to put the command line "redistribute static" :

"Static routes that point to an interface will be advertised using RIP,

IGRP, and other dynamic routing protocols, regardless of whether

redistribute static commands were specified for those routing protocols."

And when you make a "show ip route" on R2 you see

that the network 10.10.10.0/24 is directly connected with the static flag but... :

R2#sho ip route

10.0.0.0 255.255.255.0 is subnetted, 1 subnets

S 10.10.10.0 is directly connected, Serial0

Vincent.

New Member

Re: automatic redistribute static route that point on a serial..

Remove the "network 10.10.10.0 0.0.0.255 area 1" from R2 (without redistribute static)

New Member

Re: automatic redistribute static route that point on a serial..

yes, i have already tried this

solution also....

In fact perhaps it's only a big bug

from CISCO...

New Member

Re: automatic redistribute static route that point on a serial..

I would say it's a documentation error. If I hadn't read anything I would have do it as aammar said from the start.

New Member

Re: automatic redistribute static route that point on a serial..

Manuel

I haven't had a chance to do OSPF since we don't use it, but it is true in OSPF, area 0 must be defined? I didn't see area 0 under router ospf

New Member

Re: automatic redistribute static route that point on a serial..

Hi.

If you have a network running OSPF with 1 area only, that area doesn't need to be area 0. However it's a good practice to use area 0 even if you have 1 area only, because if in the future you want to add some more areas, area 0 must exist in order to have connectivty between all areas.

Rgds.

NM

New Member

Re: automatic redistribute static route that point on a serial..

I agree with you to have

an area 0 with OSPF. In fact in my case

it was just a test, then i put area 0

to see if the beheviour of the router still

the same and this this the case.

I try also with RIPE, and it's work...

I imagine that in fact it's not work with all

kind of dynamic routing...

I will try with EIGRP just in case....

I adevertise you about the result.

Gold

Re: automatic redistribute static route that point on a serial..

All dynamic routing treat a static to an interface as a connected, and will pick them up through a network command.

:-)

Russ

New Member

Re: automatic redistribute static route that point on a serial..

Hi man,

i would like to be agree with you, but

it's not the case.

I think you have never try to test this.

Just do with OSPF and you see that it doesn't work.

Best regards.

Vincent.

Gold

Re: automatic redistribute static route that point on a serial..

I'm talking to one of the coders about this now--and it should work. I'm not certain why it's not.

:-)

Russ

Cisco Employee

Re: automatic redistribute static route that point on a serial..

not if you have only a single area.

Area 0 is required if you want more than 1 area.

Also, not every router needs to be attached to the area 0

New Member

Re: automatic redistribute static route that point on a serial..

True. But, both routers are communicating in area 1 (Intra-Area) so area 0 is not needed in this case. Inter-area communications requires Area 0 or a virtual link to an area 0 ABR.

I would remove the Network 10.x.x.x statement and do the redistribute connected as has already been pointed out. It will then show up on R1 as an OSPF external route - (type E2??).

I think the issue with dynamic routing protocols advertising connected type routes in the manner described applies to the distance vector protocols (Rip & IGRP) as indicated. I've never tested this theory though.

Cisco Employee

Re: automatic redistribute static route that point on a serial..

what software version are you using ?

OSPF used be different from Rip/IGRP in regards of static route to interface.

A lot of things changed with the latest version.

Gold

Re: automatic redistribute static route that point on a serial..

I just tried 12.2(9.4)T, and it doesn't seem to be working there.... I'll have to play with it some more--we might need to file a defect on it. We should definitely be picking these routes up.

:-)

Russ

New Member

Re: automatic redistribute static route that point on a serial..

Hi all guys,

I would to make a special thanks for all

of you on this case.

Thanks taking some time to see what can be wrong.

But i think aloso like an other man here that perhaps,

OSPF doesn't have the same behavior than RIP or IGRP

in this kind of context...

Vincent.

Gold

Re: automatic redistribute static route that point on a serial..

Okay-after looking through the code, and talking to one of the coders about it, it turns out that this is a documentation bug. OSPF will not pick up statics to interfaces through a network statement. You should contact the TAC and get a case opened/bug filed to change the documentation in this case.

:-)

Russ

210
Views
0
Helpful
19
Replies
CreatePlease to create content