Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Aux to Aux Port Config Problems

Hello all,

my problem in theory is simple but I cannot explain the reason for this failing. I am testing an aux to aux port remote connectivity using identical US Robotics 56k voice fax modems on either side. The routers being used are X2 Cisco 2501's

There are no dip switch settings on this modem. What happens is I plug a telephone in the phone jack of modem & dial the other remote modem. The remote modem receives the call but refuses to answer. I also created a chat script obtained from www.cisco.com that first factory defaults the modem & then adds the req'ed strings.

I am at my wits ends (been trying to resolve this from Tuesday) & would appreciate any assistance, configs etc ...

Regards

Lincoln

8 REPLIES

Re: Aux to Aux Port Config Problems

Have you already checked that the modems are anwering?

It sounds to me like you have this setup in a lab environment.

It may be the case that your modems are not detecting the ring signal from the telephone exchange system. Sounds unbelievable? I have seen this happen more often than not when connecting to a non-public phone system.

Possible reasons for this are: Frequency mismatch of the ring signal, modem expects 50Hz, gets 60Hz.

Modem does not react on an external ring signal. This is often a dual ring (on for 0,4s, off 0,2s, on 0,4s) with the same duration as an internal ring-signal (on for 1,0s)

Voltage issues: Incoming ring voltage is too low. On a PABX these voltages are often lower than those from a public phone line.

To check this, watch the RI (Ring Indicator) signal toggle when a call arrives or check the Rx input for the character string: RING. Which one applies for you depends on your configuration.

Goodluck!

New Member

Re: Aux to Aux Port Config Problems

Hi, one line is public & the other is an analogue extension. Originally it was the public line calling the analogue. I've reversed the lines & re-tested as you suggested but no luck - the modem still does not answer ...

Regards

Lincoln

Re: Aux to Aux Port Config Problems

Ok then I would suggest that you confirm that the modem is giving the proper signalling upon an incoming call.

This can be achieved by observing RI (pin 22) or the modem transmitting the RING singnal to the router.

Only after you have confirmed that your modems are working as they should, and excluded cabling issues, you can dive into the configs etc.

Silver

Re: Aux to Aux Port Config Problems

At the risk of belaboring the obvious, you have verified that the modem being called is configured to auto answer? In the modem, "S" register zero configures how many rings to wait before answering the phone, a value of zero disables auto answer. Keep in mind that it is not enough just to see an "S0=2" in the setup string. Depending upon the modem, settings in the same command line as a command not recognized by the modem may be ignored, as may any commands sent immediately after a reset.

Good luck and have fun!

Vincent C Jones

www.networkingunlimited.com

New Member

Re: Aux to Aux Port Config Problems

Ok, being a test environment, I've done a 'debug all' & noticed that the router is doing a discovery for the modem although a modem cap entry has been

created.

I've tested both modems & lines & can confirm that they can both dial-out &

receive a call (tested using our Shiva dial-back server). When I call the remote

modem the 'AA' & 'SD' lights of the remote modem flicker. How else can I

confirm that both modems are sending/receiving the proper signalling. I have

ruled out the cables & modems with my test & am leaning towards the config.

A note about the routers & config - both routers are cisco 2501's & are running

ios 11.1

Regards

Lincoln

Bronze

Re: Aux to Aux Port Config Problems

Lincoln,

Do you have the aux 0 line of the receiving router set for "autoselect ppp"?

Mark

New Member

Re: Aux to Aux Port Config Problems

Hi,

yes - the 'autoselect ppp' parameter has been configured on the AUX 0 line.

There is a senior networking tech that is very comfortable with modems. He

is back in the office on Monday. I will ask him on Monday/Tuesday & will let

you know how this problem was resolved. Thanks to all of you for taking the

time to help ...

Regards

Lincoln

New Member

Re: Aux to Aux Port Config Problems

Hi,

thanks to all of you for the assistance. I managed to find the problem & got this working (script reset parameter on the line aux 0). Attached are the configs of both routers. Better still is when I swopped the calling router with a GPRS unit it worked without any config changes.

The only odd aspect is that my chat-script is not being used but the routers default (does not make sense as this only worked when I changed script reset parameter). I am also using different routers (2610 for calling & 3640 for receiving).

Calling Router

sh run

Building configuration...

Current configuration:

!

version 12.0

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname CPX

!

aaa new-model

aaa authentication login default local

aaa authentication login NO_AUTHEN none

aaa authentication ppp default local

!

username ICC password 0 a

username CPX password 0 a

!

ip subnet-zero

!

chat-script Dialout ABORT ERROR ABORT BUSY " " "AT" OK "ATDP \P" TIMEOUT 45 CONNECT \C

modemcap entry USR:MSC=&FS0=1&C1&D0&H1&R2&B1&M4&K1&M0

modemcap entry USSR:MSC=AT&FS0=1&C1&D2&H1&R2&N14&B1&W

!

process-max-time 200

!

interface Loopback0

ip address 172.16.1.1 255.255.255.0

no ip directed-broadcast

!

interface Ethernet0/0

no ip address

no ip directed-broadcast

shutdown

!

interface Serial1/0

no ip address

no ip directed-broadcast

no ip mroute-cache

shutdown

no fair-queue

no ignore-hw local-loopback

!

interface Async65

ip unnumbered Loopback0

no ip directed-broadcast

encapsulation ppp

dialer in-band

dialer idle-timeout 214000

dialer watch-disable 60

dialer map ip 0.0.0.0 name ICC broadcast 0315606314

dialer map ip 172.16.1.2 name ICC broadcast 0315606314

dialer watch-group 8

dialer-group 1

async default routing

async mode dedicated

no fair-queue

ppp authentication chap

!

router eigrp 1

network 172.16.0.0

no auto-summary

!

ip classless

no ip http server

!

dialer watch-list 8 ip 192.1.1.0 255.255.255.0

dialer-list 1 protocol ip permit

!

line con 0

transport input none

line aux 0

exec-timeout 0 0

autoselect ppp

script reset Dialout

modem InOut

modem autoconfigure type USSR

transport input all

stopbits 1

flowcontrol hardware

line vty 0 4

!

!

end

CPX#

Called Router

sh run

Building configuration...

Current configuration : 2186 bytes

!

version 12.1

no service single-slot-reload-enable

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname ICC

!

logging rate-limit console 10 except errors

aaa new-model

aaa authentication login default local

aaa authentication login NO_AUTHEN none

aaa authentication ppp default local

!

username ICC password 0 a

username CPX password 0 a

memory-size iomem 15

ip subnet-zero

!

no ip finger

!

ip audit notify log

ip audit po max-events 100

modemcap entry USR:MSC=&FS0=1&C1&D0&H1&R2&B1&M4&K1&M0

!

interface Loopback0

ip address 172.16.1.2 255.255.255.0

!

interface BRI0/0

no ip address

shutdown

!

interface Ethernet0/0

no ip address

shutdown

half-duplex

!

interface Serial1/0

no ip address

shutdown

!

interface Async129

ip unnumbered Loopback0

encapsulation ppp

dialer in-band

dialer idle-timeout 214000

dialer map ip 0.0.0.0 name CPX broadcast

dialer map ip 172.16.1.1 name CPX broadcast

dialer-group 1

async default routing

async mode dedicated

no peer default ip address

ppp authentication chap

!

router eigrp 1

network 172.16.0.0

no auto-summary

no eigrp log-neighbor-changes

!

ip classless

no ip http server

!

dialer-list 1 protocol ip permit

!

line con 0

transport input none

line aux 0

autoselect ppp

modem InOut

modem autoconfigure type USR

transport input all

stopbits 1

speed 115200

flowcontrol hardware

line vty 0 4

!

end

ICC#

Regards

Lincoln

235
Views
0
Helpful
8
Replies
CreatePlease to create content