Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements
Webcast-Catalyst9k
New Member

Back to the basics... PING

Ok...I have a default configuration on a Cisco 2620 with the FE port configured as IP address 10.10.10.1/24. I've connected my laptop with a x-over cable to the router eth port. My laptop is 10.10.10.2/24 and gateway 10.10.10.1/24. Why am I unable to ping the router from the PC and vice-versa? I've tried multiple cables, different routers and different PCs and I still can't get a ping. A show arp will resolve the PC as well. What am I missing here? Duplex/speed on both are set to auto.

11 REPLIES
Blue

Re: Back to the basics... PING

is the e0 interface in 'shutdown' mode?

send a display of your config; will help us a bit more....keep all sensative ip addys out.

if the interface is not shutdown, monitor the console while you unplug and replug in the ethernet xOver cable. you should see the interface protocol go up/down and vice versa.

if no link, try another cable.

Hall of Fame Super Gold

Re: Back to the basics... PING

In addition to Greg's suggestion about posting the config (which is an excellent suggestion) I would ask for the output of show interface from the router.

Is there any possibility of mismatch in interface speed or duplex setting between the router and the PC? Also I would suggest that you double check the config of the router and of the PC looking for any possible mismatches in config (keystroke errors, reversed digits, etc). Do the config of router and PC put them both in exactly the same subnet (address and mask are important, default gateway not so important at this point).

HTH

Rick

New Member

Re: Back to the basics... PING

Ok...I've doubled check everything and changed the IP scheme as well...not that it should matter. The link LEDs on the router are lit (Link, FDX, 100). Here is the config, sho int, sho arp and ping results.

Using 671 out of 29688 bytes

!

version 12.2

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname router

!

no logging console

enable secret xxxx

enable password cisco1

!

ip subnet-zero

!

!

!

ip audit notify log

ip audit po max-events 100

!

!

!

interface FastEthernet0/0

ip address 192.168.254.1 255.255.255.0

duplex auto

speed auto

!

interface Serial0/0

no ip address

shutdown

!

interface Serial0/1

no ip address

shutdown

!

interface Serial1/0

no ip address

shutdown

!

interface Serial1/1

no ip address

shutdown

!

line con 0

line aux 0

line vty 0 4

password cisco

login

!

end

FastEthernet0/0 is up, line protocol is up

Hardware is AmdFE, address is 0003.e383.0de0 (bia 0003.e383.0de0)

Internet address is 192.168.254.1/24

MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation ARPA, loopback not set

Keepalive set (10 sec)

Full-duplex, 100Mb/s, 100BaseTX/FX

ARP type: ARPA, ARP Timeout 04:00:00

Last input 00:03:32, output 00:00:08, output hang never

Last clearing of "show interface" counters never

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: fifo

Output queue: 0/40 (size/max)

5 minute input rate 0 bits/sec, 0 packets/sec

5 minute output rate 0 bits/sec, 0 packets/sec

10 packets input, 1482 bytes

Received 9 broadcasts, 0 runts, 0 giants, 0 throttles

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

0 watchdog

0 input packets with dribble condition detected

72 packets output, 6598 bytes, 0 underruns

0 output errors, 0 collisions, 0 interface resets

0 babbles, 0 late collision, 0 deferred

0 lost carrier, 0 no carrier

0 output buffer failures, 0 output buffers swapped out

router#sho arp

Protocol Address Age (min) Hardware Addr Type Interface

Internet 192.168.254.2 4 0014.22c7.f0c8 ARPA FastEthernet0/0

Internet 192.168.254.1 - 0003.e383.0de0 ARPA FastEthernet0/0

router#ping 192.168.254.2

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 192.168.254.2, timeout is 2 seconds:

.....

Success rate is 0 percent (0/5)

router#

Hall of Fame Super Gold

Re: Back to the basics... PING

James

Thanks for posting the additional information. The config is pretty straightforward and does not seem to have any issues. The show interface looks quite normal and the show arp is convincing proof that at least at layer 2 the router and the PC are communicating.

Is there any possibility that there is a personal firewall running on the PC which is stopping the ping?

Can you do debug ip icmp, attempt ping from the PC to the router, and post any output? (This should demonstrate whether the ping from the PC gets to the router)

HTH

Rick

New Member

Re: Back to the basics... PING

I went ahead and enabled ICMP debugging, however, I did not receive any debugging messages. I don't have any personal firewalls running on my PC and checked all Services that might disallow ICMP. I am able to ping the IP of my NIC from a DOS prompt without any issues and I've been using this laptop to troubleshoot LAN issues and have never had a problem receiving ICMP. Very strange. Unless the Eth port on the router is bad, but I've had this happen on a number of occasions with different routers.

New Member

Re: Back to the basics... PING

I have two suggestions:

1)Erase the router config then reload & start from scratch.

2)It appears that your fa0/0 negotiated to "Full-duplex, 100Mb/s, 100BaseTX/FX", might want to hard code your pc to 10mb or 100mb as well as hard code the router. Your pc/router might not like "auto".

New Member

Re: Back to the basics... PING

clear your interface stats.

debug ip packet

ping from the router

ping from the laptop

Look at the debug output.

Look at interface stats

arp -a on the laptop.

ipconfig on the laptop (assuming windows)

If all was working you should see at least 10 input packets, probably 11 if the arp entry is not in the cache.

Such a case is why, I say "Allways expect the unexpected when working on networks." In my experiance something always crops up that makes it take longer than expected to get working.

New Member

Re: Back to the basics... PING

Hmm... firewall setting on your PC? Is ICMP blocked?

New Member

Re: Back to the basics... PING

the ethernet port of router is 192.168.254.1/24 your laptop is 10.10.10.2/24 ?change ip address on laptop to 192.168.254.2 255.255.255.0 so you are on the same network

New Member

Re: Back to the basics... PING

laptop and ethernet not on same network change laptop to 192.168.254.2 255.255.255.0 and try ping

Re: Back to the basics... PING

Hi,

FE port configured as IP address 10.10.10.1/24

interface FastEthernet0/0

ip address 192.168.254.1 255.255.255.0

See the mismatch in IP's u had given.

My laptop is 10.10.10.2/24 and gateway 10.10.10.1/24

i dont see any of the 10 N/W IP in your router configuration. Both are in different network.

Laptop in Class A and Router in Class C network. Change both to same Class and try pinging.

Regards,

Guru Prasad.R

285
Views
0
Helpful
11
Replies
CreatePlease to create content