Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. If you'd prefer to explore, try our test area to get started. And see here for current known issues.

New Member

Back up Route FAILS

I have no idea whats going on here. There are 4 routers involved, the main router configs are as follows and the others I have attached. I Need the router named Tower to redirect traffic back down the serial interface to the router named JCWAtoDowntown. The problem is the JCWAtoTower Router is in the way and redirects the traffic back to the tower when it receives the traffic from the tower because that is it's default gateway. What needs to happen to make the JCWAtoTower router redirect the traffic coming back from the tower and put it to the JCWAtoDowntown router.

version 12.2

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname JCW

!

enable secret xxxx

!

memory-size iomem 25

ip subnet-zero

no ip domain-lookup

ip name-server x.x.x.x

ip name-server x.x.x.x

!

interface Tunnel1

no ip address

!

interface FastEthernet0

ip address 10.6.18.4 255.255.255.0

speed auto

!

interface Serial0

ip address 192.168.101.2 255.255.255.0

no fair-queue

service-module t1 clock source internal

service-module t1 timeslots 1-24

!

interface Serial1

ip address 192.168.100.4 255.255.255.0

ip accounting output-packets

no fair-queue

service-module t1 clock source internal

service-module t1 timeslots 1-24

!

router rip

network 10.0.0.0

network 192.168.100.0

network 192.168.101.0

default-information originate

!

ip classless

ip forward-protocol udp 5631

ip forward-protocol udp 5632

ip route 0.0.0.0 0.0.0.0 192.168.100.1

ip http server

!

arp 10.6.18.5 00c0.b607.d30b ARPA

!

line con 0

logging synchronous

line aux 0

line vty 0 4

session-timeout 60

------------------------------------------------------------------------------------------

Gateway of last resort is 192.168.100.1 to network 0.0.0.0

R 69.0.0.0/8 [120/2] via 10.6.18.2, 00:00:00, FastEthernet0

R 192.168.104.0/24 [120/1] via 10.6.18.2, 00:00:00, FastEtherne

t0

R 67.0.0.0/8 [120/2] via 192.168.100.1, 00:00:05, Serial1

10.0.0.0/24 is subnetted, 1 subnets

C 10.6.18.0 is directly connected, FastEthernet0

R 192.168.0.0/24 [120/1] via 192.168.101.1, 00:00:09, Serial0

R 192.168.1.0/24 [120/1] via 192.168.100.1, 00:00:05, Serial1

C 192.168.100.0/24 is directly connected, Serial1

C 192.168.101.0/24 is directly connected, Serial0

S* 0.0.0.0/0 [1/0] via 192.168.100.1

5 REPLIES

Re: Back up Route FAILS

Hello,

IP routing will take the longest match - i.e. most specific entry - in the IP routing table to determine, where to send an IP packet. In case you want some traffic not to follow the default route, you need to create a more specific entry in the iP routing table. This can f.e. be done by configuring a static route.

So to solve your problem you should specify which traffic (destination network) should be sent to which router. You did not mention any specific network, but in case you add the information we will be able to help you.

Regards, Martin

New Member

Re: Back up Route FAILS

The default route for the 10.6.18.2(JCWAtoTower) is 192.168.104.1 (Tower) and it has a 2nd default route to 10.6.1.8.4 (JCWAtoDowntown) with a metric of 2.

If I shut off the S0 int on 10.6.18.2 the traffic redirects just fine,

On the Tower router there is a default route of 69.146.108.57 and a 2nd route 10.6.18.4 with a metric of 2, the problem is at the tower, when I shut off the Fa0 interface(internet) the traffic redirects to the JCWAtoTower router (the next router in line) and instead of passing through to the 10.6.18.4 (JCWAtoDowntown) Router it puts the traffic back to the tower because thats the default route. How can I get the JCWAtoTower router to recognize that the internet interface at the tower has gone down to allow the redirected traffic to now go to the 10.6.18.4 router?

Thanks in advance for your help and any configs.

Purple

Re: Back up Route FAILS

Hey Dale,

Did you try injecting the defaults into RIP as I mentioned in my response to your earlier post ?

Paresh

New Member

Re: Back up Route FAILS

Paresh,,

Actually , no I didn't. Could you shoot me the configs on how to do that.

Not sure what that would do exactly, All the routes already show up in the show ip route command.

Thanks

Dale

New Member

Re: Back up Route FAILS

In case anybody cares I figured out the solution to this problem. The answer was to make the default gateway of the 10.6.18.2 router 69.146.108.59 (the outside interface of the Tower router) that way when that interface went down the .2 router brought up the second route.

Thanks for all teh suggestions, it at least got me going in the right direction

201
Views
0
Helpful
5
Replies