Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Announcements

Welcome to Cisco Support Community. We would love to have your feedback.

For an introduction to the new site, click here. And see here for current known issues.

New Member

backup ddr link is being brought up, can't work out why

Here is my router config

Version 12.0

service timestamps debug datetime

service timestamps log datetime

no service password-encryption

service udp-small-servers

service tcp-small-servers

!

hostname remoterouter

!

aaa new-model

aaa authentication login default group tacacs+ local

aaa authentication ppp default local

aaa authorization exec default group tacacs+

aaa accounting exec default start-stop group tacacs+

aaa accounting network default start-stop group tacacs+

enable secret 5 xxxxxxxxxxxxxxxx

enable password xxxxxxxx

!

username master password 7 xxxxxxxxxxxxxx

username siterouter password 7 xxxxxxxxxxxxxx

!

!

clock timezone gmt 0

clock summer-time bst recurring last Sun Mar 2:00 last Sun Oct 2:00

ip subnet-zero

!

isdn switch-type basic-net3

isdn voice-call-failure 0

isdn tei-negotiation first-call

!

!

interface Loopback0

no ip address

no ip directed-broadcast

!

interface Ethernet0

ip address 10.28.0.1 255.255.252.0

ip helper-address 10.2.44.200

no ip directed-broadcast

keepalive 4

!

interface Serial0

description Frame-Relay Link

bandwidth 64

ip address 10.1.16.2 255.255.252.0

no ip directed-broadcast

encapsulation frame-relay

no ip route-cache

no ip mroute-cache

no fair-queue

frame-relay map ip 10.1.16.1 100 broadcast

frame-relay lmi-type ansi

!

interface Serial1

no ip address

no ip directed-broadcast

shutdown

!

interface BRI0

description dial backup link

bandwidth 56

no ip address

no ip directed-broadcast

encapsulation ppp

no ip route-cache

no ip mroute-cache

no keepalive

dialer pool-member 1

isdn switch-type basic-net3

no fair-queue

no cdp enable

!

interface Dialer0

ip address 10.2.176.10 255.255.255.0

no ip directed-broadcast

encapsulation ppp

dialer remote-name siterouter

dialer pool 1

dialer idle-timeout 90

dialer string 01xxxxxxxx

dialer-group 1

no fair-queue

no cdp enable

ppp authentication chap

ppp multilink

!

interface Dialer1

no ip address

no ip directed-broadcast

no cdp enable

!

router eigrp 1

network 10.0.0.0

network 144.98.0.0

no auto-summary

!

ip classless

no ip forward-protocol udp tftp

no ip forward-protocol udp nameserver

no ip forward-protocol udp domain

no ip forward-protocol udp time

no ip forward-protocol udp netbios-ns

no ip forward-protocol udp netbios-dgm

no ip forward-protocol udp tacacs

ip route 10.0.0.0 255.0.0.0 10.2.176.1 200

no ip http server

!

logging trap debugging

access-list 101 deny eigrp any any

access-list 101 permit ip any any

dialer-list 1 protocol ip list 101

!

tacacs-server host 10.2.44.208

tacacs-server host 10.2.44.206

tacacs-server timeout 1000

tacacs-server key cisco

snmp-server engineID local 00000009020000E01E3E7080

snmp-server community public xxxx!

line con 0

transport input none

line aux 0

password cisc0

no activation-character

modem InOut

stopbits 1

flowcontrol hardware

line vty 0 4

password xxxxxxx

!

ntp clock-period 17179532

ntp server 144.98.xx.xx

end

remoterouter#sh ver

Cisco Internetwork Operating System Software

IOS (tm) 2500 Software (C2500-P-L), Version 12.0(7)T, RELEASE SOFTWARE (fc2)

Copyright (c) 1986-1999 by cisco Systems, Inc.

Compiled Mon 06-Dec-99 19:39 by phanguye

Image text-base: 0x0303C3D4, data-base: 0x00001000

ROM: System Bootstrap, Version 11.0(10c), SOFTWARE

BOOTFLASH: 3000 Bootstrap Software (IGS-BOOT-R), Version 11.0(10c), RELEASE SOF)

remoterouter uptime is 2 days, 18 hours, 35 minutes

System returned to ROM by power-on

System restarted at 15:37:54 bst Fri Jul 26 2002

System image file is "flash:c2500-p-l.120-7.T.bin"

cisco 2500 (68030) processor (revision N) with 6144K/2048K bytes of memory.

Processor board ID 06099777, with hardware revision 00000001

X.25 software, Version 3.0.0.

Basic Rate ISDN software, Version 1.1.

1 Ethernet/IEEE 802.3 interface(s)

2 Serial network interface(s)

1 ISDN Basic Rate interface(s)

32K bytes of non-volatile configuration memory.

8192K bytes of processor board System flash (Read ONLY)

Configuration register is 0x2102

I have been having problems with the bri interface being brought up for reasons i can't work out. I noticed that if i ping an ip address the bri interface stays down but if i traceroute to the same ip then the bri interface comes up:

Dial String Successes Failures Last DNIS Last status

0 incoming call(s) have been screened.

0 incoming call(s) rejected for callback.

BRI0:1 - dialer type = ISDN

Idle timer (90 secs), Fast idle timer (20 secs)

Wait for carrier (30 secs), Re-enable (15 secs)

Dialer state is data link layer up

Dial reason: ip (s=10.2.176.10, d=255.255.255.255)

Interface bound to profile Dialer0

Time until disconnect 80 secs

Current call connected 00:00:43

Connected to 0xxxxxxx (siterouter)

If i do a show ip route for the destination ip it shows the serial interface as i would expect:

sh ip route 10.2.44.200

Routing entry for 10.2.44.0/22

Known via "eigrp 1", distance 90, metric 40514304, type internal

Redistributing via eigrp 1

Last update from 10.1.16.1 on Serial0, 00:27:42 ago

Routing Descriptor Blocks:

* 10.1.16.1, from 10.1.16.1, 00:27:42 ago, via Serial0

Route metric is 40514304, traffic share count is 1

Total delay is 20090 microseconds, minimum bandwidth is 64 Kbit

Reliability 255/255, minimum MTU 1500 bytes

Loading 75/255, Hops 2

why does the router send a broadcast via the bri interface when i traceroute?

debug dialer packet shows following:

Jul 29 09:23:33: Dialer0 DDR: ip (s=10.2.176.10, d=255.255.255.255), 68 bytes, outgoing interesting (list 101)

Any further data needed then please let me know.

3 REPLIES
Cisco Employee

Re: backup ddr link is being brought up, can't work out why

It looks like the BRI interface is brought up by the routing protocol. You can either put the BRI interface in backup state using the backup command under the appropriate serial int erface or make sure EIGRP is not enabled on that BRI interface.

Silver

Re: backup ddr link is being brought up, can't work out why

Except for two things...

1 - EIGRP uses multicast, not broadcast, and is denied in access-list 101.

2 - Does not explain why traceroute triggers the call and ping does not (assuming original question is accurate).

I don't see anything obvious in the information provided, other than the use of 12.0(7)T IOS, which is full of bugs. This could be one of them.

Vincent C Jones

www.networkingunlimited.com

New Member

Re: backup ddr link is being brought up, can't work out why

i'll try a newer ios as it doesn't make a lot of sense. thanks for the input.

81
Views
0
Helpful
3
Replies
CreatePlease login to create content