Cisco Support Community
cancel
Showing results for 
Search instead for 
Did you mean: 
New Member

Backup Interface Cannot Trigger

I have configured my Cisco 1720 Router with a primary Serial interface and a

dialer profile tied to a BRI as a backup interface. I am using both the backup load and backup delay commands on the primary Serial interface, to trigger the bri in event of excess traffic load and primary line failure, however the backup interface never seems to trigger, even though I've set a very low threshold for traffic load on the primary interface. Is it possible that the backup

load command only works with similar interfaces? Need help..

thanks

11 REPLIES
New Member

Re: Backup Interface Cannot Trigger

Hi,

here is a sample configuration which should work.

interface Serial0/0

bandwidth 128

backup interface Dialer2

backup load 60 40

no ip address

interface Bri0/0

description *** ***

no ip address

no ip directed-broadcast

encapsulation ppp

dialer pool-member 2

isdn switch-type basic-net3

no cdp enable

ppp authentication chap

!

!

interface Dialer2

description *** BoD ***

bandwidth 64

ip address 10.65.65.10 255.255.255.252

no ip directed-broadcast

encapsulation ppp

dialer remote-name bod_location_b

dialer string 0511...

dialer load-threshold {1-255} {outbound | inbound | either}

dialer pool 2

dialer-group 2

ppp authentication chap

ppp chap hostname bod_loaction_a

ppp multilink

I the dialer-list you should enable ip any any first, to check if it is working.

Check also with the "debug dialer" command if the ISDN tries to establish

a call, maybe you have a problem with ISDN. If it is fitting in your flash

memory, take at least IOS version 12.2(7) or higher for ISDN.

Hope this will help

regards Ulrich Marzoli

www.netaid.de

New Member

Re: Backup Interface Cannot Trigger

thankx for the input ulrich,

tried ur sample config but was still unsuccessful, the backup interface will trigger only if the primary interface fails , but never when traffic exceeds the maximum load specified, the following is my router config. I even did a debug isdn, but saw zero isdn activity.Could it be because I am using a sub interface for my primary serial frame relay link?

any ideas?...

thanx again

sh ru

Building configuration...

Current configuration:

!

version 12.1

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname BT9_RT1720_01

!

!

username KJG_RT3640_01

username RG_Kuala_Lumpur

!

!

!

!

memory-size iomem 15

clock timezone SGT 8

ip subnet-zero

no ip domain-lookup

no ip dhcp conflict logging

ip dhcp excluded-address 10.31.34.1 10.31.34.19

ip dhcp excluded-address 10.31.34.51 10.31.34.126

!

ip dhcp pool bt9

network 10.31.34.0 255.255.255.128

default-router 10.31.34.1

dns-server 10.31.29.10 10.0.8.1

domain-name kjg

lease 365

!

isdn switch-type basic-net3

!

!

!

interface Loopback0

ip address 202.178.62.21 255.255.255.0

!

interface Loopback1

ip address 10.10.10.10 255.255.255.255

!

interface Serial0

bandwidth 32

backup delay 1 300

backup interface Dialer1

backup load 30 10

no ip address

encapsulation frame-relay IETF

no fair-queue

frame-relay class bt9

frame-relay lmi-type ansi

!

interface Serial0.1 point-to-point

description KK Batu 9 Cheras_Hulu Langat to Hospital Kajang

ip address 202.178.63.34 255.255.255.252

ip ospf message-digest-key 10 md5 7 0524222C7067642E4B

frame-relay interface-dlci 41

!

interface BRI0

no ip address

encapsulation ppp

dialer pool-member 1

dialer pool-member 2

isdn switch-type basic-net3

no cdp enable

ppp authentication chap

!

interface FastEthernet0

ip address 10.31.34.1 255.255.255.128

speed auto

!

interface Dialer1

bandwidth 128

ip unnumbered Loopback0

encapsulation ppp

dialer remote-name KJG_RT3640_01

dialer pool 1

dialer idle-timeout 1800

dialer string 87321292

dialer load-threshold 200 either

dialer-group 1

no cdp enable

ppp authentication chap

ppp chap hostname BT9_RT1720_01

ppp multilink

!

interface Dialer2

ip unnumbered Loopback1

encapsulation ppp

dialer remote-name RG_Kuala_Lumpur

dialer pool 2

dialer idle-timeout 20

dialer string 20529946

dialer-group 1

ppp authentication chap

!

router ospf 2

log-adjacency-changes

area 2 authentication message-digest

area 2 nssa

passive-interface BRI0

passive-interface Dialer1

network 10.31.34.0 0.0.0.127 area 2

network 202.178.63.32 0.0.0.3 area 2

ip classless

ip route 0.0.0.0 0.0.0.0 Dialer1 200

no ip http server

map-class frame-relay bt9

frame-relay traffic-rate 32000 64000

no frame-relay adaptive-shaping

frame-relay priority-group 1

logging 202.178.0.98

logging 202.178.10.10

logging 10.0.11.8

priority-list 1 protocol ip high

dialer-list 1 protocol ip permit

!

end

BT9_RT1720_01#

rgds,

shahrun

http://www.medical-online.net

Silver

Re: Backup Interface Cannot Trigger

You must have a functional dialer configuration before "backup interface" can use it. To test, delete the "backup interface" command and see if the dialer activates (the only thing which should stand between the dialer and a backup call should be the "backup interface" command disabling the dialer.

Warning note: removing the backup interface line will also delete all other backup parameters on the interface, so you'll need to add everything back once you get the dialer working correctly.

If you need help finding your configuration error, try posting a sanitized version of your configuration. There are examples of working configurations on www.cisco.com and in the "Listings from my book" section of my website. See in particular Listing 4-4.

Good luck and good hunting!

Vincent C Jones

www.networkingunlimited.com

New Member

Re: Backup Interface Cannot Trigger

thankx for the input guys,

tried ur sample config but was still unsuccessful, the backup interface will trigger only if the primary interface fails , but never when traffic exceeds the maximum load specified, the following is my router config. I even did a debug isdn, but saw zero isdn activity.Could it be because I am using a sub interface for my primary serial frame relay link?

any ideas?...

thanx again

sh ru

Building configuration...

Current configuration:

!

version 12.1

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname BT9_RT1720_01

!

!

username KJG_RT3640_01

username RG_Kuala_Lumpur

!

!

!

!

memory-size iomem 15

clock timezone SGT 8

ip subnet-zero

no ip domain-lookup

no ip dhcp conflict logging

ip dhcp excluded-address 10.31.34.1 10.31.34.19

ip dhcp excluded-address 10.31.34.51 10.31.34.126

!

ip dhcp pool bt9

network 10.31.34.0 255.255.255.128

default-router 10.31.34.1

dns-server 10.31.29.10 10.0.8.1

domain-name kjg

lease 365

!

isdn switch-type basic-net3

!

!

!

interface Loopback0

ip address 202.178.62.21 255.255.255.0

!

interface Loopback1

ip address 10.10.10.10 255.255.255.255

!

interface Serial0

bandwidth 32

backup delay 1 300

backup interface Dialer1

backup load 30 10

no ip address

encapsulation frame-relay IETF

no fair-queue

frame-relay class bt9

frame-relay lmi-type ansi

!

interface Serial0.1 point-to-point

description KK Batu 9 Cheras_Hulu Langat to Hospital Kajang

ip address 202.178.63.34 255.255.255.252

ip ospf message-digest-key 10 md5 7 0524222C7067642E4B

frame-relay interface-dlci 41

!

interface BRI0

no ip address

encapsulation ppp

dialer pool-member 1

dialer pool-member 2

isdn switch-type basic-net3

no cdp enable

ppp authentication chap

!

interface FastEthernet0

ip address 10.31.34.1 255.255.255.128

speed auto

!

interface Dialer1

bandwidth 128

ip unnumbered Loopback0

encapsulation ppp

dialer remote-name KJG_RT3640_01

dialer pool 1

dialer idle-timeout 1800

dialer string 87321292

dialer load-threshold 200 either

dialer-group 1

no cdp enable

ppp authentication chap

ppp chap hostname BT9_RT1720_01

ppp multilink

!

interface Dialer2

ip unnumbered Loopback1

encapsulation ppp

dialer remote-name RG_Kuala_Lumpur

dialer pool 2

dialer idle-timeout 20

dialer string 20529946

dialer-group 1

ppp authentication chap

!

router ospf 2

log-adjacency-changes

area 2 authentication message-digest

area 2 nssa

passive-interface BRI0

passive-interface Dialer1

network 10.31.34.0 0.0.0.127 area 2

network 202.178.63.32 0.0.0.3 area 2

ip classless

ip route 0.0.0.0 0.0.0.0 Dialer1 200

no ip http server

map-class frame-relay bt9

frame-relay traffic-rate 32000 64000

no frame-relay adaptive-shaping

frame-relay priority-group 1

logging 202.178.0.98

logging 202.178.10.10

logging 10.0.11.8

priority-list 1 protocol ip high

dialer-list 1 protocol ip permit

!

end

BT9_RT1720_01#

New Member

Re: Backup Interface Cannot Trigger

Hi,

I think that you should configure the backup commands on your sub-interface.

Be aware that you are using fram-relay and when the PVC is down your interface could be up. So the router won't dailout.

Regards,

Mario

New Member

Re: Backup Interface Cannot Trigger

hi mario,

actually i tried the backup interface on the serial interface, and fail-over backup

kicked in, because it is tracking the line protocol(so even though the serial is up, the backup will trigger because line protocol is down). So, I have no problem with backup failover,just the traffic load backup. Also,

to do a backup load on the sub interface is not possible as the backup command only allows backup delay and backup interface options, and I am running IOS version 12.1.3.Is it possible with more recent versions?

thanx..

New Member

Re: Backup Interface Cannot Trigger

Hi,

just reviewed your configuration and I believe the problem is that you didn't

have included the Loopback network in the OSPF routing process. So in case

of the backupload is exceeded the ISDN will only establish a call when there

is interesting traffic but there is none, because you didn't have a route pointing

in direction of the dialer interface. The floating static default route only kicks

in when the leased line fails, that#s why the backup function works.

Including the Loopback network in the OSPF process will let open the ISDN

connection via the OSPF Hello packets, and than the OSPF routing updates

will advertise also all networks over ISDN.

You also should ensure that in case both connections are up (the serial and

the ISDN connection) that the metrics are equal and the sessions were

load-balanced over the serial and the ISDN connection otherwise it will not

be working properly.

regards Ulrich Marzoli

www.netaid.de

New Member

Re: Backup Interface Cannot Trigger

HI,

I've been searching on CCO and as far as i can found that there is no support for the "backup load" command on an sub-interface which is on a frame-relay encapsulation.

See the following URL:

http://www.cisco.com/en/US/customer/tech/tk713/tk237/technologies_configuration_example09186a0080094373.shtml

Regard,

Mario

New Member

Re: Backup Interface Cannot Trigger

hey mario,

that's right, no such command on a sub interface and there should'nt be any

with more recent versions...anyways..as ulrich advised, my problem was with

my loopback network route. but thanx all the same!

New Member

Re: Backup Interface Cannot Trigger

Hi ulrich,

thanx, for the advice, u were right about the ospf hello packets. I added in the loopback networks and the backup interface kicked off instantly. However, I am only seeing output traffic thru the backup interface, as most of the input traffic(which consumes the bandwidth most) keeps flowing thru the small frame relay pipe, even though I've set a similar metric for both routes. I suppose this is the standard nature in which backup load operates. I just

hope to able to tune the traffic flow so that the load is really balanced.

anyways thanx again for the helpful info

New Member

Re: Backup Interface Cannot Trigger

Hi,

I hope you have added the loopback interface on the other router as well to

the OSPF process, otherwise the router can not built an OSPF neighboring

and no route informations will be exchanged. Also the metric on the other router must be adjusted for load-balancing. Then all should work well.

regards Ulrich Marzoli

www.netaid.de

256
Views
0
Helpful
11
Replies
作成コンテンツを作成するには してください